Problem With Responsive Menu

shaulhadar
439 Posts
shaulhadar posted this 14 August 2014

Hello Themler Team.
When I work with a menu inside the header, in the responsive view, the responsive menu doesn't work good, and you can see that it doesn't push the content down when you open it. This is quite a problem, because this means that currently these types of designs can't be used with themeler. is there anything that can be done to fix that other than putting the menu some other place?

THanks,
Shaul.

Hello Themler Team. When I work with a menu inside the header, in the responsive view, the responsive menu doesn't work good, and you can see that it doesn't push the content down when you open it. This is quite a problem, because this means that currently these types of designs can't be used with themeler. is there anything that can be done to fix that other than putting the menu some other place? THanks, Shaul.

Last edited 19 August 2014 by Support Team

Vote to pay developers attention to this features or issue.
25 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 14 August 2014

Hello Shaul,

Is it the same issue that you posted in the other ticket? Does the issue persist with Chrome browser? Please provide a screenshot.

Hello Shaul, Is it the same issue that you posted in the other ticket? Does the issue persist with Chrome browser? Please provide a screenshot.
shaulhadar
439 Posts
shaulhadar posted this 14 August 2014

Hi, thanks for getting back to me.

Yes, its the same bug like last time... I have been checking the progress, and I saw there is a workaround if you put the menu in another column in the header, but my specific design incorporates the menu in the regular header, and that's were the bug occurs...

I have sent you two pictures, one of the desktop version, and one of the mobile one so you can see what I mean.

If you need any more information or to check anything, please let me know and i will be happy to help.

THanks for your time,
Shaul.

Hi, thanks for getting back to me. Yes, its the same bug like last time... I have been checking the progress, and I saw there is a workaround if you put the menu in another column in the header, but my specific design incorporates the menu in the regular header, and that's were the bug occurs... I have sent you two pictures, one of the desktop version, and one of the mobile one so you can see what I mean. If you need any more information or to check anything, please let me know and i will be happy to help. THanks for your time, Shaul.
Support Team posted this 14 August 2014

Hi,

In fact this is behavior by default. When the horizontal menu is located inside the header it has absolute position.
As the result it does not push the content down.
To fix the display problem you can try adding menu background for responsive modes. In this case you will not the other page content behind menu.

Thank you,
Olivia

Hi, In fact this is behavior by default. When the horizontal menu is located inside the header it has absolute position. As the result it does not push the content down. To fix the display problem you can try adding menu background for responsive modes. In this case you will not the other page content behind menu. Thank you, Olivia
shaulhadar
439 Posts
shaulhadar posted this 28 August 2014

I actually know this bug from artisteer, and i helped them fix it and test... what they did was in responsive mode, add a row in the top of the site, with the menu div inside, and than no matter where the menu was in the desktop version, in the responsive it was in a seperate div and didn't interfere with the header... maybe you can do something like this?
I tried doing it inside themeler, but i wasn't able to add a row with the menu to show only in the responsive modes, maybe there is a way to accomplish that? currently, this is one of the major flaws in the responsive modes from what i checked, other than that themeler is getting really tight, i like it :) you are doing a great job!!

Have a great day,
Shaul.

I actually know this bug from artisteer, and i helped them fix it and test... what they did was in responsive mode, add a row in the top of the site, with the menu div inside, and than no matter where the menu was in the desktop version, in the responsive it was in a seperate div and didn't interfere with the header... maybe you can do something like this? I tried doing it inside themeler, but i wasn't able to add a row with the menu to show only in the responsive modes, maybe there is a way to accomplish that? currently, this is one of the major flaws in the responsive modes from what i checked, other than that themeler is getting really tight, i like it :) you are doing a great job!! Have a great day, Shaul.
Support Team
Support Team posted this 28 August 2014

Hello

You can try to move the menu outside the Header and then move it on top of the header with negative margin.
This should help.

Thank you,
Olivia

Hello You can try to move the menu outside the Header and then move it on top of the header with negative margin. This should help. Thank you, Olivia
martin53
13 Posts
martin53 posted this 15 June 2015

Hello,

same problem here, mu mobile menu is in the backside (see image attached) i need it to be infront and push the slider and rest of the content down, can you help me?

Hello, same problem here, mu mobile menu is in the backside (see image attached) i need it to be infront and push the slider and rest of the content down, can you help me?
Support Team
Support Team posted this 16 June 2015

Hi,

Have you tried the suggestions provided by Olivia above? They should help you as well. In other case please provide a link to your theme.

Sincerely,
Hella
BillionDigital Team

Hi, Have you tried the suggestions provided by Olivia above? They should help you as well. In other case please provide a link to your theme. Sincerely, Hella BillionDigital Team
martin53
13 Posts
martin53 posted this 16 June 2015

Hello, here is the link to my theme, if you look at the menu in the mobile version you will see it roll behind the slider content, can you give me a solution, i dont quite understand Olivia's explanation (negative margin...), if you could show me with screen shuts?

http://184.107.208.178/~meuneriegsoucy/index.php

I also give you the site admin access on a private request.

Thanks
Martin

Hello, here is the link to my theme, if you look at the menu in the mobile version you will see it roll behind the slider content, can you give me a solution, i dont quite understand Olivia's explanation (negative margin...), if you could show me with screen shuts? http://184.107.208.178/~meuneriegsoucy/index.php I also give you the site admin access on a private request. Thanks Martin
Support Team
Support Team posted this 16 June 2015

Hi Martin,

Please try the following solution:

  1. open Hmenu Arrange:

    hmenu-arrange3.png

  2. and add z-index: 4.

This should help.

Thank you,
Olivia

Hi Martin, Please try the following solution: 1. open Hmenu **Arrange**: !hmenu-arrange3.png! 2. and add **z-index**: 4. This should help. Thank you, Olivia
martin53
13 Posts
martin53 posted this 16 June 2015

Thanks.

Now the menu is showing up on top but not the sub-menus, i changed z-index: 4 for all of them, navigation, menu, sumenu but the submenu are still behind as you can see on my screen shut. If you want i gave you the credentials to log into the site to look at this on my private posts.

Thanks. Now the menu is showing up on top but not the sub-menus, i changed z-index: 4 for all of them, navigation, menu, sumenu but the submenu are still behind as you can see on my screen shut. If you want i gave you the credentials to log into the site to look at this on my private posts.
Support Team
Support Team posted this 17 June 2015

Hello Martin,
please submit a new private topic http://answers.billiondigital.com/Topic/Create?private=1
and provide access credentials to CMS admin back end.

regards,
Aileen

Hello Martin, please submit a new private topic http://answers.billiondigital.com/Topic/Create?private=1 and provide access credentials to CMS admin back end. regards, Aileen
martin53
13 Posts
martin53 posted this 17 June 2015

Hello Alleen,

OK i just did open a new private topic for this issue call: Problems with a mobile menu

Let me know what to do.

Thanks
Martin

Hello Alleen, OK i just did open a new private topic for this issue call: Problems with a mobile menu Let me know what to do. Thanks Martin
DaveOzric
721 Posts
DaveOzric posted this 30 July 2015

What is the answer to this? I have tried a few of these things and none are working fully.

What is the answer to this? I have tried a few of these things and none are working fully.
Support Team
Support Team posted this 31 July 2015

Hi Dave,

Could you please also create a private topic with a link to your site and more details about the issue.

Sincerely,
Hella
BillionDigital Team

Hi Dave, Could you please also create a private topic with a link to your site and more details about the issue. Sincerely, Hella BillionDigital Team
Tommivi
12 Posts
Tommivi posted this 06 October 2015

Hi, i got the same issue - standard menu in header with logo on the left side, all above the slider. In all Versions it works fine, only responsive menu is not clickable. i can see the layout frame in themer opening behind the slider. I tried your suggestions, but nothing works proper, just when set menu outside the header it is working in responsive layout, but all the other designs change in menu under the logo - So i spend many hours trying to fix this:-(
So how can i get it solved to have the desired design in all views and a functional responsive menu?

Thanks for your help!

Regards Tom

Hi, i got the same issue - standard menu in header with logo on the left side, all above the slider. In all Versions it works fine, only responsive menu is not clickable. i can see the layout frame in themer opening behind the slider. I tried your suggestions, but nothing works proper, just when set menu outside the header it is working in responsive layout, but all the other designs change in menu under the logo - So i spend many hours trying to fix this:-( So how can i get it solved to have the desired design in all views and a functional responsive menu? Thanks for your help! Regards Tom
Support Team
Support Team posted this 07 October 2015

Hi,

Please create a private topic and provide access to your theme.

Sincerely,
Hella

Hi, Please create a private topic and provide access to your theme. Sincerely, Hella
info1360
10 Posts
info1360 posted this 31 October 2015

Hallo,
mein Problem ist, das mein horizontales responsive Menü auf dem Smartphone nicht richtig angezeigt wird. Es scheint sich aufzuklappen und gleich wieder zuzuklappen und wird abgeschnitten. (Bild 1 im Anhang) Auf Displays ab einer bestimmten Größe und Tablets ab 7" wird das responsive Menü aber korrekt angezeigt. (Bild Original im Anhang)

Ich komme nicht hinter die Lösung des Problems.


Hello, Unfortunately, my English is not good-
my problem is, that is my horizontal responsive menu does not display properly on your smartphone. It seems unfold and unfold them equal again and will be truncated. (Picture 1 in the appendix) on the display of a certain size and tablets from 7 " the responsive menu but displays correctly. (Original image attached)
I can not get behind the solution of the problem.

Danke Frank

Hallo, mein Problem ist, das mein horizontales responsive Menü auf dem Smartphone nicht richtig angezeigt wird. Es scheint sich aufzuklappen und gleich wieder zuzuklappen und wird abgeschnitten. (Bild 1 im Anhang) Auf Displays ab einer bestimmten Größe und Tablets ab 7" wird das responsive Menü aber korrekt angezeigt. (Bild Original im Anhang) Ich komme nicht hinter die Lösung des Problems. ------------------ Hello, Unfortunately, my English is not good- my problem is, that is my horizontal responsive menu does not display properly on your smartphone. It seems unfold and unfold them equal again and will be truncated. (Picture 1 in the appendix) on the display of a certain size and tablets from 7 " the responsive menu but displays correctly. (Original image attached) I can not get behind the solution of the problem. Danke Frank
Support Team
Support Team posted this 02 November 2015

Hi,

Could you please create a separate topic and provide the login details to your site so we could check your theme settings.

Sincerely,
Hella

Hi, Could you please create a separate topic and provide the login details to your site so we could check your theme settings. Sincerely, Hella
DFG
23 Posts
DFG posted this 02 December 2015

Hi Support team!
So, does this issue have a solution we can solve by ourselves?
I have exactly the same issue with responsive menu described above.
I see that martin53 problem is resolved.
I work on locally on XAMP, so I can not provide access to support.
Please, what to do?

Yuri

Hi Support team! So, does this issue have a solution we can solve by ourselves? I have exactly the same issue with responsive menu described above. I see that martin53 problem is resolved. I work on locally on XAMP, so I can not provide access to support. Please, what to do? Yuri
Support Team
Support Team posted this 07 December 2015

Hello Yuri,
the general solution for the problem which was reported initially in this topic is provided in this post
http://answers.themler.com/answers/1233

The issue "menu is not displayed properly" is too much general so we could provide a solution for it. So please submit new support private topic where provide link to your site and your CMS admin back end.

regards,
Aileen

Hello Yuri, the general solution for the problem which was reported initially in this topic is provided in this post http://answers.themler.com/answers/1233 The issue "menu is not displayed properly" is too much general so we could provide a solution for it. So please submit new support private topic where provide link to your site and your CMS admin back end. regards, Aileen
You must log in or register to leave comments