Wordpress - Align images in Posts / Pages

Stagger Lee
1796 Posts
Stagger Lee posted this 27 May 2015

Just small bug. Code in Themler CSS prevents aligning images (center) in Posts.
Believe it is display:inline.block making this. But need to be fixed without removing it. Display:block would make impossible to align text around images. Not sure now, just saying byheart.

Just tested on cloud too.

Just small bug. Code in Themler CSS prevents aligning images (center) in Posts. Believe it is display:inline.block making this. But need to be fixed without removing it. Display:block would make impossible to align text around images. Not sure now, just saying byheart. Just tested on cloud too.
Vote to pay developers attention to this features or issue.
14 Comments
Order By: Standard | Newest
Support Team posted this 28 May 2015

Hello

Please Navigate to Posts control >> Post Content >> Typography Styles:

posts-typogr.png

Find Image >> Style Options:

image-style.png

Arrange Tab >> Display -> "No Value".

This should help.

Thank you,
Olivia

Hello Please Navigate to Posts control >> Post Content >> Typography Styles: !posts-typogr.png! Find Image >> Style Options: !image-style.png! Arrange Tab >> Display -> "No Value". This should help. Thank you, Olivia
Stagger Lee
1796 Posts
Stagger Lee posted this 28 May 2015

Thank you.
For some reason I had it removed on my live site. An text wrapping works OK too. Put it as default setting.

Thank you. For some reason I had it removed on my live site. An text wrapping works OK too. Put it as default setting.
HERVE FRANCO
2 Posts
HERVE FRANCO posted this 21 August 2015

Sorry I can't find this option in themler, I navigate through Post content but there is no typographic style, coud you help me please ?

Sorry I can't find this option in themler, I navigate through Post content but there is no typographic style, coud you help me please ?
HERVE FRANCO
2 Posts
HERVE FRANCO posted this 21 August 2015

Ok I have it

You have to got it

You have to navigate to : Posts control >> Post Content >>More Styles >>Images Style (clic on square on right) >> Arrange (last icon on right) >> display no value

Ok I have it You have to got it You have to navigate to : Posts control >> Post Content >>More Styles >>Images Style (clic on square on right) >> Arrange (last icon on right) >> display no value
Lex
5 Posts
Lex posted this 25 March 2016

I have a similar problem.
In WordPress I have images adjacently
In Themler template they are but one below the other.
I find no solution.

In a standard WP template is displayed correctly

I have a similar problem. In WordPress I have images adjacently In Themler template they are but one below the other. I find no solution. In a standard WP template is displayed correctly

Last edited 25 March 2016 by Lex

Support Team
Support Team posted this 28 March 2016

Hi,

We need to see the page with images.
Could you please create a separate topic and provide the link to the page that demonstrates the issue.

Thank you,
Olivia

Hi, We need to see the page with images. Could you please create a separate topic and provide the link to the page that demonstrates the issue. Thank you, Olivia
len
120 Posts
len posted this 25 April 2016

Same problem, images in Wordpress set to centre are left aligned.
In Themler desktop v292 I have changed Design > IMage Style > Arrange Display to No Value.
Also have a 10px margin on images in this same section, so that text is not up against each image.
When I remove the 10px margin, the image centering in the Wordpress editor works.
It appears not just to be the display: inline-block, its also the additional margin setting.
LenW

Same problem, images in Wordpress set to centre are left aligned. In Themler desktop v292 I have changed Design > IMage Style > Arrange Display to No Value. Also have a 10px margin on images in this same section, so that text is not up against each image. When I remove the 10px margin, the image centering in the Wordpress editor works. It appears not just to be the display: inline-block, its also the additional margin setting. LenW

Last edited 25 April 2016 by len

Support Team
Support Team posted this 26 April 2016

Hi,

Please let us know if you need any assist with this matter. If yes, please create a private topic with the access to your site back end.

Sincerely,
Hella

Hi, Please let us know if you need any assist with this matter. If yes, please create a private topic with the access to your site back end. Sincerely, Hella
len
120 Posts
len posted this 22 June 2016

This is still an issue.
In Outline, Content & Sliders > CMS Content > Posts > Post Content > More Styles > Image Style
I have set Arrange, Display to no value.
In Wordpress images set to be centred are still left aligned,
I have a margin around images, to keep text from being right up against the images. This margin is over-riding the margin-left:auto and margin-right:auto css used to centre images, so preventing centering.

The margin should be applied if specified for left or right aligned images, and top/bottom of centred images. For centred images the auto settings need to over-ride these, but currently don't.

Please will you fix this by removing the inline-block and the CSS. Fixing the image in each template and in Wordpress with additional CSS is more unnecessary work.

This is still an issue. In Outline, Content & Sliders > CMS Content > Posts > Post Content > More Styles > Image Style I have set Arrange, Display to no value. In Wordpress images set to be centred are still left aligned, I have a margin around images, to keep text from being right up against the images. This margin is over-riding the margin-left:auto and margin-right:auto css used to centre images, so preventing centering. The margin should be applied if specified for left or right aligned images, and top/bottom of centred images. For centred images the auto settings need to over-ride these, but currently don't. Please will you fix this by removing the inline-block and the CSS. Fixing the image in each template and in Wordpress with additional CSS is more unnecessary work.
Stagger Lee
1796 Posts
Stagger Lee posted this 22 June 2016

Set display: inline-block for images.

Set display: inline-block for images.
Stagger Lee
1796 Posts
Stagger Lee posted this 22 June 2016

Sorry it is for Gallery, for images dispplay:block works. How to combine those two.

I have to check why it works on all my themes. I dont have problems like this, as I remember.

Sorry it is for Gallery, for images dispplay:block works. How to combine those two. I have to check why it works on all my themes. I dont have problems like this, as I remember.
Stagger Lee
1796 Posts
Stagger Lee posted this 23 June 2016

I have one theme where aligment is respected on frontend but not in Themler edit screen.
Have to investigate more this phenomena.

Maybe I did not notice anything before because I allways override Gallery shortcode with my own with Bootstrap classes.

I have one theme where aligment is respected on frontend but not in Themler edit screen. Have to investigate more this phenomena. Maybe I did not notice anything before because I allways override Gallery shortcode with my own with Bootstrap classes.
lauragalca
1 Posts
lauragalca posted this 29 March 2017

Hi! I have the same problem. When I upload the theme to Wordpress, all images are aligned at left by default and I don't want it. I've followed the steps but I can't find this path. I've tried with: Styles > Images > Arrange but i don't find "Arrange Tab >> Display -> "No Value". I attach the image. Thanks.

Hi! I have the same problem. When I upload the theme to Wordpress, all images are aligned at left by default and I don't want it. I've followed the steps but I can't find this path. I've tried with: Styles > Images > Arrange but i don't find "Arrange Tab >> Display -> "No Value". I attach the image. Thanks.
Support Team
Support Team posted this 29 March 2017

Hi,

Try to set none where it says Display: inline-block in your screen shot.

Sincerely,
Hella

Hi, Try to set `none` where it says `Display: inline-block` in your screen shot. Sincerely, Hella
You must log in or register to leave comments