Your theme contains outdated copies of some WooCommerce template files..

Lakeasha
13 Posts
Lakeasha posted this 24 April 2017

Hello,

I am working in my clients website and they have the most current version of themler and woocommerce and we are still getting this message. Is there a fix?

Message: "Your theme contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. You can see which files are affected from the system status page. If in doubt, check with the author of the theme."

Hello, I am working in my clients website and they have the most current version of themler and woocommerce and we are still getting this message. Is there a fix? ***Message***: "Your theme contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce. You can see which files are affected from the system status page. If in doubt, check with the author of the theme."
Vote to pay developers attention to this features or issue.
9 Comments
Order By: Standard | Newest
wpexpertinbd
92 Posts
wpexpertinbd posted this 25 April 2017

Click "system status" from woocommerce tab then you will find 2 file are outdated. Goto your cpanel or hosting control panel update that 2 file from plugin folder woocommerce file to your theme folder woocommerce file that's all.

Click "system status" from woocommerce tab then you will find 2 file are outdated. Goto your cpanel or hosting control panel update that 2 file from plugin folder woocommerce file to your theme folder woocommerce file that's all.

Last edited 25 April 2017 by wpexpertinbd

Support Team
Support Team posted this 25 April 2017

Hi,

As alternative solution you can simply change the version number specified in the file:
change
@version 2.3.8
to
@version 3.0.0

This number does not affect anything and this incompatibility does not cause any problems. This is just a question of text comment with version.

Thank you,
Olivia

Hi, As alternative solution you can simply change the version number specified in the file: change `@version 2.3.8` to ` @version 3.0.0` This number does not affect anything and this incompatibility does not cause any problems. This is just a question of text comment with version. Thank you, Olivia
Lakeasha
13 Posts
Lakeasha posted this 27 April 2017

Hi,

As alternative solution you can simply change the version number specified in the file:
change
@version 2.3.8
to
@version 3.0.0

This number does not affect anything and this incompatibility does not cause any problems. This is just a question of text comment with version.

Thank you,
Olivia

Where would I be donig this change? in the plugin or the theme?

> Hi, > > As alternative solution you can simply change the version number specified in the file: > change > `@version 2.3.8` > to > ` @version 3.0.0` > > This number does not affect anything and this incompatibility does not cause any problems. This is just a question of text comment with version. > > Thank you, > Olivia Where would I be donig this change? in the plugin or the theme?
Support Team
Support Team posted this 28 April 2017

Hi,

You need to edit it in the theme.

Sincerely,
Hella

Hi, You need to edit it in the theme. Sincerely, Hella
Lakeasha
13 Posts
Lakeasha posted this 28 April 2017

Thank you

Thank you
Support Team
Support Team posted this 01 May 2017

Hello,
you're welcome!
Let us know if you have additional questions.

regards,
Aileen

Hello, you're welcome! Let us know if you have additional questions. regards, Aileen
len
140 Posts
len posted this 19 July 2017

If these messages are relating to template over-rides, surely the current version of Themler should be adding the correct version number in the template override. This could be corresponding to the version of Woocommerce in the Themler desktop install, a long as that gets updated regularly.

Part of the issue here is that the Desktop install of Themler has no easy way to upgrade Wordpress and Woocommerce other than manually, and no guidance as to when to upgrade these with the current Themler version.

If these messages are relating to template over-rides, surely the current version of Themler should be adding the correct version number in the template override. This could be corresponding to the version of Woocommerce in the Themler desktop install, a long as that gets updated regularly. Part of the issue here is that the Desktop install of Themler has no easy way to upgrade Wordpress and Woocommerce other than manually, and no guidance as to when to upgrade these with the current Themler version.
Support Team
Support Team posted this 20 July 2017

Hi,

In fact, We created Themler Desktop for theme developing only. The Woocommerce version does not affect theme developing and final theme. As alternative to the Themler Desktop you can install local WordPress with any Woocommerce version you need.

We updated this text comment in one of the last Themler updates.

Thank you,
Olivia

Hi, In fact, We created Themler Desktop for theme developing only. The Woocommerce version does not affect theme developing and final theme. As alternative to the Themler Desktop you can install local WordPress with any Woocommerce version you need. We updated this text comment in one of the last Themler updates. Thank you, Olivia
len
140 Posts
len posted this 19 September 2018

This is still an issue.
I only use themler desktop with the current version of WordPress (4.9.8) and Woocommerce (3.4.5) in theThemler environment (yes I do update these).
Woocommerce system status shows:
JW_E29/woocommerce/archive-product.php version 3.3.0 is out of date. The core version is 3.4.0,
JW_E29/woocommerce/cart/cart.php version 3.3.0 is out of date. The core version is 3.4.0,

Can this please be handled with with each Themler update?

Thanks

This is still an issue. I only use themler desktop with the current version of WordPress (4.9.8) and Woocommerce (3.4.5) in theThemler environment (yes I do update these). Woocommerce system status shows: JW_E29/woocommerce/archive-product.php version 3.3.0 is out of date. The core version is 3.4.0, JW_E29/woocommerce/cart/cart.php version 3.3.0 is out of date. The core version is 3.4.0, Can this please be handled with with each Themler update? Thanks
You must log in or register to leave comments