typography changes

damian_tito25
6 Posts
damian_tito25 posted this 03 June 2015

the font used planer, but it changes the fonts on the other computers...

I use system fonts (Planer)

the font used planer, but it changes the fonts on the other computers... I use system fonts (Planer)
Vote to pay developers attention to this features or issue.
7 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 03 June 2015

Hello

This issue happens because you're using SYSTEM font. Each visitor of your website will not see this font if it's not installed in his system. This is the problem of using system fonts on websites.
There are a few possible options:

The first option is better. The last options reacquires adding custom css and uploading your font to the website directory.

Thank you,
Olivia

Hello This issue happens because you're using SYSTEM font. Each visitor of your website will not see this font if it's not installed in his system. This is the problem of using system fonts on websites. There are a few possible options: - using google fonts instead - using [web safe fonts][1]: - using `@font-face` [css rule][2] The first option is better. The last options reacquires adding custom css and uploading your font to the website directory. Thank you, Olivia [1]: http://www.w3schools.com/cssref/css_websafe_fonts.asp [2]: http://www.font-face.com/
damian_tito25
6 Posts
damian_tito25 posted this 03 June 2015

I can give an example of how to put me does not work / me puede dar un ejemplo de como poner no me funciona

@font-face {
font-family: Planer;
src: url(http://www.bsc-ec.com/fonts/Planer.otf);
font-weight:400;
}

@import url(http://www.bsc-ec.com/fonts/planer.css);

I can give an example of how to put me does not work / me puede dar un ejemplo de como poner no me funciona @font-face { font-family: Planer; src: url(http://www.bsc-ec.com/fonts/Planer.otf); font-weight:400; } @import url(http://www.bsc-ec.com/fonts/planer.css);
Support Team posted this 04 June 2015

Hello

In general it should be enough to add @font-face rule to the theme Settings in Themler >> Additional CSS:

@font-face
{
font-family: Planer;
src: url(http://website.com/fonts/Planer.otf);
src: url(...) format('woff'),
url(...) format('truetype');
}

Please note that custom font will not be visible if it's located on the different domain. This happens because browsers block Cross-Origin Requests:

Cross-Origin Request Blocked: ...
The Same Origin Policy disallows reading the remote resource at (Reason: CORS header 'Access-Control-Allow-Origin' missing).

The @import rule will not work because it needs to be added to the beginning of the css file.
The code added to the Settings >> Additional CSS in Themler will be added to the end of the css file.

Please keep us posted about the progress.

Thank you,
Olivia

Hello In general it should be enough to add `@font-face` rule to the theme Settings in Themler >> Additional CSS: `@font-face { font-family: Planer; src: url(http://website.com/fonts/Planer.otf); src: url(...) format('woff'), url(...) format('truetype'); }` Please note that custom font will not be visible if it's located on the different domain. This happens because browsers block Cross-Origin Requests: Cross-Origin Request Blocked: ... The Same Origin Policy disallows reading the remote resource at (Reason: CORS header 'Access-Control-Allow-Origin' missing). The @import rule will not work because it needs to be added to the beginning of the css file. The code added to the Settings >> Additional CSS in Themler will be added to the end of the css file. Please keep us posted about the progress. Thank you, Olivia
damian_tito25
6 Posts
damian_tito25 posted this 04 June 2015

ready thanks, I will use google fonts / listos gracias, voy a utilizar fuentes google :)

ready thanks, I will use google fonts / listos gracias, voy a utilizar fuentes google :)
Support Team
Support Team posted this 04 June 2015

You're welcome!

You're welcome!
denisp
35 Posts
denisp posted this 21 October 2015

Hello

In general it should be enough to add @font-face rule to the theme Settings in Themler >> Additional CSS:

@font-face
{
font-family: Planer;
src: url(http://website.com/fonts/Planer.otf);
src: url(...) format('woff'),
url(...) format('truetype');
}

Please note that custom font will not be visible if it's located on the different domain. This happens because browsers block Cross-Origin Requests:

Cross-Origin Request Blocked: ...
The Same Origin Policy disallows reading the remote resource at (Reason: CORS header 'Access-Control-Allow-Origin' missing).

The @import rule will not work because it needs to be added to the beginning of the css file.
The code added to the Settings >> Additional CSS in Themler will be added to the end of the css file.

Please keep us posted about the progress.

Thank you,
Olivia

Hello

I'm using the @font-face solution, adding in Settings in Themler >> Additional CSS the proper CSS code.
Please, consider that my webfonts are in a dir that I stored in the template directory.

I'd like to know HOW can I recall the font.
I mean: the title of my posts, I want them they be styled with my new font.

But via Themler the settings of the posts dont see the new css font-face ... they show me the usual Google web fonts and the System Fonts. but my new font is not listed ... so what I have to do?

thanks in advance
denis

> Hello > > In general it should be enough to add `@font-face` rule to the theme Settings in Themler >> Additional CSS: > > `@font-face > { > font-family: Planer; > src: url(http://website.com/fonts/Planer.otf); > src: url(...) format('woff'), > url(...) format('truetype'); > }` > > Please note that custom font will not be visible if it's located on the different domain. This happens because browsers block Cross-Origin Requests: > > Cross-Origin Request Blocked: ... > The Same Origin Policy disallows reading the remote resource at (Reason: CORS header 'Access-Control-Allow-Origin' missing). > > The @import rule will not work because it needs to be added to the beginning of the css file. > The code added to the Settings >> Additional CSS in Themler will be added to the end of the css file. > > Please keep us posted about the progress. > > Thank you, > Olivia Hello I'm using the @font-face solution, adding in Settings in Themler >> Additional CSS the proper CSS code. Please, consider that my webfonts are in a dir that I stored in the template directory. I'd like to know HOW can I recall the font. I mean: the title of my posts, I want them they be styled with my new font. But via Themler the settings of the posts dont see the new css font-face ... they show me the usual Google web fonts and the System Fonts. but my new font is not listed ... so what I have to do? thanks in advance denis
Support Team
Support Team posted this 22 October 2015

Hello Denis,
after you added the @font-face code under Settings >> Additional CSS you may apply it to the tags, e.g.

h3 {font-family: 'Planer';}

Regards,
Aileen

Hello Denis, after you added the @font-face code under Settings >> Additional CSS you may apply it to the tags, e.g. h3 {font-family: 'Planer';} Regards, Aileen
You must log in or register to leave comments