500 Internal Server Error when duplicating template

gaa
3 Posts
gaa posted this 2 weeks ago

Hi there,
I get an 500 Internal Server Error when duplicating template

Other than that Themler seem to work fine.

CMS: Joomla 3.8.2
Problem both within Chrome and Firefox

Any ideas?

Hi there, I get an 500 Internal Server Error when duplicating template Other than that Themler seem to work fine. CMS: Joomla 3.8.2 Problem both within Chrome and Firefox Any ideas?
Vote to pay developers attention to this features or issue.
5 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 2 weeks ago

Hello,

Please try these steps:
1. Temporary disable all third-party CMS plugins, components and modules.
2. Clear cache:
http://answers.themler.com/articles/8713/error-sorry-an-error-has-occurred-please-clear-your-browser-cache
3. Clear AppCache. Use Chrome browser for this:
http://answers.themler.com/articles/14063/how-to-clear-appcache

Also please make sure that the user and group running the web server are granted the appropriate read, write and execute (linux only) permissions on the following folders, as well as read and write permission on the files in these folders:

root/templates
root/plugins
root/tmp

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try these steps: 1. Temporary disable all third-party CMS plugins, components and modules. 2. Clear cache: http://answers.themler.com/articles/8713/error-sorry-an-error-has-occurred-please-clear-your-browser-cache 3. Clear AppCache. Use Chrome browser for this: http://answers.themler.com/articles/14063/how-to-clear-appcache Also please make sure that the user and group running the web server are granted the appropriate read, write and execute (linux only) permissions on the following folders, as well as read and write permission on the files in these folders: root/templates root/plugins root/tmp Sincerely, Nettie, BillionDigital Team
gaa
3 Posts
gaa posted this 2 weeks ago

Thanks a lot for the feedback.

It looks like it is the Securitycheck Pro component causing this.

This component has a firewall that seem to stop this.

In order to create an exception for Themler in the firewall I need to have an idea what commands are used when adding/duplicating and removing templates.

Any idea what the commands are?

Thanks a lot for the feedback. It looks like it is the Securitycheck Pro component causing this. This component has a firewall that seem to stop this. In order to create an exception for Themler in the firewall I need to have an idea what commands are used when adding/duplicating and removing templates. Any idea what the commands are?
Support Team
Support Team posted this 2 weeks ago

Hello,

Please try the following:
1. Please add the websites *.billiondigital.com, themler.com and themler.io to exception list. If it is not possible, please try adding cstatic.billiondigital.com etc.
2. Then please clear Appcache in Chrome: chrome://appcache-internals - all Themler entries.
3. After this please try running Themler and start a theme in a CMS anew.
Please let us know the result.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try the following: 1. Please add the websites `*.billiondigital.com`, `themler.com` and `themler.io` to exception list. If it is not possible, please try adding `cstatic.billiondigital.com` etc. 2. Then please clear Appcache in Chrome: chrome://appcache-internals - all Themler entries. 3. After this please try running Themler and start a theme in a CMS anew. Please let us know the result. Sincerely, Nettie, BillionDigital Team
gaa
3 Posts
gaa posted this 2 weeks ago

Thanks a lot for your feedback.

The Securitycheck Pro does not work like that. The firewall simply block certain components within Joomla from doing certain commands.

I think I have got a fit further now as I see from the Themler adminurl within Joomla that it is the com_templates that need an exception. By adding an exception for com_templates within the Securitycheckpro firewall for the socalled 'LFI' filter, I seem to have got rid of the error. (See the attached picture.

I will monitor this going forward, and also test this out on other sites as well, but at the moment I no longer get the error.

Thanks a lot for your feedback. The Securitycheck Pro does not work like that. The firewall simply block certain components within Joomla from doing certain commands. I think I have got a fit further now as I see from the Themler adminurl within Joomla that it is the com_templates that need an exception. By adding an exception for com_templates within the Securitycheckpro firewall for the socalled 'LFI' filter, I seem to have got rid of the error. (See the attached picture. I will monitor this going forward, and also test this out on other sites as well, but at the moment I no longer get the error.
Support Team
Support Team posted this 2 weeks ago

Hello,

I see now. Thanks for letting us know. Please let us know if our further assistance is needed.

Sincerely,
Nettie,
BillionDigital Team

Hello, I see now. Thanks for letting us know. Please let us know if our further assistance is needed. Sincerely, Nettie, BillionDigital Team
You must log in or register to leave comments