Themler export empty zip file

kvences
3 Posts
kvences posted this 17 November 2017

Hi, i am using Themler 1.0.319 (fe25b), on OS X 10.11.6 When i export a File->Export as Zip the first time work fine, but when i modify and try to export again it create an empty zip file.

Hi, i am using Themler 1.0.319 (fe25b), on OS X 10.11.6 When i export a File->Export as Zip the first time work fine, but when i modify and try to export again it create an empty zip file.
Vote to pay developers attention to this features or issue.
14 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 17 November 2017

Hello,

Please try the following
1. Make sure to enable cookies in Safari browser.
2. Please try to open Themler through a browser using this link
http://127.0.0.1:29958/themler_3440141799/startup/

Try different browsers like Safari, Firefox, Chrome and to export. Please let us know the result.

As a temporary solution, you may copy the theme manually from the folder with themes. Please click Go >> Go to Folder >> type ~/Library and ENTER >> Themler >> hd_data >> cms >> choose CMS and access the themes folder, copy the theme, zip it and install on your hosted website.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try the following 1. Make sure to enable cookies in Safari browser. 2. Please try to open Themler through a browser using this link http://127.0.0.1:29958/themler_3440141799/startup/ Try different browsers like Safari, Firefox, Chrome and to export. Please let us know the result. As a temporary solution, you may copy the theme manually from the folder with themes. Please click Go >> Go to Folder >> type `~/Library` and ENTER >> Themler >> hd_data >> cms >> choose CMS and access the themes folder, copy the theme, zip it and install on your hosted website. Sincerely, Nettie, BillionDigital Team
kvences
3 Posts
kvences posted this 17 November 2017

Hi, i do this:
1.- Open Themler
2.- Open Browser ( Safari, Firefox, Chrome)
3.- Try http://127.0.0.1:29958/themler_3440141799/startup/ in all browsers
4.- Clic on Joomla
5.- Get errors in all browsers you can see the errors on themler-error.txt

The temporary solution works, thanks

Hi, i do this: 1.- Open Themler 2.- Open Browser ( Safari, Firefox, Chrome) 3.- Try http://127.0.0.1:29958/themler_3440141799/startup/ in all browsers 4.- Clic on Joomla 5.- Get errors in all browsers you can see the errors on themler-error.txt The temporary solution works, thanks
Support Team
Support Team posted this 18 November 2017

Hello,

Please make sure to backup all the created themes from the folder on your computer. Then please try completely uninstalling Themler and also remove Themler folder from the Mac library. Then temporarily disable antivirus and firewall, download and install Themler for Mac anew. Let us know if you can start a Joomla theme withou any errors and if export works.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please make sure to backup all the created themes from the folder on your computer. Then please try completely uninstalling Themler and also remove Themler folder from the Mac library. Then temporarily disable antivirus and firewall, download and install Themler for Mac anew. Let us know if you can start a Joomla theme withou any errors and if export works. Sincerely, Nettie, BillionDigital Team
chinas
12 Posts
chinas posted this 26 August 2019

Hello.
I have the same problem. None of the above helped me.
I still have a problem in the admin panel when trying to edit a template. After clicking on the button "Edit Template" returns an error: "Sorry, an error has occurred. Please clear your browser cache."
Clearing the cache gives nothing.

Hello. I have the same problem. None of the above helped me. I still have a problem in the admin panel when trying to edit a template. After clicking on the button "Edit Template" returns an error: "Sorry, an error has occurred. Please clear your browser cache." Clearing the cache gives nothing.

Last edited 26 August 2019 by chinas

Support Team
Support Team posted this 27 August 2019

Hello,

Do you have the issue on your hosted website or locally in Themler for Mac?

Sincerely,
Nettie

Hello, Do you have the issue on your hosted website or locally in Themler for Mac? Sincerely, Nettie
chinas
12 Posts
chinas posted this 27 August 2019

I use Windows 10 and Chrome browser

I use Windows 10 and Chrome browser

Last edited 27 August 2019 by chinas

Support Team
Support Team posted this 28 August 2019

Hello,

The solutions above were mainly for Mac. With Themler desktop for Windows please try the following:
1) close Themler
2) open Windows Explorer and type %LocalAppData% in the address bar
3) find & rename Themler directory
4) start Themler again

Sincerely,
Nettie

Hello, The solutions above were mainly for Mac. With Themler desktop for Windows please try the following: 1) close Themler 2) open Windows Explorer and type %LocalAppData% in the address bar 3) find & rename Themler directory 4) start Themler again Sincerely, Nettie
chinas
12 Posts
chinas posted this 28 August 2019

I have completed all the points.
A new directory Themler was created.
Here's what I got after running the application (file attached).

P.S. Opened VirtueMart mode

I have completed all the points. A new directory Themler was created. Here's what I got after running the application (file attached). P.S. Opened VirtueMart mode

Last edited 28 August 2019 by chinas

Support Team
Support Team posted this 29 August 2019

Hello,

In this case please try a little longer way:
1. Backup all theme folders somewhere on your computer if there are any. The path is shown in the Theme Management screen after selecting some CMS, for example, C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\wordpress.
2. Uninstall Themler completely and also check the box for "Remove all CMS content".
3. Check if the following folders are still present:

C:\Program Files (x86)\Themler
C:\ProgramData\Themler

4. If they exist, remove them.
5. Reboot the machine after uninstalling Themler, so that all Themler services are removed for sure.
6. Temporarily disable antivirus and firewall.
7. Download latest version of Themler for Windows from themler.io, install it and try to start with Themler for any CMS and create a theme.
Please let us know the result.

Sincerely,
Nettie

Hello, In this case please try a little longer way: 1. Backup all theme folders somewhere on your computer if there are any. The path is shown in the Theme Management screen after selecting some CMS, for example, `C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\wordpress`. 2. Uninstall Themler completely and also check the box for "Remove all CMS content". 3. Check if the following folders are still present: C:\Program Files (x86)\Themler C:\ProgramData\Themler 4. If they exist, remove them. 5. Reboot the machine after uninstalling Themler, so that all Themler services are removed for sure. 6. Temporarily disable antivirus and firewall. 7. Download latest version of Themler for Windows from themler.io, install it and try to start with Themler for any CMS and create a theme. Please let us know the result. Sincerely, Nettie
chinas
12 Posts
chinas posted this 30 August 2019

This path is not on my disk:

C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\wordpress

I have completed all the points.
The application started to run. But my achievements have not been preserved. I will survive it.
An error started to appear again (in the attached file).

This path is not on my disk: > C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\wordpress I have completed all the points. The application started to run. But my achievements have not been preserved. I will survive it. An error started to appear again (in the attached file).
Support Team
Support Team posted this 30 August 2019

Hello,

The numbers instead of XXXXXXXXXX are individual and can be seen if you for example try Themler Live preview. Also ProgramData folder may be hidden and you may need to set displaying of hidden folders to view it.
The issue happens with Themler for HTML only, right? I mean, there are no issues with Themler for Wordpress for example, aren't they?

Sincerely,
Nettie

Hello, The numbers instead of XXXXXXXXXX are individual and can be seen if you for example try Themler Live preview. Also ProgramData folder may be hidden and you may need to set displaying of hidden folders to view it. The issue happens with Themler for HTML only, right? I mean, there are no issues with Themler for Wordpress for example, aren't they? Sincerely, Nettie
chinas
12 Posts
chinas posted this 30 August 2019

Yes, the directory was hidden

I do not use Wordpress or HTML. I'm trying to create a template for Joomla / VirtueMart.

Can you recommend something about the error?

Yes, the directory was hidden I do not use Wordpress or HTML. I'm trying to create a template for Joomla / VirtueMart. Can you recommend something about the error?

Last edited 31 August 2019 by chinas

chinas
12 Posts
chinas posted this 31 August 2019

I do not know what you did, but the error has ceased to be displayed. Thanks.

I do not know what you did, but the error has ceased to be displayed. Thanks.
Support Team
Support Team posted this 31 August 2019

Hello,

We haven't done anything special in this time, the issue must have been local. Thanks for letting us know and please feel free to contact us in any other case.

Sincerely,
Nettie

Hello, We haven't done anything special in this time, the issue must have been local. Thanks for letting us know and please feel free to contact us in any other case. Sincerely, Nettie
You must log in or register to leave comments