WP Widget area issue and a fix

lavisbre
67 Posts
lavisbre posted this 29 December 2017

enter image description here

when adding Widgets to a container or column it gives an odd message ###area 1#### or 2 or 3 or 4 iv had elven as well.
I had a custom widget code to add and nothing worked.

The fix is to open the page in WP and pick add code to the page, not the widget it represents!

Hope that was of use

PS themar your wordpress widget thing doesn't work

![enter image description here][1] [1]: https://image.ibb.co/jUMyzw/widget_error.png when adding Widgets to a container or column it gives an odd message ###area 1#### or 2 or 3 or 4 iv had elven as well. I had a custom widget code to add and nothing worked. The fix is to open the page in WP and pick add code to the page, not the widget it represents! Hope that was of use PS themar your wordpress widget thing doesn't work
Vote to pay developers attention to this features or issue.
9 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 29 December 2017

Hi,

As I see, you are adding the widget areas in the content. They should not be added in the content, that may be the reason for the issue. The green content area should have only static content added in Themler or from the WP admin, but not the widget areas.

Sincerely,
Hella

Hi, As I see, you are adding the widget areas in the content. They should not be added in the content, that may be the reason for the issue. The green content area should have only static content added in Themler or from the WP admin, but not the widget areas. Sincerely, Hella
lavisbre
67 Posts
lavisbre posted this 29 December 2017

Hi Hella

Thank you for your prompt replies I really appreciate all you do and your team.

When I add the widget to the blue area it goes sitewide on every page? what setting should I change?
Before I did just as you described but this latest update has it going site-wide.?

Hi Hella Thank you for your prompt replies I really appreciate all you do and your team. When I add the widget to the blue area it goes sitewide on every page? what setting should I change? Before I did just as you described but this latest update has it going site-wide.?

Last edited 29 December 2017 by lavisbre

Support Team
Support Team posted this 31 December 2017

Hi,

The blue area is an area of a template level. It means that Widget area added to the Blue area will be displayed on all pages which use this template. If you want to display widget area and widgets inside it on all pages please try shared areas with orange borders (Header, Footer, Sidebars). These are special areas to share controls between templates.

Thank you,
Olivia

Hi, The blue area is an area of a template level. It means that Widget area added to the Blue area will be displayed on all pages which use this template. If you want to display widget area and widgets inside it on all pages please try shared areas with orange borders (Header, Footer, Sidebars). These are special areas to share controls between templates. Thank you, Olivia
lavisbre
67 Posts
lavisbre posted this 13 January 2018

Ok I only want this widget on one page called free test.
Right now it shows on all pages i makeƉ
How do i only have it show on one page and not the rest?

When I click new page in WP dashbord it makes a page but with the widget in?
How do I do this so I only have widget on one page please and no more than that one page?

Ok I only want this widget on one page called free test. Right now it shows on all pages i makeÉ How do i only have it show on one page and not the rest? When I click new page in WP dashbord it makes a page but with the widget in? How do I do this so I only have widget on one page please and no more than that one page?
lavisbre
67 Posts
lavisbre posted this 13 January 2018

No the CPU is not causing this?
I shall repost so your chaos dosent confuse anyone

No the CPU is not causing this? I shall repost so your chaos dosent confuse anyone
lavisbre
67 Posts
lavisbre posted this 13 January 2018

Ok I only want this widget on one page called free test.
Right now it shows on all pages i make?
How do i only have it show on one page and not the rest?

When I click new page in WP dashbord it makes a page but with the widget in?
How do I do this so I only have widget on one page please and no more than that one page?
I added this into blue part of site

Ok I only want this widget on one page called free test. Right now it shows on all pages i make? How do i only have it show on one page and not the rest? When I click new page in WP dashbord it makes a page but with the widget in? How do I do this so I only have widget on one page please and no more than that one page? I added this into blue part of site
Support Team
Support Team posted this 15 January 2018

Hi,

Ok I only want this widget on one page called free test.
Right now it shows on all pages i make?

Each Widget has "Show widget on" option under the WP Appearance >> Widgets. You can manage the widget visibility with this option and display it on the specific page by its ID.

Thank you,
Olivia

Hi, > Ok I only want this widget on one page called free test. Right now it shows on all pages i make? Each Widget has "Show widget on" option under the WP Appearance >> Widgets. You can manage the widget visibility with this option and display it on the specific page by its ID. Thank you, Olivia
lavisbre
67 Posts
lavisbre posted this 16 January 2018

AWsome .... With all going wrong this month I guess i didnt look past my nose.

For anyone wondering what your page ID looks like, its a set of numbers found in your browser of that page

This technique also works for the Post ID of your pages.
Click "Posts" in the admin menu.
Click a Post title.
The Post ID will be visible in the URL bar. In my case, the Post ID is 357 .
https://seo-inbound-marketing.com/wp-admin/post=357&action=edit

AWsome .... With all going wrong this month I guess i didnt look past my nose. For anyone wondering what your page ID looks like, its a set of numbers found in your browser of that page This technique also works for the Post ID of your pages. Click "Posts" in the admin menu. Click a Post title. The Post ID will be visible in the URL bar. In my case, the Post ID is **357** . https://seo-inbound-marketing.com/wp-admin/post=**357**&action=edit
Support Team
Support Team posted this 16 January 2018

Hi,

You are welcome. Feel free to contact us in any occasion.

Sincerely,
Hella

Hi, You are welcome. Feel free to contact us in any occasion. Sincerely, Hella
You must log in or register to leave comments