404-page is missing

Waennefredder
14 Posts
Waennefredder posted this 21 March 2018

Dear all,

trying to edit 404 page for Joomla at Themler shows up 404 page as follows:
heading: Not Found
text: The requested Url /themler_longnumber/joomla/error.php was not found on this server.

Above mentioned text/page is also shown for standard unnamed project (when opening first time)
For me it looks like the error page is not existing as I cannot edit anything. Furthermore using "manage templates" to create a 404 by using the drop down and selecting "Page not found - 404" ends with the same result as described above.

Technical: days ago I reordered a new license and (nevertheless due do other circumstances had to) install Themler with Themler.1.0.319.fe25b.exe. Basically editing/creating new themes for Joomla is still working great, programm runs perfect, and not any bad behaviours but the 404-page is maybe broken itself and I can't find any hint in the forum...

Thank you so much for your help, appreciate
Kind regards
Waennefredder

Dear all, trying to edit 404 page for Joomla at Themler shows up 404 page as follows: ***heading:*** Not Found ***text:*** The requested Url /themler_*longnumber*/joomla/error.php was not found on this server. Above mentioned text/page is also shown for standard unnamed project (when opening first time) For me it looks like the error page is not existing as I cannot edit anything. Furthermore using "manage templates" to create a 404 by using the drop down and selecting "Page not found - 404" ends with the same result as described above. Technical: days ago I reordered a new license and (nevertheless due do other circumstances had to) install Themler with Themler.1.0.319.fe25b.exe. Basically editing/creating new themes for Joomla is still working great, programm runs perfect, and not any bad behaviours but the 404-page is maybe broken itself and I can't find any hint in the forum... Thank you so much for your help, appreciate Kind regards Waennefredder

Last edited 21 March 2018 by Waennefredder

Vote to pay developers attention to this features or issue.
27 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 22 March 2018

Hello Waennefredder,

Please go to Joomla admin and check f there is a menu item marked as Front page. If the issue persists, please try installing the new version of Themler for Windows from http://themler.io/download
Make sure to backup your created themes before this.

Sincerely,
Nettie,
BillionDigital Team

Hello Waennefredder, Please go to Joomla admin and check f there is a menu item marked as Front page. If the issue persists, please try installing the new version of Themler for Windows from http://themler.io/download Make sure to backup your created themes before this. Sincerely, Nettie, BillionDigital Team
Waennefredder
14 Posts
Waennefredder posted this 22 March 2018

Hi,

first of all thank you for the reply but somehow I don't get the solution.
Did the expected but nothing worked.
Now I installed Themler completely new as per mentioned link, openened it and logged in. Then Themler wanted to update the standard theme to newest version - done but still same problem. Afterwards I now disabled all modules but module for hmenu and footer 2 positions. One article is favorite too, but basically all other things are Themler standard right after installation - the problem is still there.

themler404.png

Sorry but I am getting crazy. Do you still have an Idea for me?

Sincerely
Karsten
(Waennefredder)

Hi, first of all thank you for the reply but somehow I don't get the solution. Did the expected but nothing worked. Now I installed Themler completely new as per mentioned link, openened it and logged in. Then Themler wanted to update the standard theme to newest version - done but still same problem. Afterwards I now disabled all modules but module for hmenu and footer 2 positions. One article is favorite too, but basically all other things are Themler standard right after installation - the problem is still there. !themler404.png! Sorry but I am getting crazy. Do you still have an Idea for me? Sincerely Karsten (Waennefredder)
DaveOzric
789 Posts
DaveOzric posted this 22 March 2018

OK, can you click on the Joomla admin icon and get to the backend? If so you just need to check a few things in there to see.

OK, can you click on the Joomla admin icon and get to the backend? If so you just need to check a few things in there to see.
Support Team
Support Team posted this 22 March 2018

Hello Karsten,

Could you please make sure there is a menu item marked as Home (Front) page in Joomla backend?
Also - did you check the option to "Remove CMS content" while reinstalling Themler?

Sincerely,
Nettie,
BillionDigital Team

Hello Karsten, Could you please make sure there is a menu item marked as Home (Front) page in Joomla backend? Also - did you check the option to "Remove CMS content" while reinstalling Themler? Sincerely, Nettie, BillionDigital Team
Waennefredder
14 Posts
Waennefredder posted this 22 March 2018

OK, can you click on the Joomla admin icon and get to the backend? If so you just need to check a few things in there to see.

Hi Dave,

yes I can click / use the admin icon on the right top for opening the backend and as described it looks like I can use the backend as normal.
Regards

> OK, can you click on the Joomla admin icon and get to the backend? If so you just need to check a few things in there to see. Hi Dave, yes I can click / use the admin icon on the right top for opening the backend and as described it looks like I can use the backend as normal. Regards
Waennefredder
14 Posts
Waennefredder posted this 22 March 2018

Hello Nettie,

I might not understand you correctly sorry. Can you describe this point more detailed as I am not a native english speaker? That would be great.
And yes, I checked the option to remove everything.

Sincerely
Karsten

Hello Nettie, I might not understand you correctly sorry. Can you describe this point more detailed as I am not a native english speaker? That would be great. And yes, I checked the option to remove everything. Sincerely Karsten
DaveOzric
789 Posts
DaveOzric posted this 22 March 2018

What she is saying is you must assign the default menu item to the menu that is on the homepage. Themler needs to see the home or default menu item in the menu published on the homepage.

Another thing, can you see any other templates? Click the dropdown and choose Default for example. Does that show a template? If so then it's the menu problem. If not it's probably some other issue.

Screenshot-24.jpg

What she is saying is you must assign the default menu item to the menu that is on the homepage. Themler needs to see the home or default menu item in the menu published on the homepage. Another thing, can you see any other templates? Click the dropdown and choose Default for example. Does that show a template? If so then it's the menu problem. If not it's probably some other issue. !Screenshot-24.jpg!
Waennefredder
14 Posts
Waennefredder posted this 22 March 2018

Maybe I found it but if so it changed nothing.
There was the "create a post" menu entry set as default/home with linking to English language and special access. Changed this to the standard main menu with the standard home entry and "all" languages & public access but it did not help. This is the stand right now:

menu-view.png

Afterwards I checked the other point you said and I can see the list of templates in that dropdown (as said I just installed it new and try now to fix the issue with standard themler and standard template before restart) as well as opening successfully these templates for editing.
view-of-templates.png

Maybe I found it but if so it changed nothing. There was the "create a post" menu entry set as default/home with linking to English language and special access. Changed this to the standard main menu with the standard home entry and "all" languages & public access but it did not help. This is the stand right now: !menu-view.png! Afterwards I checked the other point you said and I can see the list of templates in that dropdown (as said I just installed it new and try now to fix the issue with standard themler and standard template before restart) as well as opening successfully these templates for editing. !view-of-templates.png!
Waennefredder
14 Posts
Waennefredder posted this 22 March 2018

Maybe I am completely wrong or full of work but...Just one more thing. I now copied the database link from backend and checked the given link with windows explorer where Themler was missing "error.php" (see first entry and picture).

for some reason I was curious and just created an error.php file like follows (for real beginners)

trial-error-php.png

the result is that Themler now loads this page instead of showing the message (of course still nothing to edit)

result-of-trial.png

My question now: might it be possible that the installation programm just did forget/overran to create the editable standard error.php page of Themler which finally would mean I just ran out of one page but basically all things worked fine?

Sincerely
Karsten
(Waennefredder)

Maybe I am completely wrong or full of work but...Just one more thing. I now copied the database link from backend and checked the given link with windows explorer where Themler was missing "error.php" (see first entry and picture). for some reason I was curious and just created an error.php file like follows (for real beginners) !trial-error-php.png! the result is that Themler now loads this page instead of showing the message (of course still nothing to edit) !result-of-trial.png! My question now: might it be possible that the installation programm just did forget/overran to create the editable standard error.php page of Themler which finally would mean I just ran out of one page but basically all things worked fine? Sincerely Karsten (Waennefredder)
DaveOzric
789 Posts
DaveOzric posted this 22 March 2018

Is the default menu item's single article published? Change the main menu default to Featured Articles and try it without your new error.php file.

Is the default menu item's single article published? Change the main menu default to Featured Articles and try it without your new error.php file.
Support Team
Support Team posted this 23 March 2018

Hello Karsten,

As for the error page - it should use use the corresponding template and output the text for "Text 404" control that is in the functions.php file. I would not recommend you to create some additional files for this.
Am I correct that the issue is present now on the Home template only?

Sincerely,
Nettie,
BillionDigital Team

Hello Karsten, As for the error page - it should use use the corresponding template and output the text for "Text 404" control that is in the `functions.php` file. I would not recommend you to create some additional files for this. Am I correct that the issue is present now on the Home template only? Sincerely, Nettie, BillionDigital Team
Waennefredder
14 Posts
Waennefredder posted this 23 March 2018

Is the default menu item's single article published? Change the main menu default to Featured Articles and try it without your new error.php file.

yes it is, and no it doens't solve the problem to change for featured articles as menu entry

> Is the default menu item's single article published? Change the main menu default to Featured Articles and try it without your new error.php file. yes it is, and no it doens't solve the problem to change for featured articles as menu entry
Waennefredder
14 Posts
Waennefredder posted this 23 March 2018

Hello Nettie,

the document was directly deleted after this - I just thought it might help to know (although o course I am neither know to Themler program structure nor programming php).

Finally and sadly you are correct. I still have this problem to be unable open & edit 404 page of themes. The other functions work as far as I can rate this.

Sincerely
Karsten
(Waennefredder)

Hello Nettie, the document was directly deleted after this - I just thought it might help to know (although o course I am neither know to Themler program structure nor programming php). Finally and sadly you are correct. I still have this problem to be unable open & edit 404 page of themes. The other functions work as far as I can rate this. Sincerely Karsten (Waennefredder)
Support Team
Support Team posted this 23 March 2018

Hello,

I mean that in Joomla some menu item shuold be marked as Front page as https://www.collectiveray.com/joomla/joomla-tips-and-tricks/5-changing-the-default-frontpage.html
Have you already done this?

Sincerely,
Nettie,
BillionDigital Team

Hello, I mean that in Joomla some menu item shuold be marked as Front page as https://www.collectiveray.com/joomla/joomla-tips-and-tricks/5-changing-the-default-frontpage.html Have you already done this? Sincerely, Nettie, BillionDigital Team
Waennefredder
14 Posts
Waennefredder posted this 23 March 2018

Hello,
ok I think I understood and already did this but maybe my language skills are not enough...
see here the Themler details (as mentioned so often: I use Themler standard, no modifications after installation - and already re-installed a lot including "delete old")
Opening Themler after installation looks like:

fresh-opened.jpg

Opening directly Theme for 404 pages looks like:
404-theme.jpg

Thinking to check/modify as per your suggestions is first here:
menu1.jpg

afterwards here:
menu2.jpg

and finally we have a check at the articles:
article.jpg

Hello, ok I think I understood and already did this but maybe my language skills are not enough... see here the Themler details (as mentioned so often: I use Themler standard, no modifications after installation - and already re-installed a lot including "delete old") Opening Themler after installation looks like: !fresh-opened.jpg! Opening directly Theme for 404 pages looks like: !404-theme.jpg! Thinking to check/modify as per your suggestions is first here: !menu1.jpg! afterwards here: !menu2.jpg! and finally we have a check at the articles: !article.jpg!
Support Team
Support Team posted this 24 March 2018

Hello,

Could you please try to rename the following folder into joomla-old and try to run Themler once again:

C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\joomla

Let us know if the issue with 404 Template persists.

Sincerely,
Nettie,
BillionDigital Team

Hello, Could you please try to rename the following folder into **joomla-old** and try to run Themler once again: C:\ProgramData\Themler\hd_data\themler_xxxxxxxxx\joomla Let us know if the issue with 404 Template persists. Sincerely, Nettie, BillionDigital Team
Waennefredder
14 Posts
Waennefredder posted this 24 March 2018

Hello,

sadly it does not change a thing.

For information: today I started finally to work out the needed theme. What can I say, published the new theme on webpage and it works obviously. Till now no problems found. AND an (unedited) correctly shown 404 page is available too.

404-online.png

Sincerely,
Karsten
(Waennefredder)

Hello, sadly it does not change a thing. For information: today I started finally to work out the needed theme. What can I say, published the new theme on webpage and it works obviously. Till now no problems found. AND an (unedited) correctly shown 404 page is available too. !404-online.png! Sincerely, Karsten (Waennefredder)
Support Team
Support Team posted this 26 March 2018

Hello Karsten,

Do I understand it correctly that the issue is present currently in Themler desktop only and with any theme?

Sincerely,
Nettie,
BillionDigital Team

Hello Karsten, Do I understand it correctly that the issue is present currently in Themler desktop only and with any theme? Sincerely, Nettie, BillionDigital Team
DaveOzric
789 Posts
DaveOzric posted this 26 March 2018

Hello, I am working with a new theme in the desktop version and have some issues now as well. I cannot get to my 404 page to edit it?

Screenshot-133.jpg

I can get to Home, and other templates OK so I can edit the 404 template on the live site later.

Hello, I am working with a new theme in the desktop version and have some issues now as well. I cannot get to my 404 page to edit it? !Screenshot-133.jpg! I can get to Home, and other templates OK so I can edit the 404 template on the live site later.
Support Team
Support Team posted this 26 March 2018

Hello Dave,

Do you have a new version of Themler desktop itself as well?

Sincerely,
Nettie,
BillionDigital Team

Hello Dave, Do you have a new version of Themler desktop itself as well? Sincerely, Nettie, BillionDigital Team
You must log in or register to leave comments