PHP error when edit Joomla-theme online (J! 3.8)

Seppe
118 Posts
Seppe posted this 2 weeks ago

Good afternoon

This is not in the latest 3.9 version of Joomla, the problem is already here in version 3.8.13
When trying to edit the themplate, I receive this error:

[PHP_ERROR]{"message":"\n\nOS: Linux com-linweb161 4.14.12-combell #1 SMP Mon Jan 8 12:29:26 CET 2018 x86_64\nPHP: 7.2.10\nerror handler: A non well formed numeric value encountered\nArray\n(\n [value] => 128M\n [str] => 128m\n)\n Callstack: \n -> Helper::toBytes('128M')\n -> Helper::getMemoryLimit()\n -> Helper::tryAllocateMemory()\n -> ExportController::execute(array(4) { ... })\n\n\n","type":"E_NOTICE","file":"/data/sites/web/MySite/www/templates/MyTemplate/app/classes/Helper.php","line":586}[PHP_ERROR]

Good afternoon This is not in the latest 3.9 version of Joomla, the problem is already here in version 3.8.13 When trying to edit the themplate, I receive this error: > [PHP_ERROR]{"message":"\n\nOS: Linux com-linweb161 4.14.12-combell #1 SMP Mon Jan 8 12:29:26 CET 2018 x86_64\nPHP: 7.2.10\nerror handler: A non well formed numeric value encountered\nArray\n(\n [value] => 128M\n [str] => 128m\n)\n Callstack: \n -> Helper::toBytes('128M')\n -> Helper::getMemoryLimit()\n -> Helper::tryAllocateMemory()\n -> ExportController::execute(array(4) { ... })\n\n\n","type":"E_NOTICE","file":"\/data\/sites\/web\/MySite\/www\/templates\/MyTemplate\/app\/classes\/Helper.php","line":586}[PHP_ERROR]
Vote to pay developers attention to this features or issue.
5 Comments
Order By: Standard | Newest
laertsky
8 Posts
laertsky posted this 2 weeks ago

change php version! 7.1 -> 5.6!

change php version! 7.1 -> 5.6!
Seppe
118 Posts
Seppe posted this 2 weeks ago

When my site is running PHP 5.6, I continiously get the message that I need to update

Your PHP version, 5.6.36, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-10-01. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

A lot of other websites already run version PHP version 7.2, without any problems

When my site is running PHP 5.6, I continiously get the message that I need to update > Your PHP version, 5.6.36, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-10-01. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions. A lot of other websites already run version PHP version 7.2, without any problems
laertsky
8 Posts
laertsky posted this 2 weeks ago

When my site is running PHP 5.6, I continiously get the message that I need to update

Your PHP version, 5.6.36, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-10-01. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

A lot of other websites already run version PHP version 7.2, without any problems

[PHP_ERROR]{"message":"\n\nOS: Linux com-linweb161 4.14.12-combell #1 SMP Mon Jan 8 12:29:26 CET 2018 x86_64\ nPHP: 7.2.10 \nerror handler: A non well formed numeric value encountered\nArray\n(\n [value] => 128M\n [str] => 128m\n)\n Callstack: \n ->

> When my site is running PHP 5.6, I continiously get the message that I need to update > > > Your PHP version, 5.6.36, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-10-01. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions. > > > A lot of other websites already run version PHP version 7.2, without any problems [PHP_ERROR]{"message":"\n\nOS: Linux com-linweb161 4.14.12-combell #1 SMP Mon Jan 8 12:29:26 CET 2018 x86_64\ **nPHP: 7.2.10** \nerror handler: A non well formed numeric value encountered\nArray\n(\n [value] => 128M\n [str] => 128m\n)\n Callstack: \n ->
laertsky
8 Posts
laertsky posted this 2 weeks ago

And what version of Themler?

And what version of Themler?
Seppe
118 Posts
Seppe posted this 2 weeks ago

I can't see ;)
That is the problem
I can't get into themler

I can't see ;) That is the problem I can't get into themler
You must log in or register to leave comments