Problemi con Wordpress e PHP 7

skalpo81
14 Posts
skalpo81 posted this 3 weeks ago

Buongiorno, dopo l'aggiornamento da parte dell'hosting del sito hotelvalgranda.it, accedendo al sito mi da degli errori che riporto qui di seguito e negli screenshots:

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-content/themes/Themler_Valgranda/functions.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-includes/pluggable.php on line 1251

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-includes/pluggable.php on line 1254

Ho sottoposto il problema al'hosting, dal quale mi hanno risposto che loro hanno aggiornato al PHP 7 e che questo ha causato un problema di incompatibilità. Sembra infatti che serva agiornare Themler al riguardo.

Da anche un ulteriore problema: se cerco di aprire themler da Firefox me lo rileva come device mobile e quindi incompatibile.

Attendo urgente risposta e aiuto

Buongiorno, dopo l'aggiornamento da parte dell'hosting del sito hotelvalgranda.it, accedendo al sito mi da degli errori che riporto qui di seguito e negli screenshots: Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-content/themes/Themler_Valgranda/functions.php on line 4 Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-includes/pluggable.php on line 1251 Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/prodolomiti.it/valgranda/wp-content/plugins/avk-background-manager/include/avk-background-setting.php:108) in /var/www/vhosts/prodolomiti.it/valgranda/wp-includes/pluggable.php on line 1254 Ho sottoposto il problema al'hosting, dal quale mi hanno risposto che loro hanno aggiornato al PHP 7 e che questo ha causato un problema di incompatibilità. Sembra infatti che serva agiornare Themler al riguardo. Da anche un ulteriore problema: se cerco di aprire themler da Firefox me lo rileva come device mobile e quindi incompatibile. Attendo urgente risposta e aiuto
Vote to pay developers attention to this features or issue.
6 Comments
Order By: Standard | Newest
Giuma
88 Posts
Giuma posted this 3 weeks ago

Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7

Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7
skalpo81
14 Posts
skalpo81 posted this 3 weeks ago

Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7

Ho già chiesto all'hosting di fare downgrade pho, ma mi hanno risposto, come puoi vedere dagli allegati, che PHP 5 non è più attuale

> Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7 Ho già chiesto all'hosting di fare downgrade pho, ma mi hanno risposto, come puoi vedere dagli allegati, che PHP 5 non è più attuale
skalpo81
14 Posts
skalpo81 posted this 3 weeks ago

Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7

Ho già chiesto all'hosting di fare downgrade pho, ma mi hanno risposto, come puoi vedere dagli allegati, che PHP 5 non è più attuale

In realtà i messaggi d'errore erano dati da un plugin "AVK" che mi modificava anche la formattazione del backend di Wordpress, dopo aver disattivato il quale tutto è tornato alla normalità.

Unica altra anomalia però è data da Themler, che già da un po' mi da problemi con Safari, ma che non me ne dava con Forefox. Ora con Safari non mi fa il login, mentre con Firefox e Chrome il login lo fa, ma non mi visualizza le impostazioni del template.

> > Fatti mettere la versione di php tipo 5.6 e poi aggiorna themler, poi fa rispristinare php 7 > > Ho già chiesto all'hosting di fare downgrade pho, ma mi hanno risposto, come puoi vedere dagli allegati, che PHP 5 non è più attuale In realtà i messaggi d'errore erano dati da un plugin "AVK" che mi modificava anche la formattazione del backend di Wordpress, dopo aver disattivato il quale tutto è tornato alla normalità. Unica altra anomalia però è data da Themler, che già da un po' mi da problemi con Safari, ma che non me ne dava con Forefox. Ora con Safari non mi fa il login, mentre con Firefox e Chrome il login lo fa, ma non mi visualizza le impostazioni del template.
Giuma
88 Posts
Giuma posted this 3 weeks ago

Allora come server ti consiglio uno in cui puoi sceglierti la versione di php
Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li

Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2
fai tutto da solo da pannelo cpanel

Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li)

Allora come server ti consiglio uno in cui puoi sceglierti la versione di php Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2 fai tutto da solo da pannelo cpanel Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li)
assistenza.storm
20 Posts
assistenza.storm posted this 2 weeks ago

Allora come server ti consiglio uno in cui puoi sceglierti la versione di php
Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li

Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2
fai tutto da solo da pannelo cpanel

Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li)

Aruba lo uso da 11 anni per tutti i miei clienti e la versione php la decidi tu da cpanel. Giusto per correttezza di informazione.

> Allora come server ti consiglio uno in cui puoi sceglierti la versione di php > Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li > > Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2 > fai tutto da solo da pannelo cpanel > > Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li) > > > > Aruba lo uso da 11 anni per tutti i miei clienti e la versione php la decidi tu da cpanel. Giusto per correttezza di informazione.
skalpo81
14 Posts
skalpo81 posted this 2 weeks ago

Allora come server ti consiglio uno in cui puoi sceglierti la versione di php
Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li

Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2
fai tutto da solo da pannelo cpanel

Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li)

Aruba lo uso da 11 anni per tutti i miei clienti e la versione php la decidi tu da cpanel. Giusto per correttezza di informazione.

vi ringrazio per i consigli e l'aiuto.

Attualmente il mio cliente ha come hosting Flame Networks e dal loro CPanel non è possibile scegliere in autonomia la versione PHP da utilizzare.

Mi hanno risposto che loro hanno aggiornato a PHP7 in quanto versione più recente e che sono io a dover adattare il mio template.

> > Allora come server ti consiglio uno in cui puoi sceglierti la versione di php > > Se prendi per esempio Aruba hosting linux easy, non aggiornano di loro iniziativa mai, ho un lavoro su php 4.4 del 2005 che sta ancora li > > > > Se prendi invece netsons mono o multidominio puoi sceglierti la versione che vuoi a partire dalla 4.4 in su fino alla attuale 7.2 > > fai tutto da solo da pannelo cpanel > > > > Ho provato ora login ed è perfetto, ti consiglio di provare da un diverso computer pc (tipo con windows i browser installati li) > > > > > > > > > > Aruba lo uso da 11 anni per tutti i miei clienti e la versione php la decidi tu da cpanel. Giusto per correttezza di informazione. vi ringrazio per i consigli e l'aiuto. Attualmente il mio cliente ha come hosting Flame Networks e dal loro CPanel non è possibile scegliere in autonomia la versione PHP da utilizzare. Mi hanno risposto che loro hanno aggiornato a PHP7 in quanto versione più recente e che sono io a dover adattare il mio template.
You must log in or register to leave comments