Problem with Social Links feature for the header

David at Acoma
7 Posts
David at Acoma posted this 15 May 2019

I think there is a problem when inserting a link to a facebook page and ask for it to be treated as a static URL, Themler currently converts that to a share page link, which is not what we need. we have share icons elsewhere these are links to the facebook page itself.

If I switch the URL to Static URL with Share, it does that same thing, which is correct for static url with share, but its not meant to be the same when you use Static URL only.

The only solution I have is to not use your Social group feature and go with manual icons and wrap a link on them, which is time-consuming.

PS also any news on this Chrome issue, as I develop in Chrome but now need to use Firefox on Themler and the rest in Chrome.

I think there is a problem when inserting a link to a facebook page and ask for it to be treated as a static URL, Themler currently converts that to a share page link, which is not what we need. we have share icons elsewhere these are links to the facebook page itself. If I switch the URL to Static URL with Share, it does that same thing, which is correct for static url with share, but its not meant to be the same when you use Static URL only. The only solution I have is to not use your Social group feature and go with manual icons and wrap a link on them, which is time-consuming. PS also any news on this Chrome issue, as I develop in Chrome but now need to use Firefox on Themler and the rest in Chrome.
Vote to pay developers attention to this features or issue.
6 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 16 May 2019

Hello David,

Under Insert menu tab in Themler you can add Social Links (which is used only for sharing purposes) or Icon. When inserting an Icon, you can (as you mentioned) pick a social icon image and add a link to social media. This is standard options for adding links to social media.

As for the issue with Chrome, try this:
1) navigate to:
chrome://appcache-internals
find your website and click on 'Remove Item'
2) navigate to:
chrome://settings/clearBrowserData
select 'Cached images and files ' and click on 'Clear Data' (please don't check other check-boxes).
3) Reload your Themler Editor.

If you are using the Desktop version, then:
1) close Themler
2) open Windows Explorer and type %LocalAppData% in the address bar
3) find & rename Themler directory
4) start Themler again

Gina
Themler Support

Hello David, Under Insert menu tab in Themler you can add Social Links (which is used only for sharing purposes) or Icon. When inserting an Icon, you can (as you mentioned) pick a social icon image and add a link to social media. This is standard options for adding links to social media. As for the issue with Chrome, try this: 1) navigate to: chrome://appcache-internals find your website and click on 'Remove Item' 2) navigate to: chrome://settings/clearBrowserData select 'Cached images and files ' and click on 'Clear Data' (please don't check other check-boxes). 3) Reload your Themler Editor. If you are using the Desktop version, then: 1) close Themler 2) open Windows Explorer and type %LocalAppData% in the address bar 3) find & rename Themler directory 4) start Themler again Gina Themler Support
David at Acoma
7 Posts
David at Acoma posted this 16 May 2019

Thank you for the Chrome Themler issue advice, worked!

On the Social Icons feature. Please take a link, I was not asking how you create the icon, but I was talking about the setting not working. See attached files.
I want a static URL and not a share URL But regardless of setting, this triggers the share FB function.

Thank you for the Chrome Themler issue advice, worked! On the Social Icons feature. Please take a link, I was not asking how you create the icon, but I was talking about the setting not working. See attached files. I want a static URL and not a share URL But regardless of setting, this triggers the share FB function.
David at Acoma
7 Posts
David at Acoma posted this 20 May 2019

Hello??

Hello??
Support Team
Support Team posted this 21 May 2019

Hello,

We are sorry for delay in response. You may consider using Icon Link control - there a link can be set like you wish.

Sincerely,
Nettie

Hello, We are sorry for delay in response. You may consider using Icon Link control - there a link can be set like you wish. Sincerely, Nettie
David at Acoma
7 Posts
David at Acoma posted this 21 May 2019

GGrrrrr. this is getting annoying, as this is what I am already using and it does not make a difference on the icon function, I want a static link to the business page so they can look around. BUT THE LINK IS A SHARE LINK. THE STATIC LINK FUNCTION DOES NOT WORK. IF YOU CONTINUE TO NOT UNDERSTAND THE FAULT THEN I WILL PRODUCE A VIDEO WITH THE FULL SEQUENCE.

the website is https://dev.spelthornebusinessforum.uk and the temp password is 2019

Please look at the icons in the top right. these are meant to be static URLs only, no share function, but regardless of how the function is set in the icon link control panel, it forces a share function to trigger.

I AM RUNNING OUT OF WAYS OF SAYING THIS AND YOU KEEP COMING BACK WITH ANSWER DEMONSTRATING YOU ARE NOT UNDERSTANDING MY PROBLEM. I LOVE YOU PRODUCT BUT GOD THIS IS DRIVING ME NUTS

GGrrrrr. this is getting annoying, as this is what I am already using and it does not make a difference on the icon function, I want a static link to the business page so they can look around. BUT THE LINK IS A SHARE LINK. THE STATIC LINK FUNCTION DOES NOT WORK. IF YOU CONTINUE TO NOT UNDERSTAND THE FAULT THEN I WILL PRODUCE A VIDEO WITH THE FULL SEQUENCE. the website is https://dev.spelthornebusinessforum.uk and the temp password is 2019 Please look at the icons in the top right. these are meant to be static URLs only, no share function, but regardless of how the function is set in the icon link control panel, it forces a share function to trigger. I AM RUNNING OUT OF WAYS OF SAYING THIS AND YOU KEEP COMING BACK WITH ANSWER DEMONSTRATING YOU ARE NOT UNDERSTANDING MY PROBLEM. I LOVE YOU PRODUCT BUT GOD THIS IS DRIVING ME NUTS
Support Team
Support Team posted this 24 May 2019

Hello,

Sorry but from the page code it looks like you still use Social Icon controls instead of the Icon. The control mentioned by me and Gina can be found in the Insert tab and is called just Icon. After it is added, you will be able to set a static link like this:

i506.png

Let us know if there are any issues with it either.

Sincerely,
Nettie

Hello, Sorry but from the page code it looks like you still use Social Icon controls instead of the Icon. The control mentioned by me and Gina can be found in the Insert tab and is called just Icon. After it is added, you will be able to set a static link like this: !i506.png! Let us know if there are any issues with it either. Sincerely, Nettie

Last edited 24 May 2019 by Support Team

You must log in or register to leave comments