How to disable linked images (lightbox?)

john.oxlade
17 Posts
john.oxlade posted this 19 August 2015

Probably me doing something simple (and wrong), but in my Joomla articles, clicking on images opens them in a lightbox - which I don't want. I want to be able to link the images, but the lightbox feature seems to take precedence.
How do I turn it off?
(I started with the default them/template and have been modifying it as I go)
Thanks.

Probably me doing something simple (and wrong), but in my Joomla articles, clicking on images opens them in a lightbox - which I don't want. I want to be able to link the images, but the lightbox feature seems to take precedence. How do I turn it off? (I started with the default them/template and have been modifying it as I go) Thanks.
Vote to pay developers attention to this features or issue.
47 Comments
Order By: Standard | Newest
Chuck_c1M5xGbOnw
6 Posts
Chuck_c1M5xGbOnw posted this 22 February 2016

While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better.

https://imgur.com/a/wYgce

While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better. https://imgur.com/a/wYgce
Katarzyna
7 Posts
Katarzyna posted this 18 April 2016

While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better.

https://imgur.com/a/wYgce

THANK YOU!! :) :)

> While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better. > > https://imgur.com/a/wYgce THANK YOU!! :) :)
john.oxlade
17 Posts
john.oxlade posted this 04 May 2016

I am going through a new site and am having the same problem. Even though I have turned off lightbox in post-content on all of my templates, the "page" one is still acting like it is on.
It is not obvious that you have to highlight the posts section of the page for the posts tab to appear.

I am going through a new site and am having the same problem. Even though I have turned off lightbox in post-content on all of my templates, the "page" one is still acting like it is on. It is not obvious that you have to highlight the posts section of the page for the posts tab to appear.
Support Team
Support Team posted this 04 May 2016

Hi,

If you still have issues with the lightbox on the page template, please attach your theme so we could review the settings.

Sincerely,
Hella

Hi, If you still have issues with the lightbox on the page template, please attach your theme so we could review the settings. Sincerely, Hella
john.oxlade
17 Posts
john.oxlade posted this 04 May 2016

Hi,

If you still have issues with the lightbox on the page template, please attach your theme so we could review the settings.

Sincerely,
Hella

Yes, still not working as I would expect it to, so here's the them as a .zip
Thnaks

> Hi, > > If you still have issues with the lightbox on the page template, please attach your theme so we could review the settings. > > Sincerely, > Hella Yes, still not working as I would expect it to, so here's the them as a .zip Thnaks

Last edited 04 May 2016 by john.oxlade

Support Team
Support Team posted this 06 May 2016

Hello John,

It looks like the theme was exported without possibility to customize theme in Themler, so the Edit in Themler button does not appear. Could you please check?

Sincerely,
Nettie,
BillionDigital Team

Hello John, It looks like the theme was exported without possibility to customize theme in Themler, so the Edit in Themler button does not appear. Could you please check? Sincerely, Nettie, BillionDigital Team
john.oxlade
17 Posts
john.oxlade posted this 08 May 2016

With Thelmer included.

With Thelmer included.
Support Team
Support Team posted this 10 May 2016

Hi John,

Image Lightbox is disabled and works for me as expected with your theme installed on my end (with sample content). Images in Posts on a Page template are not clickable.
Please create a new private topic and provide temporary access to your website backend for investigation.

Sincerely,
Nettie,
BillionDigital Team

Hi John, Image Lightbox is disabled and works for me as expected with your theme installed on my end (with sample content). Images in Posts on a Page template are not clickable. Please create a new private topic and provide temporary access to your website backend for investigation. Sincerely, Nettie, BillionDigital Team
Kalman
5 Posts
Kalman posted this 11 May 2016

Hi,

I managed to solve this. Hope this helps.

If you have tried the above and found it does not work, try the following:
1. Navigate to a 'Page' (not a post), within Themler,
2. Click on one of the images you are having problems with
3. Finally, choose 'Post Content' from the icons on the left control panel and turn off 'image Lightbox'

I trust you are having the same problem as me, as the previous suggestions did not work for me either, but this does.

I think this is either a bug, a process that is a little confusing in itself. Perhaps there should be a separate Lightbox control under Pages and Posts (assuming the process provided above by Support works for Posts - have not tried this yet as I am not using Posts). It is a bit of a shame that the control is all or nothing. Would be great if we could choose per page, or if a Shortcode could be used to activate this. Perhaps something for the next update maybe?

This worked perfectly! I never enabled this in the first place but somehow it was activated. I pointed blame towards a few extensions at first but after switching the template I saw that it was something caused here.

To clear things up, make sure you select 'Page' from the dropdown as Morpheus0101 mentioned. By default 'Post' under Blog Templates is selected instead of 'Page' under Main Templates.

![enter image description here][1]

From there you can select Posts then Post Content to get to the lightbox option. Mine was set to ON and this was why I was getting the automatic lightbox for EVERY image.

![enter image description here][2]

If you need the lightbox feature, there are tons of free plugins on JED (or you can use JS) that can do this outside of the template.

[1]: http://i.imgur.com/XuPzwN9.png
[2]: http://i.imgur.com/9ksgALW.png

Hi,

It helped!

Thank you!

Hi, > > I managed to solve this. Hope this helps. > > > > If you have tried the above and found it does not work, try the following: > > 1. Navigate to a 'Page' (not a post), within Themler, > > 2. Click on one of the images you are having problems with > > 3. Finally, choose 'Post Content' from the icons on the left control panel and turn off 'image Lightbox' > > > > I trust you are having the same problem as me, as the previous suggestions did not work for me either, but this does. > > > > I think this is either a bug, a process that is a little confusing in itself. Perhaps there should be a separate Lightbox control under Pages and Posts (assuming the process provided above by Support works for Posts - have not tried this yet as I am not using Posts). It is a bit of a shame that the control is all or nothing. Would be great if we could choose per page, or if a Shortcode could be used to activate this. Perhaps something for the next update maybe? > > > > > > This worked perfectly! I never enabled this in the first place but somehow it was activated. I pointed blame towards a few extensions at first but after switching the template I saw that it was something caused here. > > To clear things up, make sure you select 'Page' from the dropdown as Morpheus0101 mentioned. By default 'Post' under Blog Templates is selected instead of 'Page' under Main Templates. > > ![enter image description here][1] > > > From there you can select Posts then Post Content to get to the lightbox option. Mine was set to ON and this was why I was getting the automatic lightbox for EVERY image. > > ![enter image description here][2] > > If you need the lightbox feature, there are tons of free plugins on JED (or you can use JS) that can do this outside of the template. > > > [1]: http://i.imgur.com/XuPzwN9.png > [2]: http://i.imgur.com/9ksgALW.png Hi, It helped! Thank you!
uvikmedium
7 Posts
uvikmedium posted this 17 August 2016

я могу отключить лайтбокс у блога, записи, но у страницы по умолчанию не могу, не появляется нужная вкладка для настройки, только "сайдбары и контент" а там настройки нет

я могу отключить лайтбокс у блога, записи, но у страницы по умолчанию не могу, не появляется нужная вкладка для настройки, только "сайдбары и контент" а там настройки нет
Support Team
Support Team posted this 18 August 2016

Hi,

There is a Path line at the bottom of the preview area:

path-line-2.png

If Page template outputs CMS content you can navigate Posts or Post Content control in Path.

Thank you,
Olivia

Hi, There is a Path line at the bottom of the preview area: !path-line-2.png! If Page template outputs CMS content you can navigate Posts or Post Content control in Path. Thank you, Olivia
bsjelin
40 Posts
bsjelin posted this 08 December 2016

Hello - I am having issues with this as well - I have disabled lightbox for pages and posts, but I am still receiving popups from my template for product images in hikashop. Any ideas on how to disable this as hikashop products are not directly supported? I removed the store options from the template thinking that might remove it but its still using a shadowbox.

example page: https://www.timelessgala.com/shop/clothing/jackets/product/198-heather

Hello - I am having issues with this as well - I have disabled lightbox for pages and posts, but I am still receiving popups from my template for product images in hikashop. Any ideas on how to disable this as hikashop products are not directly supported? I removed the store options from the template thinking that might remove it but its still using a shadowbox. example page: https://www.timelessgala.com/shop/clothing/jackets/product/198-heather
Support Team
Support Team posted this 08 December 2016

Hi,

That is not a Themler lightbox. Maybe you will need to search for some options in Hikashop.

Sincerely,
Hella

Hi, That is not a Themler lightbox. Maybe you will need to search for some options in Hikashop. Sincerely, Hella
hardcpz
11 Posts
hardcpz posted this 10 March 2017

While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better.

https://imgur.com/a/wYgce

That sorted it out for me. Thank you so much!:)

> While modifying the post layout may be easy, modifying the page layout may be a little more tricky. In order to completely disable the lightbox then you have to disable it on both. Feel free to check out the tutorial I created that explains this better. > > https://imgur.com/a/wYgce That sorted it out for me. Thank you so much!:)
john.oxlade
17 Posts
john.oxlade posted this 18 September 2017

Without me doing anything, this problem has come back again but with the revised Themler layout, the options are no longer in the same places as above.
So, as of Sept 2017, with the latest Themler template updates, how do I turn off the lightbox?
This is URGENT.
I have no idea why this suddenly came back on again when I haven't done anything.

Without me doing anything, this problem has come back again but with the revised Themler layout, the options are no longer in the same places as above. So, as of Sept 2017, with the latest Themler template updates, how do I turn off the lightbox? This is URGENT. I have no idea why this suddenly came back on again when I haven't done anything.
Support Team
Support Team posted this 18 September 2017

Hi,

This option is still under the Posts control >> Post Content drop down option. Have a look to the screen:

lightbox-off-1.png

Sincerely,
Hella

Hi, This option is still under the Posts control >> Post Content drop down option. Have a look to the screen: !lightbox-off-1.png! Sincerely, Hella
john.oxlade
17 Posts
john.oxlade posted this 18 September 2017

Except that mine doesn't look anything like that...

Except that mine doesn't look anything like that...
Support Team
Support Team posted this 18 September 2017

Hi,

Look at the bottom of the screen shot I have provided above. The Posts control is selected in the bottom breadcrumbs. Then you will see the Posts options in the top ribbon.

Sincerely,
Hella

Hi, Look at the bottom of the screen shot I have provided above. The Posts control is selected in the bottom breadcrumbs. Then you will see the Posts options in the top ribbon. Sincerely, Hella
john.oxlade
17 Posts
john.oxlade posted this 18 September 2017

Hang on, I just found it, and it is off but it is still behaving as a lightbox.

Hang on, I just found it, and it is off but it is still behaving as a lightbox.
john.oxlade
17 Posts
john.oxlade posted this 18 September 2017

I have tried turning it on and back on again. It makes no difference.

I have tried turning it on and back on again. It makes no difference.
You must log in or register to leave comments