Google Analytics not working on Joomla 3.4.5...

pawel.neografix
13 Posts
pawel.neografix posted this 06 November 2015

Why do not the statistics Google Analytics, adds them as an extra html settings in the head or hand in notepad ++ file homeX.php and in both cases the statistics do not work on a few already google pages ... Is templates Themler should be done differently, just with information about cookies (in terms of Joomla 3.4.5)?

Why do not the statistics Google Analytics, adds them as an extra html settings in the head or hand in notepad ++ file homeX.php and in both cases the statistics do not work on a few already google pages ... Is templates Themler should be done differently, just with information about cookies (in terms of Joomla 3.4.5)?
Vote to pay developers attention to this features or issue.
8 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 09 November 2015

Hi,

Sorry for the delay.
As far as I know Google Analytics code should be added to the BODY section, isn't it?
Anyway, if you need to add some js code to the HEAD section please add it under the Themler Settings >> Additional HEAD html.
If you need to add some js to the BODY section you can either add HTML control to the very bottom of the page with desired js or add joomla module position control to the same place and put the joomla Custom HTML module into this position.

Please let us know if you have any further questions.

Thank you,
Olivia

Hi, Sorry for the delay. As far as I know Google Analytics code should be added to the BODY section, isn't it? Anyway, if you need to add some js code to the HEAD section please add it under the Themler Settings >> Additional HEAD html. If you need to add some js to the BODY section you can either add HTML control to the very bottom of the page with desired js or add joomla module position control to the same place and put the joomla Custom HTML module into this position. Please let us know if you have any further questions. Thank you, Olivia
info12345
30 Posts
info12345 posted this 26 January 2016

I still can't work this out. Can you please give me more detail on adding the analytics script to the body of the HTML. Google asks for it to be placed right after the opening <body> tag.</body>

I still can't work this out. Can you please give me more detail on adding the analytics script to the body of the HTML. Google asks for it to be placed right after the opening &lt;body&gt; tag.&lt;/body&gt;
info12345
30 Posts
info12345 posted this 26 January 2016

Ok worked out how to do it via custom HTML module.. should work but I would have preferred being able to place it just after <body> tag</body>

Ok worked out how to do it via custom HTML module.. should work but I would have preferred being able to place it just after &lt;body&gt; tag&lt;/body&gt;
Support Team
Support Team posted this 27 January 2016

Hi,

Sorry about that, but there is no such option to include the code directly after the opening <body> tag.

Sincerely,
Hella

Hi, Sorry about that, but there is no such option to include the code directly after the opening `<body>` tag. Sincerely, Hella
tmgarrison
67 Posts
tmgarrison posted this 21 February 2016

Hella and Olivia,

Google Analytics code "must" be added within the <head></head> - usually just before the closing </head>

According to everything I find in Themler, adding the code to the Settings >> Additional Head HTML is "supposed" to work - but it does not.
I've added it, confirmed by closing the template and then reopening, reviewing each of the various template pages within Themler, and "every" part of the template indicates that the code is as stated (above).

However, when viewing the "source" for any page of the site, there is NO code!
I've reviewed the various template files within Joomla (Extensions >> Templates >> Templates >> ?themeler template? >>) and none of them show the code that is clearly in the "Additional Head HTML" box.

After 5 or 6 attempts to figure out the reason it wasn't appearing, even after I'd cleared Joomla cache, refreshed the pages, refreshed and re-saved the template (many times), nothing worked.

Then, in the Themler editor, I went to File >> CMS >> Refresh Content
The code finally appeared just before the </head> tag as expected.

Please have the developers review this to find out why the "Additional Head HTML" code doesn't appear immediately. It seems there is something wrong with the cache that's only related to that additional code. Any other changes to the template are immediate after saving the changes.

UPDATE!
The first site I described (above) uses only 1 template.
If you use 2 (or more) different templates in the same site, the analytics code will not work in the pages that have been assigned a template "other" than the "default" template.

I'm using 1 template for the home page, and another template for the default pages (etc.), and 1 template assigned to 1 page in order to have a slider appear on only that 1 page.
The analytics code only appears on the home page. That template was originally the only template and is assigned as the default template.

I've saved, reloaded, refreshed, cleared cache, done everything I can think and the analytics code only appears in the home page. I even switched and made the secondary template the default, but that was no help.

This "must" be addressed or those of us who are dependent upon reviewing our analytics will have no way to monitor site statistics.

My "workaround":
I added the analytics code directly to the "/templates/page_7.php" and that worked...for the pages using that template. I also added the code to /templates/page_10.php and that worked to get the code on my single page using its own template. I also added the code to /templates/page_6.php, /templates/home_1.php, /templates/default_2.php, hoping that any other page would have the analytics. I'm not selling anything, so I'm not concerned about the productoverview or products_3 pages.

This amounts to what I have always done with Joomla - add analytics to the "index.php" of any template I'm using. Only with Themler, all of the /templates/ pages need to have the code added.

If the developers can get Themler to actually "include" the code that appears in "Additional Head HTML" to "every" template, regardless of which template is assigned as the default template for the site, then I'll remove the code from where I had to manually add analytics in order for every page of the site to have analytics code appear.

Thanks.
Thomas

Hella and Olivia, Google Analytics code "must" be added within the &lt;head&gt;&lt;/head&gt; - usually just before the closing &lt;/head&gt; According to everything I find in Themler, adding the code to the Settings >> Additional Head HTML is "supposed" to work - but it does not. I've added it, confirmed by closing the template and then reopening, reviewing each of the various template pages within Themler, and "every" part of the template indicates that the code is as stated (above). However, when viewing the "source" for any page of the site, there is NO code! I've reviewed the various template files within Joomla (Extensions >> Templates >> Templates >> ?themeler template? >>) and none of them show the code that is clearly in the "Additional Head HTML" box. After 5 or 6 attempts to figure out the reason it wasn't appearing, even after I'd cleared Joomla cache, refreshed the pages, refreshed and re-saved the template (many times), nothing worked. Then, in the Themler editor, I went to File >> CMS >> Refresh Content The code finally appeared just before the &lt;/head&gt; tag as expected. Please have the developers review this to find out why the "Additional Head HTML" code doesn't appear immediately. It seems there is something wrong with the cache that's only related to that additional code. Any other changes to the template are immediate after saving the changes. UPDATE! The first site I described (above) uses only 1 template. If you use 2 (or more) different templates in the same site, the analytics code will not work in the pages that have been assigned a template "other" than the "default" template. I'm using 1 template for the home page, and another template for the default pages (etc.), and 1 template assigned to 1 page in order to have a slider appear on only that 1 page. The analytics code only appears on the home page. That template was originally the only template and is assigned as the default template. I've saved, reloaded, refreshed, cleared cache, done everything I can think and the analytics code only appears in the home page. I even switched and made the secondary template the default, but that was no help. This "must" be addressed or those of us who are dependent upon reviewing our analytics will have no way to monitor site statistics. My "workaround": I added the analytics code directly to the "/templates/page_7.php" and that worked...for the pages using that template. I also added the code to /templates/page_10.php and that worked to get the code on my single page using its own template. I also added the code to /templates/page_6.php, /templates/home_1.php, /templates/default_2.php, hoping that any other page would have the analytics. I'm not selling anything, so I'm not concerned about the productoverview or products_3 pages. This amounts to what I have always done with Joomla - add analytics to the "index.php" of any template I'm using. Only with Themler, all of the /templates/ pages need to have the code added. If the developers can get Themler to actually "include" the code that appears in "Additional Head HTML" to "every" template, regardless of which template is assigned as the default template for the site, then I'll remove the code from where I had to manually add analytics in order for every page of the site to have analytics code appear. Thanks. Thomas

Last edited 21 February 2016 by tmgarrison

Support Team
Support Team posted this 26 February 2016

Hello Thomas,
thank you for details.
However I failed to reproduce both of reported issues. The code added to Settings >> Additional HEAD HTML is added immediately to template .php files. And it is added to new created template.

If you could repeat the issue(s) on any of your themes please provide access to your Joomla admin back end so we could investigate it.

regards,
Aileen

Hello Thomas, thank you for details. However I failed to reproduce both of reported issues. The code added to Settings >> Additional HEAD HTML is added immediately to template .php files. And it is added to new created template. If you could repeat the issue(s) on any of your themes please provide access to your Joomla admin back end so we could investigate it. regards, Aileen
tmgarrison
67 Posts
tmgarrison posted this 09 June 2016

Hi Aileen,

This is "still" an issue. Today, I'm working on a WordPress site. I've been "fighting" with Themler and "All in one SEO". AIOSEO wants to add the code, and that's fine. But it seems to also include an external file that Google refuses to allow. So Google keeps telling me that the code is not valid.
I also had it added directly to the index.php page, which then duplicated the code in the source.

I took the code out of Themler, deleted the code I placed in index.php, and deleted the AIOSEO plugin. Whew...back to no code which was better than duplicating and Google refusing to read whatever AIOSEO created.

Then today I switched to YOAST SEO. There is nowhere to include the analytics code, so that's a plus in my book. So I added the code (again) from the "Home" file into the "Settings > Additional Head HTML".

I refreshed Themler, saved, clicked on the "Publish" icon, and even went to "File > CMS > Refresh" and for the life of me I can't get the code to appear in the site.

I've checked all the various templates (Home; Page; Post; Blog; Default; etc.) and each shows the code in "Additional Head HTML".
EVERY page EXCEPT the home page shows the analytics code in the front end of the site!
???

While I was writing this I was making some edits on the home page and must have refreshed the content at least a dozen times.
Still, "no" analytics code on the home page...only the others.

I'll check my Joomla projects, but I think they are alright. It seems WordPress is giving me a fit.

Thanks.
Thomas

Hi Aileen, This is "still" an issue. Today, I'm working on a WordPress site. I've been "fighting" with Themler and "All in one SEO". AIOSEO wants to add the code, and that's fine. But it seems to also include an external file that Google refuses to allow. So Google keeps telling me that the code is not valid. I also had it added directly to the index.php page, which then duplicated the code in the source. I took the code out of Themler, deleted the code I placed in index.php, and deleted the AIOSEO plugin. Whew...back to no code which was better than duplicating and Google refusing to read whatever AIOSEO created. Then today I switched to YOAST SEO. There is nowhere to include the analytics code, so that's a plus in my book. So I added the code (again) from the "Home" file into the "Settings > Additional Head HTML". I refreshed Themler, saved, clicked on the "Publish" icon, and even went to "File > CMS > Refresh" and for the life of me I can't get the code to appear in the site. I've checked all the various templates (Home; Page; Post; Blog; Default; etc.) and each shows the code in "Additional Head HTML". EVERY page EXCEPT the home page shows the analytics code in the front end of the site! ??? While I was writing this I was making some edits on the home page and must have refreshed the content at least a dozen times. Still, "no" analytics code on the home page...only the others. I'll check my Joomla projects, but I think they are alright. It seems WordPress is giving me a fit. Thanks. Thomas
Support Team
Support Team posted this 15 June 2016

Hi,

You can add your custom HTML code to Head.
1. Open Settings on Ribbon Home tab.
2. Add your custom HTML HEAD code in Field on right panel.

HEAD-HTML-code.jpg

All this code Themler should add within and tag.

You can add your custom CMS code to WEB page by CMS code control. You can find it on Insert Ribbon Tab.

cms-code-control.jpg

Thank you,
Themler Team

Hi, You can add your custom HTML code to Head. 1. Open Settings on Ribbon Home tab. 2. Add your custom HTML HEAD code in Field on right panel. !HEAD-HTML-code.jpg! All this code Themler should add within <head> and </head> tag. You can add your custom CMS code to WEB page by CMS code control. You can find it on Insert Ribbon Tab. !cms-code-control.jpg! Thank you, Themler Team
You must log in or register to leave comments