shortcode is removing paragraph formatting

urbanhaze
11 Posts
urbanhaze posted this 20 January 2016

Hi,
Could you help please, I've got a page in a themler site - if I add [one_half] shortcode around the text then it removes all the paragraph formatting from the page (with or without the wordpress auto paragraph checkbox - makes no difference)

If I remove the [one_half] shortcodes then the formatting returns as normal
I've checked the html and cleaned it - there are no other spurious tags, so it looks like something to do with the shortcode.

Please let me know if you need me to make this a private message so that you can login and take a look

Thank you

Hi, Could you help please, I've got a page in a themler site - if I add [one_half] shortcode around the text then it removes all the paragraph formatting from the page (with or without the wordpress auto paragraph checkbox - makes no difference) If I remove the [one_half] shortcodes then the formatting returns as normal I've checked the html and cleaned it - there are no other spurious tags, so it looks like something to do with the shortcode. Please let me know if you need me to make this a private message so that you can login and take a look Thank you
Vote to pay developers attention to this features or issue.
6 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 23 January 2016

Hi,

Paragraphs are not working inside Themler shortcodes.
If you need paragraph formatting please use [text] shortcode or edit content inside Themler.

Thank you,
Olivia

Hi, Paragraphs are not working inside Themler shortcodes. If you need paragraph formatting please use `[text]` shortcode or edit content inside Themler. Thank you, Olivia
urbanhaze
11 Posts
urbanhaze posted this 25 January 2016

Thanks Olivia,
I tried adding [text] and [/text] within the [one_half] [/one_half] shortcode and it didn't solve the problem so that it looks like:
[one_half][text]Column 2

New Para[/text][/one_half]

However, the text "Column 2" is still displayed immediately next to the text "New Para" - rather than one above another.

I'm not familiar with the [text] shortcode, it doesn't seem to be documented with the other shortcodes here:
https://answers.themler.com/articles/3621/shortcodes-overview

There isn't an option to edit code inside Themler as the user needs to be able to make regular changes to the page content using WordPress as normal without having extra tools just to make changes.

Please could you provide more information on how to use it to solve the problem?

Many thanks

Thanks Olivia, I tried adding [text] and [/text] within the [one_half] [/one_half] shortcode and it didn't solve the problem so that it looks like: [one_half][text]Column 2 New Para[/text][/one_half] However, the text "Column 2" is still displayed immediately next to the text "New Para" - rather than one above another. I'm not familiar with the [text] shortcode, it doesn't seem to be documented with the other shortcodes here: https://answers.themler.com/articles/3621/shortcodes-overview There isn't an option to edit code inside Themler as the user needs to be able to make regular changes to the page content using WordPress as normal without having extra tools just to make changes. Please could you provide more information on how to use it to solve the problem? Many thanks
Support Team
Support Team posted this 25 January 2016

Hi,

You should wrap each paragraph with text-shortcode.

The following code will work:
[one_half]
[text]Column 2[/text]
[text]New Para[/text]
[/one_half]

Thanks,
Ivan

Hi, You should wrap **each** paragraph with text-shortcode. The following code will work: [one_half] [text]Column 2[/text] [text]New Para[/text] [/one_half] Thanks, Ivan
urbanhaze
11 Posts
urbanhaze posted this 25 January 2016

Thanks Ivan,
I can confirm that solution worked

However, it is very painful to wrap each paragraph in these [text] tags and is something that a normal user wouldn't want to do once they've got any more than two or three paragraphs. One of the conveniences of using WordPress is having a WYSIWYG editor, if adding one short code requires additional shortcodes just for content to be formatted normally, then I could see there being compatibility issues.

Is possible for these [one_half] shortcodes to behave like other WordPress column shortcodes that just let the content within them behave normally as it does in the WYSIWYG editor please?

After all, it's not really a "short" code if you then need to add even more tags to make the rest of the content behave as normal :)

Thanks Ivan, I can confirm that solution worked However, it is very painful to wrap each paragraph in these [text] tags and is something that a normal user wouldn't want to do once they've got any more than two or three paragraphs. One of the conveniences of using WordPress is having a WYSIWYG editor, if adding one short code requires additional shortcodes just for content to be formatted normally, then I could see there being compatibility issues. Is possible for these [one_half] shortcodes to behave like other WordPress column shortcodes that just let the content within them behave normally as it does in the WYSIWYG editor please? After all, it's not really a "short" code if you then need to add even more tags to make the rest of the content behave as normal :)
Support Team
Support Team posted this 27 January 2016

Hello Nick,
you may try HTML shortcode and use HTML tags inside, e.g.

    [html]
<p>    line 1</p>
<p>    line 2</p>
<p>    line 3</p>
    [/html]

It will be detected as HTML Control in Themler.

regards,
Aileen

Hello Nick, you may try HTML shortcode and use HTML tags inside, e.g. [html] <p> line 1</p> <p> line 2</p> <p> line 3</p> [/html] It will be detected as HTML Control in Themler. regards, Aileen
nick6
7 Posts
nick6 posted this 5 days ago

So in order to maintain paragraph layout in WordPress, I have to go back and add [text] [/text] shortcodes to each of the paragraphs? This is a serious bug that you guys need to fix. Nobody should have to do this extra work to maintain this simple paragraph formatting. Please find a solution to this in your next themler update.

So in order to maintain paragraph layout in WordPress, I have to go back and add [text] [/text] shortcodes to each of the paragraphs? This is a serious bug that you guys need to fix. Nobody should have to do this extra work to maintain this simple paragraph formatting. Please find a solution to this in your next themler update.
You must log in or register to leave comments