Woocommerce shortcodes not working

Seagull
116 Posts
Seagull posted this 13 March 2016

After trying it out in several Themler, Artisteer and other themes I can confirm that the Woocommerce shortcodes are not working with Themler themes but that they are with others.

The shortcodes I've tried so far are the ones to output new items, sale items and best sellers on a page/post.

The shortcodes only partially pull the css from Themler and leave off the buttons and any links to the products. The product images just link to a lightbox although that may be me missing something in the settings of the theme?

Best regards,
Angela

After trying it out in several Themler, Artisteer and other themes I can confirm that the Woocommerce shortcodes are not working with Themler themes but that they are with others. The shortcodes I've tried so far are the ones to output new items, sale items and best sellers on a page/post. The shortcodes only partially pull the css from Themler and leave off the buttons and any links to the products. The product images just link to a lightbox although that may be me missing something in the settings of the theme? Best regards, Angela
Vote to pay developers attention to this features or issue.
4 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 15 March 2016

Hello Angela,
if you have faced with the issues related to shortcodes other than described in the topic http://answers.themler.com/questions/66885/displaying-latest-stock-in-woocommerce-without-a-slider
please describe them here in details.

Regards,
Aileen

Hello Angela, if you have faced with the issues related to shortcodes other than described in the topic http://answers.themler.com/questions/66885/displaying-latest-stock-in-woocommerce-without-a-slider please describe them here in details. Regards, Aileen
Seagull
116 Posts
Seagull posted this 15 March 2016

It looks like a conflict with the Beaver Builder layout plugin that I use on most of my sites, if I use a button shortcode in a a page or post in Beaver Builder it looks good in the BB preview but upon saving it only shows as code.

On a vanilla page without BB page builder the buttons work fine.
Beaver Builder Plugin

Best regards,
Angela

It looks like a conflict with the Beaver Builder layout plugin that I use on most of my sites, if I use a button shortcode in a a page or post in Beaver Builder it looks good in the BB preview but upon saving it only shows as code. On a vanilla page without BB page builder the buttons work fine. [Beaver Builder Plugin][1] [1]: https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwi_3__m08LLAhUGvhQKHVPxDzUQFggjMAA&url=https://www.wpbeaverbuilder.com/&usg=AFQjCNGqIcMW2Zn5cPLU1WnGLkUBElOUtA&sig2=j9fer0zoIlrObxcAxPWhKg Best regards, Angela
Seagull
116 Posts
Seagull posted this 15 March 2016

Working button example

Broken button with Beaver Builder (same site)

[Working button example][1] [Broken button with Beaver Builder (same site)][2] [1]: https://ladyfyre-graphics.com/the-gallery/3d-horse-digital-gallery/ [2]: https://ladyfyre-graphics.com/the-gallery/
Support Team
Support Team posted this 16 March 2016

Hello Angela,
the issue with buttons is that CSS class reference is removed on the page where Beaver Builder plugin is used.
Here is the button with CSS class (I added it manually using browser developer tools)

WithClass.png

and here the the initial page

WithoutClass.png

I'd recommend that you contact plugin developer or support about this issue - removing CSS classes.

regards,
Aileen

Hello Angela, the issue with buttons is that CSS class reference is removed on the page where Beaver Builder plugin is used. Here is the button with CSS class (I added it manually using browser developer tools) !WithClass.png! and here the the initial page !WithoutClass.png! I'd recommend that you contact plugin developer or support about this issue - removing CSS classes. regards, Aileen
You must log in or register to leave comments