Full Row Background

jason58
1 Posts
jason58 posted this 17 May 2016

I'm trying to create a theme and use it in WP with Visual Composer and have run into and issue with trying to make my row backgournd (in VC) full width, the theme from Themler seems to be overriding the row width controls?

I have my Content and Sidebars length set to "Full Background", when I go to Wordpress to edit a page I use Visual Composer to try and make a full width row (stretched) the theme is not allowing the background element (in this case a single color) to expand past the desktop layout grid of 1200px?

I've tried setting the length to "Page Width" but this lets items in Visual composer run all the way to the edge of the browser window. I would like to know how I can achieve a 1200px center container while sill allowing VC to run a row full width?

Any input would be great, thanks.

I'm trying to create a theme and use it in WP with Visual Composer and have run into and issue with trying to make my row backgournd (in VC) full width, the theme from Themler seems to be overriding the row width controls? I have my Content and Sidebars length set to "Full Background", when I go to Wordpress to edit a page I use Visual Composer to try and make a full width row (stretched) the theme is not allowing the background element (in this case a single color) to expand past the desktop layout grid of 1200px? I've tried setting the length to "Page Width" but this lets items in Visual composer run all the way to the edge of the browser window. I would like to know how I can achieve a 1200px center container while sill allowing VC to run a row full width? Any input would be great, thanks.
Vote to pay developers attention to this features or issue.
2 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 20 May 2016

Hello Jason,
it is difficult to say anything definite without testing your page and theme.

Please try to open theme in Themler >> Home tab >> Settings >> general and increase the width for Desktop under Layout Grid section.

Let us know the results

regards,
Aileen

Hello Jason, it is difficult to say anything definite without testing your page and theme. Please try to open theme in Themler >> Home tab >> Settings >> general and increase the width for Desktop under Layout Grid section. Let us know the results regards, Aileen
Messy
3 Posts
Messy posted this 4 weeks ago

I had the same problems. Everytime I saved the VC page, the layout was changed and I had to change the page width in Themler again from Fluid to Wide. I added the next CSS in Themler, so I can use Wide rows:

/Themler wide layout code for Visual composer/
@media (min-width: 768px){
.vce-row-content {
max-width: 750px;
}
}
@media (min-width: 992px){
.vce-row-content {
max-width: 1000px;
}
}
@media (min-width: 1200px){
.vce-row-content {
max-width: 1200px;
}
}
.vce-row-content {
margin-left: auto;
margin-right: auto;
padding-right: 0px!important;
padding-left: 0px!important;
width: 100%;
}

Hope this helps

I had the same problems. Everytime I saved the VC page, the layout was changed and I had to change the page width in Themler again from Fluid to Wide. I added the next CSS in Themler, so I can use Wide rows: /*Themler wide layout code for Visual composer*/ @media (min-width: 768px){ .vce-row-content { max-width: 750px; } } @media (min-width: 992px){ .vce-row-content { max-width: 1000px; } } @media (min-width: 1200px){ .vce-row-content { max-width: 1200px; } } .vce-row-content { margin-left: auto; margin-right: auto; padding-right: 0px!important; padding-left: 0px!important; width: 100%; } Hope this helps
You must log in or register to leave comments