Problem template is_preview=on&template

Giuseppe-_70
11 Posts
Giuseppe-_70 posted this 10 August 2016

Hi, google sees the url of my site with this code, why? How to solve this problem?
http://www.xxxxxxxxx.it/xxxxx.html?is_preview=on&template=cs02

Please it is urgent!
Best regards
Giuseppe

Hi, google sees the url of my site with this code, why? How to solve this problem? http://www.xxxxxxxxx.it/xxxxx.html?is_preview=on&template=cs02 Please it is urgent! Best regards Giuseppe
Vote to pay developers attention to this features or issue.
44 Comments
Order By: Standard | Newest
DaveOzric
605 Posts
DaveOzric posted this 10 June 2017

This is interesting because they are all 200 response codes so Google thinks they are still there. They will technically always be there until you switch templates I suppose. So yes the .htacess fix with the 404 would be the fastest way to get rid of them out of Google's index. Still a massive pain to manage in GSC once they are all errors to fix.

Here's my timeline. I added a few pages, maybe 10 after the site got indexed 1/1/17 but look at this chart. 2/19-2/26 is when the error started.

2017-06-10-155837.jpg

This is interesting because they are all 200 response codes so Google thinks they are still there. They will technically always be there until you switch templates I suppose. So yes the .htacess fix with the 404 would be the fastest way to get rid of them out of Google's index. Still a massive pain to manage in GSC once they are all errors to fix. Here's my timeline. I added a few pages, maybe 10 after the site got indexed 1/1/17 but look at this chart. 2/19-2/26 is when the error started. !2017-06-10-155837.jpg!
DaveOzric
605 Posts
DaveOzric posted this 10 June 2017

Not to mention my domain authority went from 24 to 19 around the same time. These are serious bugs and must be address asap.

Not to mention my domain authority went from 24 to 19 around the same time. These are serious bugs and must be address asap.
DaveOzric
605 Posts
DaveOzric posted this 10 June 2017

RewriteCond %{QUERY_STRING} template=you&is_preview=on
RewriteRule ^.*$  - [R=404,L]

or

RewriteCond %{QUERY_STRING} template=you&is_preview=on
    RewriteRule ^.*$  - [R=410,L]

Unfortunately on my site these don't seem to work. Both of these just render the page with no styles.

> RewriteCond %{QUERY_STRING} template=you&is_preview=on > RewriteRule ^.*$ - [R=404,L] > or > > > RewriteCond %{QUERY_STRING} template=you&is_preview=on > RewriteRule ^.*$ - [R=410,L] Unfortunately on my site these don't seem to work. Both of these just render the page with no styles.
Denis L.
45 Posts
Denis L. posted this 12 June 2017

Same here! Sigh!

Other then that, are the Themler Devs ignoring us and/or that bug?!

I remember a year or two ago, in previous versions this URL destroying bug was not there. How is it so hard for them to remove that stupid template preview thing in URLs?! Don't they know it's a website destroyer on SEO side?! Such a quality product that's gonna take a plunge downhill if that stupid bug isn't fixed.

As paying customer, we're all entitle to a fix ASAP on this major bug that has been sitting around for way to long.

Come on Themler Devs, do something about it... it should be priority #1 before adding some new stuff.

Please acknowledge our demand here... we're not asking for fancy gadgets, we're asking you to fix your product so our sites SEO can stop being destroyed.

Same here! Sigh! Other then that, **are the Themler Devs ignoring us and/or that bug?!** I remember a year or two ago, in previous versions this URL destroying bug was not there. How is it so hard for them to remove that stupid template preview thing in URLs?! Don't they know it's a website destroyer on SEO side?! Such a quality product that's gonna take a plunge downhill if that stupid bug isn't fixed. As paying customer, we're all entitle to a fix ASAP on this major bug that has been sitting around for way to long. Come on Themler Devs, do something about it... it should be priority #1 before adding some new stuff. Please acknowledge our demand here... we're not asking for fancy gadgets, we're asking you to fix your product so our sites SEO can stop being destroyed.
DaveOzric
605 Posts
DaveOzric posted this 12 June 2017

Exactly

Exactly
Paul T
28 Posts
Paul T posted this 15 June 2017

This is the same problem that is mentioned in this thread:
https://answers.themler.com/questions/124389/when-i-edit-template-in-themler-all-my-links-get-template-festivalvendeev21-is_preview-on-added-every-time?page=1

As of 15 June 2017 there is no solution provided on that thread either.

This is the same problem that is mentioned in this thread: https://answers.themler.com/questions/124389/when-i-edit-template-in-themler-all-my-links-get-template-festivalvendeev21-is_preview-on-added-every-time?page=1 As of 15 June 2017 there is no solution provided on that thread either.
kheidemann
42 Posts
kheidemann posted this 15 June 2017

Sure would be nice to get some bug fixes stat. I am using this for my business. I know I would pay more to get faster turnaround for bug fixes in a heartbeat.

Good idea Dave. If for some reason Themler can't afford to provide timely support, perhaps they could charge a fee for a premium support option for those of us who can't afford to wait several days for simple fixes.

> Sure would be nice to get some bug fixes stat. I am using this for my business. I know I would pay more to get faster turnaround for bug fixes in a heartbeat. Good idea Dave. If for some reason Themler can't afford to provide timely support, perhaps they could charge a fee for a premium support option for those of us who can't afford to wait several days for simple fixes.
Paul T
28 Posts
Paul T posted this 15 June 2017

Themler support has now replied on the other thread

Themler support has now replied on the other thread
Support Team
Support Team posted this 16 June 2017

Hi,

Sorry for the delay. Issue with the preview suffix in the links is fixed on our end. We need some more time to complete the testing phase and after that the update will be released.

Sincerely,
Hella

Hi, Sorry for the delay. Issue with the preview suffix in the links is fixed on our end. We need some more time to complete the testing phase and after that the update will be released. Sincerely, Hella
Paul T
28 Posts
Paul T posted this 16 June 2017

Excellent thank you!

Excellent thank you!
DaveOzric
605 Posts
DaveOzric posted this 16 June 2017

Thank you

Thank you
Giuseppe-_70
11 Posts
Giuseppe-_70 posted this 16 June 2017

Grazie

Grazie
Denis L.
45 Posts
Denis L. posted this 16 June 2017

Finally! Thanks for that!
Hope it's gonna be pushed out soon...

Please advise us here when the fix is released so we can know when to re-open our projects and correct this.

Finally! Thanks for that! Hope it's gonna be pushed out soon... Please advise us here when the fix is released so we can know when to re-open our projects and correct this.

Last edited 16 June 2017 by Denis L.

Denis L.
45 Posts
Denis L. posted this 26 June 2017

Hi,

Two weeks and the supposedly "fixed" preview suffix bug is still not pushed out to us?! How long does it take to test a bug that you fix? I have new projects on the table and this bug is really starting to get on my nerves.

Can we have a fix already? Please!

Sorry for being a bit jumpy but you told us it was fixed on your end... not doing a favor to your own clients by holding off on an important bug like this.

Hi, Two weeks and the supposedly "fixed" preview suffix bug is still not pushed out to us?! How long does it take to test a bug that you fix? I have new projects on the table and this bug is really starting to get on my nerves. Can we have a fix already? Please! Sorry for being a bit jumpy but you told us it was fixed on your end... not doing a favor to your own clients by holding off on an important bug like this.
DaveOzric
605 Posts
DaveOzric posted this 26 June 2017

I am not sure why it's such a major deal to produce an updated version. Some programs do bug fix updates weekly. It's too quite around here lately.

I am not sure why it's such a major deal to produce an updated version. Some programs do bug fix updates weekly. It's too quite around here lately.
Giuseppe-_70
11 Posts
Giuseppe-_70 posted this 12 July 2017

Hi, have not you solved this problem yet?

Hi, have not you solved this problem yet?
Paul T
28 Posts
Paul T posted this 12 July 2017

This hasn't been fixed in Themler v.382

This hasn't been fixed in Themler v.382
Giuseppe-_70
11 Posts
Giuseppe-_70 posted this 12 July 2017

Please, can you tell us about the timings?

Please, can you tell us about the timings?
Giuseppe-_70
11 Posts
Giuseppe-_70 posted this 12 July 2017

In August, one year after the opening of this report.

In August, one year after the opening of this report.
Support Team
Support Team posted this 13 July 2017

Hi,

This issue is fixed in the latest beta update. You need to update theme, save changes and refresh the page with F5. And the issue should not happen with the new links. If you encounter any problems please let us know.

Thank you,
Olivia

Hi, This issue is fixed in the latest beta update. You need to update theme, save changes and refresh the page with F5. And the issue should not happen with the new links. If you encounter any problems please let us know. Thank you, Olivia
You must log in or register to leave comments