PHP and MySQL Updates

allayit
1 Posts
allayit posted this 30 August 2016

Not sure if I'm doing something wrong or if this is an issue with the update practice of Themler dev team.

These are the current versions of PHP and MySQL that I've got installed as part of the Themler install:

MySQL 5.5.42 - insecure version of PHP
PHP 5.4.42 - now end of life

I'm someone who tries to keep up with patching of insecure and end of life products so having these versions of software on my computer are a concern.

Is Themler behind the curve on MySQL and PHP updates or do I need to do some Themler updates?

Is there a web doc that shows how to update these manually by downloading the latest secure versions from the PHP and MySQL websites?

Thanks.

Regards

John

Not sure if I'm doing something wrong or if this is an issue with the update practice of Themler dev team. These are the current versions of PHP and MySQL that I've got installed as part of the Themler install: MySQL 5.5.42 - insecure version of PHP PHP 5.4.42 - now end of life I'm someone who tries to keep up with patching of insecure and end of life products so having these versions of software on my computer are a concern. Is Themler behind the curve on MySQL and PHP updates or do I need to do some Themler updates? Is there a web doc that shows how to update these manually by downloading the latest secure versions from the PHP and MySQL websites? Thanks. Regards John
Vote to pay developers attention to this features or issue.
3 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 31 August 2016

Hello John,
in fact the MySQL version 5.5.42 security issue was false positive as I know
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=784982

However you may update PHP and MySQL versions, they're installed to
MySQL Databases

C:\ProgramData\Themler\db_data

Themler, Apache, MySQL and PHP binaries:

C:\Program Files (x86)\Themler

http://answers.themler.com/articles/14435/themler-desktop-faq

Unfortunately there're no special docs on update PHP, MySQL for Themler Desktop is available. I suppose that you may use standard PHP, MySQL update instructions

regards,
Aileen

Hello John, in fact the MySQL version 5.5.42 security issue was false positive as I know https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=784982 However you may update PHP and MySQL versions, they're installed to MySQL Databases C:\ProgramData\Themler\db_data Themler, Apache, MySQL and PHP binaries: C:\Program Files (x86)\Themler http://answers.themler.com/articles/14435/themler-desktop-faq Unfortunately there're no special docs on update PHP, MySQL for Themler Desktop is available. I suppose that you may use standard PHP, MySQL update instructions regards, Aileen
len
140 Posts
len posted this 04 November 2017

I am equally concerned about this.
I have looked at the above links, but cannot work out what I need to download for each and the how to instal them to the correct place.
Can we please have an unambiguous procedure at to HOW to upgrade both apache, php and MySQL to the Themler environment. Which exact version of each to download, and then how to install.
Thanks
LenW

I am equally concerned about this. I have looked at the above links, but cannot work out what I need to download for each and the how to instal them to the correct place. Can we please have an unambiguous procedure at to HOW to upgrade both apache, php and MySQL to the Themler environment. Which exact version of each to download, and then how to install. Thanks LenW
Support Team
Support Team posted this 08 November 2017

Hi,

Why exactly you want to update php and MySQL libraries in Themler Desktop? They does not affect created theme. It is just sample installation of webserver and CMS. You can make your own installation with versions you need and with with Themler. Just like you can use Themler theme with Themler of the remote CMS installation.
Currently we do not plan to update php and MySQL in Themler Desktop installation because these a sample installations that do not assume their use for production websites. It is just a place where you can create a theme and then move it to your production server.

Thank you,
Olivia

Hi, Why exactly you want to update php and MySQL libraries in Themler Desktop? They does not affect created theme. It is just sample installation of webserver and CMS. You can make your own installation with versions you need and with with Themler. Just like you can use Themler theme with Themler of the remote CMS installation. Currently we do not plan to update php and MySQL in Themler Desktop installation because these a sample installations that do not assume their use for production websites. It is just a place where you can create a theme and then move it to your production server. Thank you, Olivia
You must log in or register to leave comments