Themler Active Menu incorrect in Wordpress

len
140 Posts
len posted this 07 November 2016

On the Wordpress home page, the active menu highlight is on the top level of a submenu item, with the non-clickable URL set to either a blank or # (the Wordpress recommended way).

Menu structure is:
Home
Information (with submenu items) page 1, page 2

The top level "Information" item is a custom link in Wordpress, with the URL set to either a blank or # (the Wordpress recommended way).

On the Home page, the Information item is highlighted as active irrespective is the blank or # in the URL.

In Artisteer and previous versions of Themler, setting the top level to # has always worked, with the correct top level highlighted.

There is another Answers thread with a similar issue, that suggests setting the URL to www. This does solve the highlighting of the active item, but if the website visitor clicks the top level link (which has no page associated with it) it results in a page not found. This is not a solution. http://answers.themler.com/questions/68559/active-menu-item-not-displaying-in-wordpress

How can this be fixed please?

On the Wordpress home page, the active menu highlight is on the top level of a submenu item, with the non-clickable URL set to either a blank or # (the Wordpress recommended way). Menu structure is: Home Information (with submenu items) page 1, page 2 The top level "Information" item is a custom link in Wordpress, with the URL set to either a blank or # (the Wordpress recommended way). On the Home page, the Information item is highlighted as active irrespective is the blank or # in the URL. In Artisteer and previous versions of Themler, setting the top level to # has always worked, with the correct top level highlighted. There is another Answers thread with a similar issue, that suggests setting the URL to www. This does solve the highlighting of the active item, but if the website visitor clicks the top level link (which has no page associated with it) it results in a page not found. This is not a solution. http://answers.themler.com/questions/68559/active-menu-item-not-displaying-in-wordpress How can this be fixed please?
Vote to pay developers attention to this features or issue.
8 Comments
Order By: Standard | Newest
Kolkata Aira
1 Posts
Kolkata Aira posted this 28 January 2022

Good post and to be here

Good post and to be here
Orange Gorilla
53 Posts
Orange Gorilla posted this 27 January 2022

Someone any idea how to fix this?

Someone any idea how to fix this?
Orange Gorilla
53 Posts
Orange Gorilla posted this 25 January 2022

Hi> Hello,

Are you using Themler v547?

And your WordPress is also the latest version?

Gina
Themler Support

Hi,
yes, last beta version.
And latest worpress vesion (5.8.3)

Hi> Hello, > > Are you using Themler v547? > > And your WordPress is also the latest version? > > Gina > Themler Support Hi, yes, last beta version. And latest worpress vesion (5.8.3)
Support Team
Support Team posted this 24 January 2022

Hello,

Are you using Themler v547?

And your WordPress is also the latest version?

Gina
Themler Support

Hello, Are you using Themler v547? And your WordPress is also the latest version? Gina Themler Support
Orange Gorilla
53 Posts
Orange Gorilla posted this 24 January 2022

Is this a Themler issue again? beacuse i'm dealing with it within the current version.

Is this a Themler issue again? beacuse i'm dealing with it within the current version.
Support Team
Support Team posted this 07 November 2016

Len, you are welcome! Please feel free to contact us in any other case.

Sincerely,
Nettie,
BillionDigital Team

Len, you are welcome! Please feel free to contact us in any other case. Sincerely, Nettie, BillionDigital Team
len
140 Posts
Is Solution
len posted this 07 November 2016

Nettie
That was a very quick response.
Done, and yes v.355 has fixed it, thanks.
LenW

Nettie That was a very quick response. Done, and yes v.355 has fixed it, thanks. LenW
Support Team
Support Team posted this 07 November 2016

Hello,

Please try updating to the latest Beta version. The issue should be fixed there, the behaviour should be correct with default settings (without any additional changes). You may need to check the box next to "Get Beta updates" in your profile to receive the Beta update notification. After installing the Beta update you may uncheck the box at an time.
Please let us know if the issue is still present.

Sincerely,
Nettie,
BillionDigital Team

Hello, Please try updating to the latest Beta version. The issue should be fixed there, the behaviour should be correct with default settings (without any additional changes). You may need to check the box next to "Get Beta updates" in your profile to receive the Beta update notification. After installing the Beta update you may uncheck the box at an time. Please let us know if the issue is still present. Sincerely, Nettie, BillionDigital Team
You must log in or register to leave comments