Themler - Different CMS platform - Versions

Stagger Lee
1840 Posts
Stagger Lee posted this 09 November 2016

Some topic with retroperspective how different CMS and versions are covered.

09-11-2016

  • Wordpress 4.6.1 = Themler works with latest version, mostly due to philosophy of WP to not break backward compatibility.
  • Joomla 3.6.4 = Seems to work, did not try.

  • Drupal = 8.2.0. Themler supports versions 7.x. First stable version 8.0.0 was out 19-11-2015
    One year. Please stop talking about non-existent extern Drupal developer. Say it as it is, no big deal. First Drupal Alpha was out 24-06-2013. Already then your "extern developer" could start to study code. Maybe not to start to make Themler options, it would be stupid in this stage, but for sure he could make herself familiar with new platform. Of course if he existed.

  • Prestashop = 1.7. Themler supports 1.6 version.
    (Stable version released 07-11-2016. First Alpha released 04-04-2016. But OK, despite you should have non-production code somehow to up to 60% ready even on Alpha, Beta, RC versions. To not to start develop for new versions only when stable comes out. As we see until now this business model doesnt work well for you. You are allways to late.)

  • Magento = 2,1,2 = 12-10-2016
    Themler supports 1.9.1.0 version (is it ??!!). 24.11.2014.
    First 2.x stable version was out 17-11-2015, one year now. But developing code was out for at least 3 years

Everything is OK. It is not easy to develop complex tool as Themler for so many CMS and keep it updated for all new versions. Just say frankly how it goes, and how it will be. All you say feels like very bad excuses, and making it to win more time to sell more licences.

Some topic with retroperspective how different CMS and versions are covered. **09-11-2016** - **Wordpress 4.6.1** = Themler works with latest version, mostly due to philosophy of WP to not break backward compatibility. - **Joomla 3.6.4** = Seems to work, did not try. - **Drupal = 8.2.0.** Themler supports versions 7.x. First stable version 8.0.0 was out 19-11-2015 **One year. Please stop talking about non-existent extern Drupal developer. Say it as it is, no big deal. First Drupal Alpha was out 24-06-2013. Already then your "extern developer" could start to study code. Maybe not to start to make Themler options, it would be stupid in this stage, but for sure he could make herself familiar with new platform. Of course if he existed.** - **Prestashop = 1.7.** Themler supports 1.6 version. (Stable version released 07-11-2016. First Alpha released 04-04-2016. But OK, despite you should have non-production code somehow to up to 60% ready even on Alpha, Beta, RC versions. To not to start develop for new versions only when stable comes out. As we see until now this business model doesnt work well for you. You are allways to late.) - **Magento = 2,1,2** = 12-10-2016 Themler supports 1.9.1.0 version (is it ??!!). 24.11.2014. **First 2.x stable version was out 17-11-2015, one year now. But developing code was out for at least 3 years** Everything is OK. It is not easy to develop complex tool as Themler for so many CMS and keep it updated for all new versions. Just say frankly how it goes, and how it will be. All you say feels like very bad excuses, and making it to win more time to sell more licences.

Last edited 09 November 2016 by Stagger Lee

Vote to pay developers attention to this features or issue.
1 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 11 November 2016

Hi,

Currently I can say that beta version of Drupal 8 themes will be available within next two weeks. It's ready, but we need to solve a few problems with subscriptions.
Really, this is not our project. The Drupal export is created by one of our developers in his free of work time because there was no Drupal export in our initial plans for Themler. This export is not such popular as Joomla or WordPress. He decided to create Drupal export because he knows this CMS and he created Drupal export for Artisteer. But this is his project and we cannot affect it from our side.
And that's why it requires separate subscription.

We started to work on PrestaShop 1.7 themes recently. Most probably this will be a separate export too. Unfortunately I cannot say more at this time.

And unfortunately we have no plans to support Magento 2.0 in the near future. This project requires a lot of resources. But Magento export is not really popular. The number of Themler+Magento users is lower than number of PS+Themler users. Therefore we do not see much point in spending time on it. But this task is in our backlog for future consideration.

Thank you,
Olivia

Hi, Currently I can say that beta version of **Drupal 8** themes will be available within next two weeks. It's ready, but we need to solve a few problems with subscriptions. Really, this is not our project. The Drupal export is created by one of our developers in his *free of work time* because there was no Drupal export in our initial plans for Themler. This export is not such popular as Joomla or WordPress. He decided to create Drupal export because he knows this CMS and he created Drupal export for Artisteer. But this is his project and we cannot affect it from our side. And that's why it requires separate subscription. We started to work on **PrestaShop 1.7** themes recently. Most probably this will be a separate export too. Unfortunately I cannot say more at this time. And unfortunately we have no plans to support **Magento 2.0** in the near future. This project requires a lot of resources. But Magento export is not really popular. The number of Themler+Magento users is lower than number of PS+Themler users. Therefore we do not see much point in spending time on it. But this task is in our backlog for future consideration. Thank you, Olivia
You must log in or register to leave comments