shortcodes issue on php version over 7.0

souacz
50 Posts
souacz posted this 10 September 2018

Hi, I noticed the issue using shortcodes one_half, one_third etc. When the php version is set to 7.0 shortcodes work correct but on versions 7.1 and 7.2 the shortcodes do not arrange the columns and the column's contents are one under the other.

sample (php 7.0): http://marcintafelski.pl/ and http://marcintafelski.pl/kontakt
sample (php 7.2): http://kapita.pl/ and http://kapita.pl/kontakt

Hi, I noticed the issue using shortcodes one_half, one_third etc. When the php version is set to 7.0 shortcodes work correct but on versions 7.1 and 7.2 the shortcodes do not arrange the columns and the column's contents are one under the other. sample (php 7.0): [http://marcintafelski.pl/][1] and [http://marcintafelski.pl/kontakt][2] sample (php 7.2): [http://kapita.pl/][3] and [http://kapita.pl/kontakt][4] [1]: http://marcintafelski.pl/ [2]: http://marcintafelski.pl/kontakt [3]: http://kapita.pl/ [4]: http://kapita.pl/kontakt

Last edited 10 September 2018 by souacz

Vote to pay developers attention to this features or issue.
27 Comments
Order By: Standard | Newest
SRuff
20 Posts
SRuff posted this 21 September 2018

Hi Dave,

Looks like you refer to the same issue here as in the topic https://answers.themler.io/questions/171179/no-more-shortcodes-now-what
Let's continue discussion in that topic.

Thank you,
Nettie

I have the exact problem. I renewed my license and the update caused the error.
Warning: Illegal string offset 'width' in /home/__/public_html/plugins/content/themlercontent/lib/Shortcodes.php on line 1492
Is there a fix?
Thank you

> Hi Dave, > > Looks like you refer to the same issue here as in the topic https://answers.themler.io/questions/171179/no-more-shortcodes-now-what > Let's continue discussion in that topic. > > Thank you, > Nettie I have the exact problem. I renewed my license and the update caused the error. Warning: Illegal string offset 'width' in /home/______/public_html/plugins/content/themlercontent/lib/Shortcodes.php on line 1492 Is there a fix? Thank you
DaveOzric
925 Posts
DaveOzric posted this 21 September 2018

No one knows when you removed this or if it's purely a PHP issue? The details are extremely simple. Read the initial post in this thread and you will see exactly what is wrong. The columns shortcode you had instructed us to use is no longer working with PHP 7.1 or above.

What else is there to tell you?

No one knows when you removed this or if it's purely a PHP issue? The details are extremely simple. Read the initial post in this thread and you will see exactly what is wrong. The columns shortcode you had instructed us to use is no longer working with PHP 7.1 or above. What else is there to tell you?
Support Team
Support Team posted this 21 September 2018

Hello,

Thank you all for your input. The shortcodes should work, so we will investigate the issue together with our developers. The question left now is whether anything has changed namely after the latest Themler update.

Sincerely,
Nettie

Hello, Thank you all for your input. The shortcodes should work, so we will investigate the issue together with our developers. The question left now is whether anything has changed namely after the latest Themler update. Sincerely, Nettie
souacz
50 Posts
souacz posted this 21 September 2018

This is issue specific for php. I did not update templates before before it came out, only upgraded the php version for domain. After this operation the columns showed up one under the other

This is issue specific for php. I did not update templates before before it came out, only upgraded the php version for domain. After this operation the columns showed up one under the other

Last edited 21 September 2018 by souacz

DaveOzric
925 Posts
DaveOzric posted this 21 September 2018

A fix would be nice so I do not have to update the site's I have used it on. Going forward I believe I will use only Bootstrap column divs. Although updating to a new version of Bootstrap will probably hose that up too.

A fix would be nice so I do not have to update the site's I have used it on. Going forward I believe I will use only Bootstrap column divs. Although updating to a new version of Bootstrap will probably hose that up too.
Support Team
Support Team posted this 21 September 2018

Hello,

I see, thank yo for your comments. We will update this topic as soon as there is information from our developers on the issue.

Sincerely,
Nettie

Hello, I see, thank yo for your comments. We will update this topic as soon as there is information from our developers on the issue. Sincerely, Nettie
mail152
1 Posts
mail152 posted this 18 October 2018

Do you have an update yet for the shortcodes.php?

Still got an error under PHP 7.1. and the shortcodes not work at all:
PHP Warning: Illegal string offset 'width' in /is/htdocs/wp12541520_O6HFRBX9R9/www/Theme/library/shortcodes.php on line 78

Best regards
Daniel

Do you have an update yet for the shortcodes.php? Still got an error under PHP 7.1. and the shortcodes not work at all: PHP Warning: Illegal string offset 'width' in /is/htdocs/wp12541520_O6HFRBX9R9/www/Theme/library/shortcodes.php on line 78 Best regards Daniel
You must log in or register to leave comments