Drupal Theme not Saving, keeps blinking the sign in overlay box

nmcfadden
17 Posts
nmcfadden posted this 2 weeks ago

I am attempting to save my Themler after making some changes. When I click "SAVE" the overlay login box appears and then disappears over and over (see attached image). It looks like it is having trouble seeing that I am logged in already or something. Not sure what is happening. It won't let me save or export. Please help!

I am attempting to save my Themler after making some changes. When I click "SAVE" the overlay login box appears and then disappears over and over (see attached image). It looks like it is having trouble seeing that I am logged in already or something. Not sure what is happening. It won't let me save or export. Please help!
Vote to pay developers attention to this features or issue.
14 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 2 weeks ago

Hello,
Sorry for the inconvenience. We have found the problem. It's related to a security update in Google Chrome v80.
If you are using Google Chrome, try this:
1) navigate to:
chrome://appcache-internals
find your website and click on 'Remove Item'
2) navigate to:
chrome://settings/clearBrowserData
select 'Cached images and files ' and click on 'Clear Data' (please don't check other check-boxes).
3) Reload your Themler Editor.
Some users have reported that complete re-install of Google Chrome solved the issue.

If you are using the Desktop version, then:
1) close Themler
2) open Windows Explorer and type %LocalAppData% in the address bar
3) find & rename Themler directory
4) start Themler again

Gina
Themler Support

Hello, Sorry for the inconvenience. We have found the problem. It's related to a security update in Google Chrome v80. If you are using Google Chrome, try this: 1) navigate to: chrome://appcache-internals find your website and click on 'Remove Item' 2) navigate to: chrome://settings/clearBrowserData select 'Cached images and files ' and click on 'Clear Data' (please don't check other check-boxes). 3) Reload your Themler Editor. Some users have reported that complete re-install of Google Chrome solved the issue. If you are using the Desktop version, then: 1) close Themler 2) open Windows Explorer and type %LocalAppData% in the address bar 3) find & rename Themler directory 4) start Themler again Gina Themler Support
nmcfadden
17 Posts
nmcfadden posted this 2 weeks ago

Happy to report that the second set of instructions under "Desktop version" worked. I tried the first set of instructions, but couldn't get passed step 1. Also, I reinstalled Chrome, but it still did not work.

It took a while for Themler to reopen after I renamed the directory, but it worked. Thank you.

Happy to report that the second set of instructions under "Desktop version" worked. I tried the first set of instructions, but couldn't get passed step 1. Also, I reinstalled Chrome, but it still did not work. It took a while for Themler to reopen after I renamed the directory, but it worked. Thank you.
Rune
58 Posts
Rune posted this 2 weeks ago

It works... Untill login is required again.

It works... Untill login is required again.
Support Team
Support Team posted this 2 weeks ago

Hello,

Doesn't it work with log out and then log in again in Themler desktop or online?

Sincerely,
Nettie

Hello, Doesn't it work with log out and then log in again in Themler desktop or online? Sincerely, Nettie
Rune
58 Posts
Rune posted this 2 weeks ago

Sure. But next time login session are expired, the problem occurs again

Sure. But next time login session are expired, the problem occurs again
Support Team
Support Team posted this 1 weeks ago

Does it behave same in firefox?

Gina
Themler Support

Does it behave same in firefox? Gina Themler Support
me321
96 Posts
me321 posted this 1 weeks ago

I can confirm too that this happens each time the login session expires.

I can confirm too that this happens each time the login session expires.
Support Team
Support Team posted this 6 days ago

Please, test firefox and incognoto mode in Chrome.

Gina
Themler Support

Please, test firefox and incognoto mode in Chrome. Gina Themler Support
me321
96 Posts
me321 posted this 5 days ago

Hi Gina,

The problem is that when I close Themler, I am logged out each time. So I can never export or save a theme this way.

I only use Desktop (can't run it online, it doesn't work due to server permission issues) so I can't test other browsers than Chrome.

Also, as soon as I hit the Export button, it logs me out. The instruction above worked once but now it doesn't anymore.

Please advise on how to regain use of Themler again... Thanks.

Hi Gina, The problem is that when I close Themler, I am logged out each time. So I can never export or save a theme this way. I only use Desktop (can't run it online, it doesn't work due to server permission issues) so I can't test other browsers than Chrome. Also, as soon as I hit the Export button, it logs me out. The instruction above worked once but now it doesn't anymore. Please advise on how to regain use of Themler again... Thanks.
me321
96 Posts
me321 posted this 4 days ago

For anyone looking for a (temporary) solution: I decided to undo the latest Chrome update so I can regain use of Themler. It may not be recommended but if Themler is of strategic value to you, it will restore functionality if you're using Themler Desktop on Windows 10.

Here is a working instruction: https://www.reddit.com/r/chrome/comments/9hhdbr/can_i_downgrade_my_chrome_version/

Please note that the Chrome version from before this update, is now this one for 64bit: https://www.slimjet.com/chrome/download-chrome.php?file=files%2F79.0.3945.88%2FChromeStandaloneSetup64.exe and this one for 32bit: https://www.slimjet.com/chrome/download-chrome.php?file=files%2F79.0.3945.88%2FChromeStandaloneSetup.exe

After downgrading Themler will work again.

For anyone looking for a (temporary) solution: I decided to undo the latest Chrome update so I can regain use of Themler. It may not be recommended but if Themler is of strategic value to you, it will restore functionality if you're using Themler Desktop on Windows 10. Here is a working instruction: https://www.reddit.com/r/chrome/comments/9hhdbr/can_i_downgrade_my_chrome_version/ Please note that the Chrome version from before this update, is now this one for 64bit: https://www.slimjet.com/chrome/download-chrome.php?file=files%2F79.0.3945.88%2FChromeStandaloneSetup64.exe and this one for 32bit: https://www.slimjet.com/chrome/download-chrome.php?file=files%2F79.0.3945.88%2FChromeStandaloneSetup.exe After downgrading Themler will work again.
Support Team
Support Team posted this 2 days ago

I can confirm that the issue is related to new security policy in Chrome v80 or above.
We have released one more fix to our server two days ago, you can test it if you clear the cache as suggested in my original reply once again.

Gina
Themler Support

I can confirm that the issue is related to new security policy in Chrome v80 or above. We have released one more fix to our server two days ago, you can test it if you clear the cache as suggested in my original reply once again. Gina Themler Support
me321
96 Posts
me321 posted this yesterday

Hi,

This issue is still persisting. The login overlay keeps popping up, preventing the saving of themes.

I completely removed and re-installed Themler, I did the original steps again, to no avail.

I'm using Themler desktop.

Hi, This issue is still persisting. The login overlay keeps popping up, preventing the saving of themes. I completely removed and re-installed Themler, I did the original steps again, to no avail. I'm using Themler desktop.
me321
96 Posts
me321 posted this yesterday

I've now removed Chrome from my system, after reading a useful comment by peter80 here: https://answers.themler.io/questions/198358/themler-blinking-by-save-importet-wordpress-theme-not-save-possible.

This triggers Firefox (developer edition, in my case) to load Themler and then Themler works.

I've now removed Chrome from my system, after reading a useful comment by peter80 here: https://answers.themler.io/questions/198358/themler-blinking-by-save-importet-wordpress-theme-not-save-possible. This triggers Firefox (developer edition, in my case) to load Themler and then Themler works.
nmcfadden
17 Posts
nmcfadden posted this 20 hours ago

I signed out three days ago and today I signed back in and had no issues. Following these steps worked for me:

If you are using the Desktop version, then:
1) close Themler
2) open Windows Explorer and type %LocalAppData% in the address bar
3) find & rename Themler directory
4) start Themler again

I signed out three days ago and today I signed back in and had no issues. Following these steps worked for me: If you are using the Desktop version, then: 1) close Themler 2) open Windows Explorer and type %LocalAppData% in the address bar 3) find & rename Themler directory 4) start Themler again
You must log in or register to leave comments