Scrolling issue in Firefox browser

Support Team
Support Team posted this 05 May 2021

Since Firefox v.88 update there is an issue with scrolling in Firefox browser if Smooth Wheel is enabled in a theme. We recommend to disable Smooth Wheel for Firefox browser in Themler. For this please follow the steps below:

  1. Open the theme in Themler.
  2. Navigate the Home tab >> Settings.
  3. Smooth Wheel is disabled by default. If it is enabled, there is a cogwheel icon available (for settings).
  4. Click on the cogwheel icon to open the settings and choose Browsers >> Mozilla, then disable the option.
  5. Save the changes.

smooth-wheel.png

The issue can also happen if Parallax Background effect is active. You may need temporarily disabling this effect, for this please select the control in question, select Effects on the ribbon >> Parallax Background >> disable the effect.

Since Firefox v.88 update there is an issue with scrolling in Firefox browser if Smooth Wheel is enabled in a theme. We recommend to **disable Smooth Wheel for Firefox** browser in Themler. For this please follow the steps below: 1. Open the theme in Themler. 2. Navigate the **Home tab** >> **Settings**. 3. **Smooth Wheel** is disabled by default. If it is enabled, there is a cogwheel icon available (for settings). 4. Click on the **cogwheel icon** to open the settings and choose **Browsers** >> **Mozilla**, then **disable** the option. 5. Save the changes. !smooth-wheel.png! The issue can also happen if **Parallax Background** effect is active. You may need temporarily disabling this effect, for this please select the control in question, select **Effects** on the ribbon >> **Parallax Background** >> disable the effect.

Last edited 06 May 2021 by Support Team

Vote to pay developers attention to this features or issue.
6 Comments
Order By: Standard | Newest
tmgarrison
84 Posts
tmgarrison posted this 1 weeks ago

Hello,

So, you are saying that if I "redesign" the page, then everything is functioning correctly?

If I disable Parallax, that destroys the design of the home page. Furthermore, why not get the developers to fix what they broke?!
Is this a "temporary" issue that will be fixed in a few days? Or is this something that is going to take months? Or, is management simply stating that those who pay nearly $200 a year to use Themler will simply have to find another way to design?

I can understand if an update caused something that is "being" fixed. But to simply come up with methods to not use functions, or to have to hard-code files in Themler is not acceptable.

What is being done to fix the issue?

Hello, So, you are saying that if I "redesign" the page, then everything is functioning correctly? If I disable Parallax, that destroys the design of the home page. Furthermore, why not get the developers to fix what they broke?! Is this a "temporary" issue that will be fixed in a few days? Or is this something that is going to take months? Or, is management simply stating that those who pay nearly $200 a year to use Themler will simply have to find another way to design? I can understand if an update caused something that is "being" fixed. But to simply come up with methods to not use functions, or to have to hard-code files in Themler is not acceptable. What is being done to fix the issue?

Last edited 1 weeks ago by tmgarrison

Support Team
Support Team posted this 1 weeks ago

Hello,

As written in the article, unfortunately, "The issue can also happen if Parallax Background effect is active. You may need temporarily disabling this effect, for this please select the control in question, select Effects on the ribbon >> Parallax Background >> disable the effect."
Possibly this is the reason in your case.

Sincerely,
Nettie

Hello, As written in the article, unfortunately, "The issue can also happen if Parallax Background effect is active. You may need temporarily disabling this effect, for this please select the control in question, select Effects on the ribbon >> Parallax Background >> disable the effect." Possibly this is the reason in your case. Sincerely, Nettie
tmgarrison
84 Posts
tmgarrison posted this 1 weeks ago

Not so fast there Gina.

I just noticed today that there is that problem. I made sure the site is updated, found an update for Themler in the site (and this only happens on 1 site where I have Themler installed), saved, then tested.
The full page scroll with only a small touch of the mouse wheel happens no matter what I do.

To be more clear, in Themler, I have never enabled "Smooth Wheel" and it is NOT enabled in the site that is having the problem nor any of my other sites where I have Themler installed and updated. In fact, I've been quite busy on a project using Joomla with Themler and have had no problems.
The site with the issue is one that I have "not" logged into for several weeks - or longer. Yet, when I visited the site today the page scrolled a from top to bottom when I only scrolled the wheel 1 detent.

I'm using Joomla, not wordpress.

Now what?!

Thank you.

Not so fast there Gina. I just noticed today that there is that problem. I made sure the site is updated, found an update for Themler in the site (and this only happens on 1 site where I have Themler installed), saved, then tested. The full page scroll with only a small touch of the mouse wheel happens no matter what I do. To be more clear, in Themler, I have never enabled "Smooth Wheel" and it is NOT enabled in the site that is having the problem nor any of my other sites where I have Themler installed and updated. In fact, I've been quite busy on a project using Joomla with Themler and have had no problems. The site with the issue is one that I have "not" logged into for several weeks - or longer. Yet, when I visited the site today the page scrolled a from top to bottom when I only scrolled the wheel 1 detent. I'm using Joomla, not wordpress. Now what?! Thank you.
reiner6
15 Posts
reiner6 posted this 3 weeks ago

Thanks, this solution works great for me ...

Thanks, this solution works great for me ...
Support Team
Support Team posted this 4 weeks ago

Hello,

Another workaround would be to edit the script.js file (e.g. winscp).
Search for ... arrowscroll: 50, useOnWebKit: true, useOnMozilla: false, useOnIE: true} ....
and change useOnMozilla: true to useOnMozilla: false

Gina
Themler support

Hello, Another workaround would be to edit the script.js file (e.g. winscp). Search for ... arrowscroll: 50, useOnWebKit: true, useOnMozilla: false, useOnIE: true} .... and change `useOnMozilla: true` to `useOnMozilla: false` Gina Themler support
artur.dulian
23 Posts
artur.dulian posted this 20 May 2021

OK, I found better solution. Problem is located in jquery.js file (test on Wordpress), when I remove this:

jQuery.each( { scrollLeft: "pageXOffset", scrollTop: "pageYOffset" }, function( method, prop ) {
var top = /Y/.test( prop );

jQuery.fn[ method ] = function( val ) {
    return access( this, function( elem, method, val ) {
        var win = getWindow( elem );

        if ( val === undefined ) {
            return win ? (prop in win) ? win[ prop ] :
                win.document.documentElement[ method ] :
                elem[ method ];
        }

        if ( win ) {
            win.scrollTo(
                !top ? val : jQuery( win ).scrollLeft(),
                top ? val : jQuery( win ).scrollTop()
            );

        } else {
            elem[ method ] = val;
        }
    }, method, val, arguments.length, null );
};

});

Everything with scrool work fine on firefox 88, chears!

OK, I found better solution. Problem is located in jquery.js file (test on Wordpress), when I remove this: jQuery.each( { scrollLeft: "pageXOffset", scrollTop: "pageYOffset" }, function( method, prop ) { var top = /Y/.test( prop ); jQuery.fn[ method ] = function( val ) { return access( this, function( elem, method, val ) { var win = getWindow( elem ); if ( val === undefined ) { return win ? (prop in win) ? win[ prop ] : win.document.documentElement[ method ] : elem[ method ]; } if ( win ) { win.scrollTo( !top ? val : jQuery( win ).scrollLeft(), top ? val : jQuery( win ).scrollTop() ); } else { elem[ method ] = val; } }, method, val, arguments.length, null ); }; }); Everything with scrool work fine on firefox 88, chears!
You must log in or register to leave comments