Joomla 4 support and new version of Themler with Bootstrap 5

Vitaliy WD
428 Posts
Vitaliy WD posted this 3 weeks ago

Hello.

Since you gave us information, that you work hard on completely new blank theme for Joomla 4 as there need a major code rewriting.... I have a very important question that I asked here few times but not get clear answer.

Will be new Joomla 4 Themler theme based on new Bootstrap 5 (as Joomla 4 itself)?

Or we still get outdated Bootstrap 3 that was released 8 year ago?

For me is no reason to create new project with such old framework. At the end of 2021 is prefered to use Bootrap 5, clear JavaScript (no jQuery) and PHP8.

New Themler theme will be on:

  • Bootstrap 5
  • JavaScript (no jQuery)
  • PHP8

... or no?

Hello. Since you gave us information, that you work hard on completely new blank theme for Joomla 4 as there need a major code rewriting.... I have a very important question that I asked here few times but not get clear answer. Will be new Joomla 4 Themler theme based on new **Bootstrap 5** (as Joomla 4 itself)? ======================================================================== **Or we still get outdated Bootstrap 3 that was released 8 year ago?** For me is no reason to create new project with such old framework. At the end of 2021 is prefered to use Bootrap 5, clear JavaScript (no jQuery) and PHP8. New Themler theme will be on: - Bootstrap 5 - JavaScript (no jQuery) - PHP8 ... or no?

Last edited 3 weeks ago by Vitaliy WD

Vote to pay developers attention to this features or issue.
11 Comments
Order By: Standard | Newest
DaveOzric
931 Posts
DaveOzric posted this 3 weeks ago

Are you the captain of this sinking ship? Cause you are going to sink with it if you stay on board. There are other alternatives now. I'd move on and don't look back. Do you think after three years of zero updates that they are going to rewrite this thing from scratch? I am laughing out loud just thinking of this.

Are you the captain of this sinking ship? Cause you are going to sink with it if you stay on board. There are other alternatives now. I'd move on and don't look back. Do you think after three years of zero updates that they are going to rewrite this thing from scratch? I am laughing out loud just thinking of this.
Vitaliy WD
428 Posts
Vitaliy WD posted this 3 weeks ago

Are you the captain of this sinking ship? Cause you are going to sink with it if you stay on board. There are other alternatives now. I'd move on and don't look back. Do you think after three years of zero updates that they are going to rewrite this thing from scratch? I am laughing out loud just thinking of this.

Last years I'm already use other product. Sometimes combined with Themler, sometime no. I tried many builders, but Themler rocks for advanced customization.

If you are talking about Nicepage - it's a completely unusable product... more complicated than Themler but with less functionality.

Nearest Nicepage competitor is Gridbox, but as Nicepage it's too limited. There impossible to create even Language Switch dropdown menu or just to style normally main menu. No native multilanguage support as in Nicepage. Developers says that this is feature and vision of Gridox - make it as simple as possible, with many limits. So many things you just can't control without custom code.

So for very simple projects it's ok to use Nicepage or Grodbox... but not for serious work.

Fortunately last years give to Joomla community many other powerful builders. And some fresh and new updates for Joomla is coming. New version of the most popular Joomla builder currently in Alpha for J!4.

> Are you the captain of this sinking ship? Cause you are going to sink with it if you stay on board. There are other alternatives now. I'd move on and don't look back. Do you think after three years of zero updates that they are going to rewrite this thing from scratch? I am laughing out loud just thinking of this. Last years I'm already use other product. Sometimes combined with Themler, sometime no. I tried many builders, but Themler rocks for advanced customization. If you are talking about Nicepage - it's a completely unusable product... more complicated than Themler but with less functionality. Nearest Nicepage competitor is Gridbox, but as Nicepage it's too limited. There impossible to create even Language Switch dropdown menu or just to style normally main menu. No native multilanguage support as in Nicepage. Developers says that this is feature and vision of Gridox - make it as simple as possible, with many limits. So many things you just can't control without custom code. So for very simple projects it's ok to use Nicepage or Grodbox... but not for serious work. Fortunately last years give to Joomla community many other powerful builders. And some fresh and new updates for Joomla is coming. New version of the most popular Joomla builder currently in Alpha for J!4.

Last edited 3 weeks ago by Vitaliy WD

Support Team
Support Team posted this 2 weeks ago

Hello,

We understand that you want to know when Themler is ready to support Joomla 4. It is still in work. We will ask developers about the status and will update this and similar topics as soon as there are any news.

Sincerely,
Themler team

Hello, We understand that you want to know when Themler is ready to support Joomla 4. It is still in work. We will ask developers about the status and will update this and similar topics as soon as there are any news. Sincerely, Themler team
Support Team
Support Team posted this 2 weeks ago

Hello,

Our developers have reported that Joomla 4 support is awaited in around a month.
Thank you for your patience!

Sincerely,
Nettie

Hello, Our developers have reported that Joomla 4 support is awaited in around a month. Thank you for your patience! Sincerely, Nettie
Vitaliy WD
428 Posts
Vitaliy WD posted this 2 weeks ago

Hello, Nettie.

Thank you for answer, but the question is:

Will be new Joomla 4 Themler theme based on new Bootstrap 5 (as Joomla 4 itself)?
Or we still get outdated Bootstrap 3 that was released 8 year ago?

Please give an answer.

Hello, Nettie. Thank you for answer, but the question is: **Will be new Joomla 4 Themler theme based on new Bootstrap 5 (as Joomla 4 itself)?** Or we still get outdated Bootstrap 3 that was released 8 year ago? Please give an answer.
Support Team
Support Team posted this 5 days ago

Hello,

Themler doesn't support Bootstrap 5 at the moment, this concerns Themler for any CMS, including Joomla 4. Joomla 4 support will be added for the existing Themler edition based on Bootstrap 3.

Sincerely,
Nettie

Hello, Themler doesn't support Bootstrap 5 at the moment, this concerns Themler for any CMS, including Joomla 4. Joomla 4 support will be added for the existing Themler edition based on Bootstrap 3. Sincerely, Nettie
Scorpion Computers & Software
114 Posts
Scorpion Computers & Software posted this 4 days ago

Hello,

Themler doesn't support Bootstrap 5 at the moment, this concerns Themler for any CMS, including Joomla 4. Joomla 4 support will be added for the existing Themler edition based on Bootstrap 3.

Sincerely,
Nettie

Sorry Nettie, that is unacceptable. Bootstrap 3 is deprecated a while ago and we are using bootstrap 4 for a long time now. Bootstrap 5 is out and there have been time enough to implement it. I understand that it is not possible to convert or update old templates and themes, but the new clean base theme should be build on BS5

> Hello, > > Themler doesn't support Bootstrap 5 at the moment, this concerns Themler for any CMS, including Joomla 4. Joomla 4 support will be added for the existing Themler edition based on Bootstrap 3. > > Sincerely, > Nettie Sorry Nettie, that is unacceptable. Bootstrap 3 is deprecated a while ago and we are using bootstrap 4 for a long time now. Bootstrap 5 is out and there have been time enough to implement it. I understand that it is not possible to convert or update old templates and themes, but the new clean base theme should be build on BS5
Виктор
95 Posts
Виктор posted this 3 days ago

Добрый день, присоединяюсь, Themler нам нужен на Bootstrap 5.
Сейчас я склонен присматриваться к другому продукту, такому как [...], понимая, что Themler прогрессировать не будет.
Пользуясь также nicepage, я понял, что он хорош для HTML страниц, но не для Joomla.
Мне жаль, что Themler, не имеет будущего, очень жаль!

Добрый день, присоединяюсь, Themler нам нужен на Bootstrap 5. Сейчас я склонен присматриваться к другому продукту, такому как [...], понимая, что Themler прогрессировать не будет. Пользуясь также nicepage, я понял, что он хорош для HTML страниц, но не для Joomla. Мне жаль, что Themler, не имеет будущего, очень жаль!

Last edited 3 days ago by Support Team

Vitaliy WD
428 Posts
Vitaliy WD posted this 3 days ago

Same here. How we can told to clients that website will be on Bootstrap 3 in 2022?

From other side: most of extensions and Joomla itself use Bootstrap 5 so this framework will be loaded by default. What is the reason to load Bootstrap 3 + Bootstrap 5 same time?

Agreed with Victor, Nicepage good for HTML only.

How Themler team can comment situation with Bootstrap 3 in 2022?

Same here. How we can told to clients that website will be on Bootstrap 3 in 2022? From other side: most of extensions and Joomla itself use Bootstrap 5 so this framework will be loaded by default. What is the reason to load Bootstrap 3 + Bootstrap 5 same time? Agreed with Victor, Nicepage good for HTML only. How Themler team can comment situation with Bootstrap 3 in 2022?
pdg.design
167 Posts
pdg.design posted this 3 days ago

We are pay for this product every year, and I want to work with Themler many years in future, Please, upgrade it to 2022 version!

We are pay for this product every year, and I want to work with Themler many years in future, Please, upgrade it to 2022 version!
Vitaliy WD
428 Posts
Vitaliy WD posted this 3 days ago

I'm not renew my subscription last years just because Themler stopped development. But yes, some users pay each year for this product.

But I will (as many other I think) if Themler will be updated to meet 2022 requirements.

Let's see what Themler team will answer to his loyal customers who pay for Themler.

Please vote for this topic to pay developers attention.

I'm not renew my subscription last years just because Themler stopped development. But yes, some users pay each year for this product. But I will (as many other I think) if Themler will be updated to meet 2022 requirements. Let's see what Themler team will answer to his loyal customers who pay for Themler. *Please vote for this topic to pay developers attention.*
You must log in or register to leave comments