Themler J4: error 404 after copy j4 with template

matrix630307
118 Posts
matrix630307 posted this 2 weeks ago

Hi
I have made a fresh j4 installation on my web-account. Then i have load the beta j4-tehmler-template and i have made any changes.
Then i have made a Backup from all with akeeba and i have restored this on another client-account.
Then i have open the joomla to go to made other changes in the template. But after click on Edit Template, themler will load but i have an error 404 (see printscreen).

j4-template.jpg

On frentend, the template will work. But in Backend i cannot reach the template with themler for made changes.

When i install the "blank_themler_joomla4_theme.zip" the same result. No chance to work anything...

Hi I have made a fresh j4 installation on my web-account. Then i have load the beta j4-tehmler-template and i have made any changes. Then i have made a Backup from all with akeeba and i have restored this on another client-account. Then i have open the joomla to go to made other changes in the template. But after click on Edit Template, themler will load but i have an error 404 (see printscreen).!j4-template.jpg! On frentend, the template will work. But in Backend i cannot reach the template with themler for made changes. When i install the "blank_themler_joomla4_theme.zip" the same result. No chance to work anything...

Last edited 2 weeks ago by matrix630307

Vote to pay developers attention to this features or issue.
11 Comments
Order By: Standard | Newest
matrix630307
118 Posts
matrix630307 posted this 2 weeks ago

furter info - when i will import the template on themler desktop, this error will show:
Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in C:\ProgramData\Themler\hd_data\themler_1614773620\joomla\templates\themler00\app\index.php on line 34

furter info - when i will import the template on themler desktop, this error will show: Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in C:\ProgramData\Themler\hd_data\themler_1614773620\joomla\templates\themler00\app\index.php on line 34
Support Team
Support Team posted this 2 weeks ago

Hello,

Could you please try to manually set the Home item in Joomla admin?

Sincerely,
Nettie

Hello, Could you please try to manually set the Home item in Joomla admin? Sincerely, Nettie
matrix630307
118 Posts
matrix630307 posted this 2 weeks ago

Can you please tell me exactly, what i have where to do??

Can you please tell me exactly, what i have where to do??
matrix630307
118 Posts
matrix630307 posted this 2 weeks ago

I have made this:

home.jpg

But the same result - error 404.

I have made this: !home.jpg! But the same result - error 404.
matrix630307
118 Posts
matrix630307 posted this 2 weeks ago

You will have a admin-account?

You will have a admin-account?
Support Team
Support Team posted this 2 weeks ago

Hello,

I mean to set any menu item as website Front page or Home page. Then Refresh Content in Themler and navigate to various pages, then return to the Home page, it should have Home template.

Not sure if anything went wrong during transferring the site using akeeba. Did you try just exporting the theme from your initiall website and importing it anywhere - on your customer's website, for exmple?

As for Themler desktop - current local CMS installation in Themler has Joomla 3 only, because Joomla 4 is in Beta. Alternatively you may consider trying Joomla 4 on some localhost like xampp or denver, for example, for site development and testing purposes.

Sincerely,
Nettie

Hello, I mean to set any menu item as website Front page or Home page. Then Refresh Content in Themler and navigate to various pages, then return to the Home page, it should have Home template. Not sure if anything went wrong during transferring the site using akeeba. Did you try just exporting the theme from your initiall website and importing it anywhere - on your customer's website, for exmple? As for Themler desktop - current local CMS installation in Themler has Joomla 3 only, because Joomla 4 is in Beta. Alternatively you may consider trying Joomla 4 on some localhost like xampp or denver, for example, for site development and testing purposes. Sincerely, Nettie
matrix630307
118 Posts
matrix630307 posted this 1 weeks ago

Hi Nettie
No - it's not akeeba!!!
I have for example made a template with themler j4, then i have rename it as "themler00" and see there: error 404 (on same account / not another served with akeeba).

template-02.jpg

Then - i install the j4-untitled theme new - same thin: error 404
template-01.jpg

template-02.jpg

Result: i cannot made nothing more with themler on this installation self!!!!!!!

Hi Nettie No - it's not akeeba!!! I have for example made a template with themler j4, then i have rename it as "themler00" and see there: error 404 (on same account / not another served with akeeba). !template-02.jpg! Then - i install the j4-untitled theme new - same thin: error 404 !template-01.jpg! !template-02.jpg! Result: i cannot made nothing more with themler on this installation self!!!!!!!
matrix630307
118 Posts
matrix630307 posted this 1 weeks ago

Ahh - i found anything. The Problem is this - i have reported this:
https://answers.themler.io/questions/212768/themler-joomla-4-beta-menu-or-hmenu
When i made the Menumodule to "menu", i can now open themler j4 untitled template and the template "themler00".
But on this two template i have now the message:

menu.jpg

When i change the Modul on position "hmenu" - then i become again the error 404!!!
Please made a solution for this bug with "menu" and "hmenu"!!!! I have reported this for any time:
https://answers.themler.io/questions/212768/themler-joomla-4-beta-menu-or-hmen

Same Problem with "hmenu" and "menu" on the other website copy with akeeba.

Please please - made a solution for this great Bug!

Ahh - i found anything. The Problem is this - i have reported this: https://answers.themler.io/questions/212768/themler-joomla-4-beta-menu-or-hmenu When i made the Menumodule to "menu", i can now open themler j4 untitled template and the template "themler00". But on this two template i have now the message: !menu.jpg! When i change the Modul on position "hmenu" - then i become again the error 404!!! Please made a solution for this bug with "menu" and "hmenu"!!!! I have reported this for any time: https://answers.themler.io/questions/212768/themler-joomla-4-beta-menu-or-hmen Same Problem with "hmenu" and "menu" on the other website copy with akeeba. Please please - made a solution for this great Bug!

Last edited 1 weeks ago by matrix630307

Support Team
Support Team posted this 1 weeks ago

Hello,

Yes, thank you for details. We are investigating the menu issue and will continue communication on it in the initial topic about the menu.

Sincerely,
Nettie

Hello, Yes, thank you for details. We are investigating the menu issue and will continue communication on it in the initial topic about the menu. Sincerely, Nettie
matrix630307
118 Posts
matrix630307 posted this 1 weeks ago

Hi Nettie
Many thank's.
I hope - with active cooperation of users - can we bring themler back to life ... :)...

Hi Nettie Many thank's. I hope - with active cooperation of users - can we bring themler back to life ... :)...
Support Team
Support Team posted this 1 weeks ago

Hello,

Thank you for your kind words and for your input reparging Joomla 4 theme issues. The next theme version will include the fixes.

Sincerely,
Nettie

Hello, Thank you for your kind words and for your input reparging Joomla 4 theme issues. The next theme version will include the fixes. Sincerely, Nettie
You must log in or register to leave comments