How to disable linked images (lightbox?)

john.oxlade
19 Posts
john.oxlade posted this 19 August 2015

Probably me doing something simple (and wrong), but in my Joomla articles, clicking on images opens them in a lightbox - which I don't want. I want to be able to link the images, but the lightbox feature seems to take precedence.
How do I turn it off?
(I started with the default them/template and have been modifying it as I go)
Thanks.

Probably me doing something simple (and wrong), but in my Joomla articles, clicking on images opens them in a lightbox - which I don't want. I want to be able to link the images, but the lightbox feature seems to take precedence. How do I turn it off? (I started with the default them/template and have been modifying it as I go) Thanks.
Vote to pay developers attention to this features or issue.
53 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 18 September 2017

Hi,

OK, create a private case so we could review the settings. Issue happens on that exact page on your site that is opened in Themler?

Sincerely,
Hella

Hi, OK, create a private case so we could review the settings. Issue happens on that exact page on your site that is opened in Themler? Sincerely, Hella
john.oxlade
19 Posts
john.oxlade posted this 18 September 2017

Actually, I don't know what is going on but the Post Header styling isn't working either as it used to be white and now it has changed to a pale blue. It is almost as I an old template has been made the default but it is the latest one.

Actually, I don't know what is going on but the Post Header styling isn't working either as it used to be white and now it has changed to a pale blue. It is almost as I an old template has been made the default but it is the latest one.
Support Team
Support Team posted this 18 September 2017

john.oxlade,

You already reported this issue in another topic. We'll check it when you provide active access to the admin panel.

Thank you,
Olivia

john.oxlade, You already reported this issue in another topic. We'll check it when you provide active access to the admin panel. Thank you, Olivia
Koen
2 Posts
Koen posted this 19 January 2018

I managed to solve this. Hope this helps.

If you have tried the above and found it does not work, try the following:
1. Navigate to a 'Page' (not a post), within Themler,
2. Click on one of the images you are having problems with
3. Finally, choose 'Post Content' from the icons on the left control panel and turn off 'image Lightbox'

I trust you are having the same problem as me, as the previous suggestions did not work for me either, but this does.

I think this is either a bug, a process that is a little confusing in itself. Perhaps there should be a separate Lightbox control under Pages and Posts (assuming the process provided above by Support works for Posts - have not tried this yet as I am not using Posts). It is a bit of a shame that the control is all or nothing. Would be great if we could choose per page, or if a Shortcode could be used to activate this. Perhaps something for the next update maybe?

This worked perfectly! I never enabled this in the first place but somehow it was activated. I pointed blame towards a few extensions at first but after switching the template I saw that it was something caused here.

To clear things up, make sure you select 'Page' from the dropdown as Morpheus0101 mentioned. By default 'Post' under Blog Templates is selected instead of 'Page' under Main Templates.

![enter image description here][1]

From there you can select Posts then Post Content to get to the lightbox option. Mine was set to ON and this was why I was getting the automatic lightbox for EVERY image.

![enter image description here][2]

If you need the lightbox feature, there are tons of free plugins on JED (or you can use JS) that can do this outside of the template.

[1]: http://i.imgur.com/XuPzwN9.png
[2]: http://i.imgur.com/9ksgALW.png

This is working for me, thank you so much!

> > I managed to solve this. Hope this helps. > > > > If you have tried the above and found it does not work, try the following: > > 1. Navigate to a 'Page' (not a post), within Themler, > > 2. Click on one of the images you are having problems with > > 3. Finally, choose 'Post Content' from the icons on the left control panel and turn off 'image Lightbox' > > > > I trust you are having the same problem as me, as the previous suggestions did not work for me either, but this does. > > > > I think this is either a bug, a process that is a little confusing in itself. Perhaps there should be a separate Lightbox control under Pages and Posts (assuming the process provided above by Support works for Posts - have not tried this yet as I am not using Posts). It is a bit of a shame that the control is all or nothing. Would be great if we could choose per page, or if a Shortcode could be used to activate this. Perhaps something for the next update maybe? > > > > > > This worked perfectly! I never enabled this in the first place but somehow it was activated. I pointed blame towards a few extensions at first but after switching the template I saw that it was something caused here. > > To clear things up, make sure you select 'Page' from the dropdown as Morpheus0101 mentioned. By default 'Post' under Blog Templates is selected instead of 'Page' under Main Templates. > > ![enter image description here][1] > > > From there you can select Posts then Post Content to get to the lightbox option. Mine was set to ON and this was why I was getting the automatic lightbox for EVERY image. > > ![enter image description here][2] > > If you need the lightbox feature, there are tons of free plugins on JED (or you can use JS) that can do this outside of the template. > > > [1]: http://i.imgur.com/XuPzwN9.png > [2]: http://i.imgur.com/9ksgALW.png This is working for me, thank you so much!
leora
75 Posts
leora posted this 29 March 2018

Hi, can anyone find this in the latest version of themler?

Hi, can anyone find this in the latest version of themler?
Support Team
Support Team posted this 29 March 2018

Hi,

It's just the same Posts >> Posts Content >> Lightbox. Please provide screen shots showing if this option is not available for you.

Sincerely,
Hella

Hi, It's just the same Posts >> Posts Content >> Lightbox. Please provide screen shots showing if this option is not available for you. Sincerely, Hella
James85
2 Posts
James85 posted this 23 April 2018

in CSS add

.bd-lightbox { display: none !important; }

Work in wordpress

in CSS add .bd-lightbox { display: none !important; } Work in wordpress

Last edited 23 April 2018 by James85

info1204
4 Posts
info1204 posted this 03 April 2019

in CSS add

.bd-lightbox { display: none !important; }

Work in wordpress

Works in JOOMLA too

> in CSS add > > .bd-lightbox { display: none !important; } > > Work in wordpress Works in JOOMLA too
tmgarrison
80 Posts
tmgarrison posted this 21 August 2019

Hi all - It's August of 2019 and this issues is still a headache with Themler.

After going through everything, including the Post Content "and" Blog Content to assure that "Image Lightbox" is - in fact - disabled, I had a page where it was still enabled. I'm working in Joomla 3.9.10.

Using the instructions from Morpheus0101 (2015) found originally here - https://answers.themler.io/questions/21382/how-to-disable-linked-images-lightbox - I was able to traverse through the links to the one page (using "Ctrl + click-on-desired-link"), and when I got to the one image with the issue, I looked at the top of Themler and clicked on "Post Content" to find, "Image Lightbox" was enabled. I disabled it there and that took care of the problem.

Clearly when you disable Image Lightbox for Post Content, it does NOT disable it throughout the entire Themler system. Why? I have no idea...that's something support will have to answer.

It's such a small thing in Themler to disable that Image Lightbox as the default behavior that I'm surprised nobody has done that yet.
It's extremely time-consuming to have to run down such minor issues because they actually turn into large issues with visitors and clients.

Thanks.
Thomas

Hi all - It's August of 2019 and this issues is still a headache with Themler. After going through everything, including the Post Content "and" Blog Content to assure that "Image Lightbox" is - in fact - disabled, I had a page where it was still enabled. I'm working in Joomla 3.9.10. Using the instructions from Morpheus0101 (2015) found originally here - https://answers.themler.io/questions/21382/how-to-disable-linked-images-lightbox - I was able to traverse through the links to the one page (using "Ctrl + click-on-desired-link"), and when I got to the one image with the issue, I looked at the top of Themler and clicked on "Post Content" to find, "Image Lightbox" was enabled. I disabled it there and that took care of the problem. Clearly when you disable Image Lightbox for Post Content, it does NOT disable it throughout the entire Themler system. Why? I have no idea...that's something support will have to answer. It's such a small thing in Themler to disable that Image Lightbox as the default behavior that I'm surprised nobody has done that yet. It's extremely time-consuming to have to run down such minor issues because they actually turn into large issues with visitors and clients. Thanks. Thomas
Support Team
Support Team posted this 22 August 2019

Hello Thomas,

We see what you mean. There are however also many customers who would prefer Image Lightbox enabled - and that is the reason such option exists and is enabled by default.
The reason for the mentioned behaviour is most probably the following: Image Lightbox wasn't disabled on all templates - I mean, sometimes it is also needed to disable it on Page template, Default template, Home template by switching to the corresponding template in Themler and repeating the procedure.

Sincerely,
Nettie

Hello Thomas, We see what you mean. There are however also many customers who would prefer Image Lightbox enabled - and that is the reason such option exists and is enabled by default. The reason for the mentioned behaviour is most probably the following: Image Lightbox wasn't disabled on all templates - I mean, sometimes it is also needed to disable it on Page template, Default template, Home template by switching to the corresponding template in Themler and repeating the procedure. Sincerely, Nettie
websolution
7 Posts
websolution posted this 07 March 2020

How do you turn off lightbox for HTML websites?

How do you turn off lightbox for HTML websites?
Morpheus0101
25 Posts
Morpheus0101 posted this 17 November 2020

I am having the same issue. Can someone supply an example of how to access from version of Themler from this century:-)

Seriously, would appreciate it. Thanks.

I am having the same issue. Can someone supply an example of how to access from version of Themler from this century:-) Seriously, would appreciate it. Thanks.
Support Team
Support Team posted this 18 November 2020

Hello,

Please select the Posts control (you may also find it in the outline in the Left Sidebar or in the Path at the bottom), then go to the Posts tab and in Post Content disable the Image Lighbox. Please make sure to repeat this for every template you would like to disable the lightbox on (like Posts template, Blog template, Page template etc.).

Sincerely,
Nettie

Hello, Please select the Posts control (you may also find it in the outline in the Left Sidebar or in the Path at the bottom), then go to the Posts tab and in Post Content disable the Image Lighbox. Please make sure to repeat this for every template you would like to disable the lightbox on (like Posts template, Blog template, Page template etc.). Sincerely, Nettie
You must log in or register to leave comments