ERROR in Joomla 3.9.10.3 by using PHP 8

Bayern
127 Posts
Bayern posted this 28 November 2021

Themler doesn't work with PHP 8.0 in Joomla 3!

"Your site is currently using PHP 7.4.25. This version of PHP has entered its “Security maintenance” phase since Sunday, 28 November 2021 and has stopped receiving bug fixes. It will stop receiving security updates on Monday, 28 November 2022 at which point it will be unsuitable for use on a live site"

And now???

I have round about 70 Sites and cannot upgrade to Joomla 4 cause I would have to create a new template for each page

That means I need Joomla 3 until the bitter end of mid-2023 and Thanks to themler, this is only possible with a PHP version that no longer offer bug fixes.

people what the hell do you expect your customers, you could almost sue for damages

Themler doesn't work with PHP 8.0 in Joomla 3! "Your site is currently using PHP 7.4.25. This version of PHP has entered its “Security maintenance” phase since Sunday, 28 November 2021 and has stopped receiving bug fixes. It will stop receiving security updates on Monday, 28 November 2022 at which point it will be unsuitable for use on a live site" And now??? I have round about 70 Sites and cannot upgrade to Joomla 4 cause I would have to create a new template for each page That means I need Joomla 3 until the bitter end of mid-2023 and Thanks to themler, this is only possible with a PHP version that no longer offer bug fixes. people what the hell do you expect your customers, you could almost sue for damages

Last edited 28 November 2021 by Bayern

Vote to pay developers attention to this features or issue.
15 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 29 November 2021

Hello,

Could you please specify what error you get with PHP8 and on what step?

Sincerely,
Nettie

Hello, Could you please specify what error you get with PHP8 and on what step? Sincerely, Nettie
Bayern
127 Posts
Bayern posted this 29 November 2021

direct domain call

direct domain call

Last edited 29 November 2021 by Bayern

Support Team
Support Team posted this 29 November 2021

Just to confirm:
1. Your theme is updated to Themler v523 (at least)
2. When you switch to standard Joomla theme, it opens fine
3. You tried deactivating 3rd party extensions

Gina
Themler Support

Just to confirm: 1. Your theme is updated to Themler v523 (at least) 2. When you switch to standard Joomla theme, it opens fine 3. You tried deactivating 3rd party extensions Gina Themler Support
matrix630307
140 Posts
matrix630307 posted this 30 November 2021

Hi
My Hoster will change to php8 in december!!!
I have a lot of sites with joomla 3.10.x and themler no work with php8. When you have a solution for this problem??

Hi My Hoster will change to php8 in december!!! I have a lot of sites with joomla 3.10.x and themler no work with php8. When you have a solution for this problem??
marcin8
7 Posts
marcin8 posted this 01 December 2021

Hello, when using PHP 8.0.12 there is a bug on the page "0 - Unknown named parameter $ title".
Please help because I bought a license yesterday and I cannot use Themler :(

Hello, when using PHP 8.0.12 there is a bug on the page "0 - Unknown named parameter $ title". Please help because I bought a license yesterday and I cannot use Themler :(
marcin8
7 Posts
marcin8 posted this 01 December 2021

I am using the newest Themler v.544

I am using the newest Themler v.544
matrix630307
140 Posts
matrix630307 posted this 01 December 2021

I am using the newest Themler v.544

@marcin8:
hi
i be a user from themler since x years. at time, themler no work with php 8. themler is since any time at die. no chance to work with php 8 and joomla 4.x too. old bootstrap version (3) and many other bugs.

I see - you work with j 3.9. in this case, themler work - but not with php 8 (7.4 will work).

> I am using the newest Themler v.544 @marcin8: hi i be a user from themler since x years. at time, themler no work with php 8. themler is since any time at die. no chance to work with php 8 and joomla 4.x too. old bootstrap version (3) and many other bugs. I see - you work with j 3.9. in this case, themler work - but not with php 8 (7.4 will work).

Last edited 01 December 2021 by matrix630307

marcin8
7 Posts
marcin8 posted this 01 December 2021

Even the very old Artisteer works fine with PHP8 :(

Even the very old Artisteer works fine with PHP8 :(
matrix630307
140 Posts
matrix630307 posted this 01 December 2021

Even the very old Artisteer works fine with PHP8 :(

great!!!!!

> Even the very old Artisteer works fine with PHP8 :( great!!!!!
marcin8
7 Posts
marcin8 posted this 02 December 2021

I didn't think I would write this but I am proud of the developers that they adapted Themler for Joomla4 with PHP8 (works fine).
Better late than never :)
Another customization to make Joomla3 work with PHP8 and it will be fine.

I didn't think I would write this but I am proud of the developers that they adapted Themler for Joomla4 with PHP8 (works fine). Better late than never :) Another customization to make Joomla3 work with PHP8 and it will be fine.
matrix630307
140 Posts
matrix630307 posted this 02 December 2021

I didn't think I would write this but I am proud of the developers that they adapted Themler for Joomla4 with PHP8 (works fine).
Better late than never :)
Another customization to make Joomla3 work with PHP8 and it will be fine.

Yes, that's right. When j3 work with php8, then ok.
But all template can not transfer from j3 to j4!!! We must made all templates new!! That's terrible....

> I didn't think I would write this but I am proud of the developers that they adapted Themler for Joomla4 with PHP8 (works fine). > Better late than never :) > Another customization to make Joomla3 work with PHP8 and it will be fine. Yes, that's right. When j3 work with php8, then ok. But all template can not transfer from j3 to j4!!! We must made all templates new!! That's terrible....
marcin8
7 Posts
marcin8 posted this 02 December 2021

Oh yes! Creating them from scratch is a real massacre.

Oh yes! Creating them from scratch is a real massacre.
Bayern
127 Posts
Bayern posted this 02 December 2021

We absolutely need PHP 8 for Joomla so that we can upgrade in peace!

Even in Artisteer, it only took a single sign to get it going!

We absolutely need PHP 8 for Joomla so that we can upgrade in peace! Even in Artisteer, it only took a single sign to get it going!
Support Team
Support Team posted this 02 December 2021

Hello,

We have addressed the issue to our developers and will let you know as soon as there is any information.

Sincerely,
Nettie

Hello, We have addressed the issue to our developers and will let you know as soon as there is any information. Sincerely, Nettie
marcin8
7 Posts
marcin8 posted this 02 December 2021

"Support Team" - thank you for your interest in our not new problem with PHP8 and Joomla3 :)
Please also correct that in "Additional CSS" you can enter:

outside {

background-image: url ('../../images/picture.png');
}
Because it currently only works for the full path:

outside {

background-image: url ('https://www.abc.com/images/picture.png');
}

"Support Team" - thank you for your interest in our not new problem with PHP8 and Joomla3 :) Please also correct that in "Additional CSS" you can enter: #outside { background-image: url ('../../images/picture.png'); } Because it currently only works for the full path: #outside { background-image: url ('https://www.abc.com/images/picture.png'); }
You must log in or register to leave comments