Can only see the "template404" template in Themler

gaatec
48 Posts
gaatec posted this 29 September 2022

Hi there,
I have upgraded/migrated a Joomla 3 site to Joomla 4, and wanted to start recreating a template for the website.

I installed a themler template I had functiooning on another Joomla 4 website but on this website I simply cannot edit any of the templates.

In the list I only see "template404", and not any of the expected HOME, DEFAULT, PAGE or POST templates.

I If I click on "refresh content" within Themler, then I simply get a "500 Internal Server Error" with the following description:

ClassNotFoundError HTTP 500 Whoops, looks like something went wrong.
Attempted to load class "JApplication" from the global namespace.
Did you forget a "use" statement?

Any ideas?

Hi there, I have upgraded/migrated a Joomla 3 site to Joomla 4, and wanted to start recreating a template for the website. I installed a themler template I had functiooning on another Joomla 4 website but on this website I simply cannot edit any of the templates. In the list I only see "template404", and not any of the expected HOME, DEFAULT, PAGE or POST templates. I If I click on "refresh content" within Themler, then I simply get a "500 Internal Server Error" with the following description: ClassNotFoundError HTTP 500 Whoops, looks like something went wrong. Attempted to load class "JApplication" from the global namespace. Did you forget a "use" statement? Any ideas?
Vote to pay developers attention to this features or issue.
6 Comments
Order By: Standard | Newest
gaatec
48 Posts
gaatec posted this 29 September 2022

I have previously successfully upgraded 6 sites from J3 to J4, and this is the first multilingual site I upgraded.

Everything went well during the upgrade, but I simply cannot recreate the Themler Template as I only see a "template404" template within Themler.

Likewise, as soon as I activate the Themler template on the site, I am only seeing the 404 on the frontend as well.
When using the J4 standard template "Cassiopeia" the frontend work well.

I therefore tried to upgrade another J3 site which also was multilingual, and I get the exact same problem on that one. Themler simply do not work as I cannot add/edit templates within Themler.

Is Themler for J4 simply not compatible with multilingual sites?

I have previously successfully upgraded 6 sites from J3 to J4, and this is the first multilingual site I upgraded. Everything went well during the upgrade, but I simply cannot recreate the Themler Template as I only see a "template404" template within Themler. Likewise, as soon as I activate the Themler template on the site, I am only seeing the 404 on the frontend as well. When using the J4 standard template "Cassiopeia" the frontend work well. I therefore tried to upgrade another J3 site which also was multilingual, and I get the exact same problem on that one. Themler simply do not work as I cannot add/edit templates within Themler. Is Themler for J4 simply not compatible with multilingual sites?

Last edited 29 September 2022 by gaatec

Support Team
Support Team posted this 30 September 2022

Hello,

Looks like there is an issue with the language filter plugin enabled in Joomla 4. Is the issue present with this plugins disabled?

Sincerely,
Nettie

Hello, Looks like there is an issue with the language filter plugin enabled in Joomla 4. Is the issue present with this plugins disabled? Sincerely, Nettie
gaatec
48 Posts
gaatec posted this 02 October 2022

Hi again Nettie, and thanks a lot for getting back to me.

You are correct, if I disable the "System - Language Filter"before opening Themler, then I am able to see all templates.
I assume from that that there must be a problem with Themler not liking this.

I will do some more testing on my side to see if there are any more follow on problems on multilingual sites, but I guess you at least need to get that bug sorted.

Regards
Goran

Hello,

Looks like there is an issue with the language filter plugin enabled in Joomla 4. Is the issue present with this plugins disabled?

Sincerely,
Nettie

Hi again Nettie, and thanks a lot for getting back to me. You are correct, if I disable the "System - Language Filter"before opening Themler, then I am able to see all templates. I assume from that that there must be a problem with Themler not liking this. I will do some more testing on my side to see if there are any more follow on problems on multilingual sites, but I guess you at least need to get that bug sorted. Regards Goran > Hello, > > Looks like there is an issue with the language filter plugin enabled in Joomla 4. Is the issue present with this plugins disabled? > > Sincerely, > Nettie
Support Team
Support Team posted this 03 October 2022

Hello Goran,

Thanks for the deails. We have forwarded the issue to our developers. It shouldn't be present with Joomla 3 though (neither with PHP 7.x, nor with 8). Let us know if it is.

Sincerely,
Nettie

Hello Goran, Thanks for the deails. We have forwarded the issue to our developers. It shouldn't be present with Joomla 3 though (neither with PHP 7.x, nor with 8). Let us know if it is. Sincerely, Nettie
gaatec
48 Posts
gaatec posted this 03 October 2022

Hello Goran,

Thanks for the deails. We have forwarded the issue to our developers. It shouldn't be present with Joomla 3 though (neither with PHP 7.x, nor with 8). Let us know if it is.

Sincerely,
Nettie

You are correct Nettie,
This problem only appear once I have upgraded a site to Joomla 4. I have not experienced this on Joomla 3.

Regards
Goran

> Hello Goran, > > Thanks for the deails. We have forwarded the issue to our developers. It shouldn't be present with Joomla 3 though (neither with PHP 7.x, nor with 8). Let us know if it is. > > Sincerely, > Nettie You are correct Nettie, This problem only appear once I have upgraded a site to Joomla 4. I have not experienced this on Joomla 3. Regards Goran
Support Team
Support Team posted this 04 October 2022

Hello Goran,

Thanks for the additional information. We will let you know when there is an update with the fix is available.

Sincerely,
Nettie

Hello Goran, Thanks for the additional information. We will let you know when there is an update with the fix is available. Sincerely, Nettie
You must log in or register to leave comments