PHP update causes error

moordigital
21 Posts
moordigital posted this 16 February 2023

Hi Team Themler,

I am trying to update PHP version on a site and when I update to 8.0 or 8.1 (from 7.4) I get these errors - please advise.

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 291

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 291

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302

Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302

Many thanks in advance.

Angus

Hi Team Themler, I am trying to update PHP version on a site and when I update to 8.0 or 8.1 (from 7.4) I get these errors - please advise. Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 291 Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 291 Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302 Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302 Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302 Warning: Trying to access array offset on value of type null in /homepages/25/d790384314/htdocs/wp-content/plugins/themler-core/shortcodes/shortcodes-effects.php on line 302 Many thanks in advance. Angus
Vote to pay developers attention to this features or issue.
10 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 17 February 2023

Hello,

Could you please try to update Themler version first to the latest v.559?

Sincerely,
Nettie

Hello, Could you please try to update Themler version first to the latest v.559? Sincerely, Nettie
moordigital
21 Posts
moordigital posted this 19 February 2023

Hi Nettie,

Thanks for getting back to me - I updated Themler to the latest version before updating PHP version.

That said, my Themler Core plugin is showing as version 0.2.22

Hi Nettie, Thanks for getting back to me - I updated Themler to the latest version before updating PHP version. That said, my Themler Core plugin is showing as version 0.2.22
SH707
80 Posts
SH707 posted this 19 February 2023

i have the same problem with version 0.2.22

i have the same problem with version 0.2.22
Support Team
Support Team posted this 20 February 2023

Hello,

Could you please temporary switch to an older PHP version, open Themler theme and click Updates there? There the version should be 559.

Sincerely,
Nettie

Hello, Could you please temporary switch to an older PHP version, open Themler theme and click Updates there? There the version should be 559. Sincerely, Nettie
moordigital
21 Posts
moordigital posted this 21 February 2023

You bet - I currently have PHP version 7.4 but cannot see any option to update Themler?

You bet - I currently have PHP version 7.4 but cannot see any option to update Themler?
moordigital
21 Posts
moordigital posted this 4 weeks ago

Hi, is there any further progress on this issue please?

Hi, is there any further progress on this issue please?
Support Team
Support Team posted this 4 weeks ago

Hello,

What is the current Themler version for this theme? It can be checked in the top right corner in the Help section >> About.

Sincerely,
Nettie

Hello, What is the current Themler version for this theme? It can be checked in the top right corner in the Help section >> About. Sincerely, Nettie
moordigital
21 Posts
moordigital posted this 4 weeks ago

Hi Nettie,

It is showing Themler v.559

Hi Nettie, It is showing Themler v.559
Support Team
Support Team posted this 3 weeks ago

Hello,

This means the theme has already the latest version. Is the issue still reproducible if you now switch to PHP 8?

Sincerely,
Nettie

Hello, This means the theme has already the latest version. Is the issue still reproducible if you now switch to PHP 8? Sincerely, Nettie
moordigital
21 Posts
moordigital posted this 3 weeks ago

Looks like we are all good now. Many thanks.

Looks like we are all good now. Many thanks.
You must log in or register to leave comments