Themler has stopped working

haka81
15 Posts
haka81 posted this 07 December 2023

Hey. Themler has stopped working. It is not possible to modify any themes that I have made. The error message "0 - Class "Uri" not found" appears. I have tested on several Joomla4 sites. Everything was still working at the end of November. The old themes (559) seem to still work somehow, but there are problems too. All themes that have already been updated to newer ones can no longer be edited at all.

Hey. Themler has stopped working. It is not possible to modify any themes that I have made. The error message "0 - Class "Uri" not found" appears. I have tested on several Joomla4 sites. Everything was still working at the end of November. The old themes (559) seem to still work somehow, but there are problems too. All themes that have already been updated to newer ones can no longer be edited at all.

Last edited 07 December 2023 by haka81

Vote to pay developers attention to this features or issue.
15 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 07 December 2023

Hello,

We are sorry for the issue. Does the new default Themler theme v.570 for Joomla 4/5 from our website work for you?

Sincerely,
Nettie

Hello, We are sorry for the issue. Does the new default Themler theme v.570 for Joomla 4/5 from our website work for you? Sincerely, Nettie
haka81
15 Posts
haka81 posted this 07 December 2023

Hey. How do I update "v.570"? When you update the theme to the latest one, you update to version "ver=567". Or where can I download v.570 to test it?

Hey. How do I update "v.570"? When you update the theme to the latest one, you update to version "ver=567". Or where can I download v.570 to test it?

Last edited 07 December 2023 by haka81

haka81
15 Posts
haka81 posted this 07 December 2023

Hello,

We are sorry for the issue. Does the new default Themler theme v.570 for Joomla 4/5 from our website work for you?

Sincerely,
Nettie

Hey. How do I update "v.570"? When you update the theme to the latest one, it will update to version "ver=567". Or where can I download v.570 to test it?

> Hello, > > We are sorry for the issue. Does the new default Themler theme v.570 for Joomla 4/5 from our website work for you? > > Sincerely, > Nettie Hey. How do I update "v.570"? When you update the theme to the latest one, it will update to version "ver=567". Or where can I download v.570 to test it?
CHSNET
16 Posts
CHSNET posted this 07 December 2023

Themler version 570 does not fix the problem. I use Joomla 4 and Joomla 5 and on both versions Themler gives the error "0 - Class "Uri" not found". According to my investigations, Themler accesses old or no longer available information in the PHP versions

Themler version 570 does not fix the problem. I use Joomla 4 and Joomla 5 and on both versions Themler gives the error "0 - Class "Uri" not found". According to my investigations, Themler accesses old or no longer available information in the PHP versions
CHSNET
16 Posts
CHSNET posted this 08 December 2023

The problem is not caused by the browser. The problem appears to be due to incorrectly interpreted PHP code.

The problem is not caused by the browser. The problem appears to be due to incorrectly interpreted PHP code.
Support Team
Support Team posted this 15 December 2023

haka81, CHSNET,

Thank you for reporting the issue. Yes, v.570 is the latest at the moment. Just click on Updates(1) at the top in Themler to appy the update. Could you please specify if the issue is still actual and also:
- if you use default Themler theme for Joomla 4/5 fromour website in v.570?
- your current Joomla version on your website
- your PHP version
- at what stage does the error appear

Sincerely,
Nettie

haka81, CHSNET, Thank you for reporting the issue. Yes, v.570 is the latest at the moment. Just click on Updates(1) at the top in Themler to appy the update. Could you please specify if the issue is still actual and also: - if you use default Themler theme for Joomla 4/5 fromour website in v.570? - your current Joomla version on your website - your PHP version - at what stage does the error appear Sincerely, Nettie
CHSNET
16 Posts
CHSNET posted this 18 December 2023

Hallo Nettie,

ich nutze Joomla

v 4.4.1 - PHP 8.1 (das selbe unter 8.0+8.2)
v 5.0.1 - PHP 8.1 (das selbe unter 8.0+8.2)

Themler v570

Sobald ich die Breite einer Spalte verändere, oder wenn ich neue elemente einfüge erscheint der Fehler:"0 - Class "Uri"

Hallo Nettie, ich nutze Joomla v 4.4.1 - PHP 8.1 (das selbe unter 8.0+8.2) v 5.0.1 - PHP 8.1 (das selbe unter 8.0+8.2) Themler v570 Sobald ich die Breite einer Spalte verändere, oder wenn ich neue elemente einfüge erscheint der Fehler:"0 - Class "Uri"
CHSNET
16 Posts
CHSNET posted this 18 December 2023

I use Joomla

v 4.4.1 - PHP 8.1 (same under 8.0+8.2)
v 5.0.1 - PHP 8.1 (same under 8.0+8.2)

Themler v570

As soon as I change the width of a column or when I insert new elements, the error appears: "0 - Class "Uri"

I use Joomla v 4.4.1 - PHP 8.1 (same under 8.0+8.2) v 5.0.1 - PHP 8.1 (same under 8.0+8.2) Themler v570 As soon as I change the width of a column or when I insert new elements, the error appears: "0 - Class "Uri"
haka81
15 Posts
haka81 posted this 18 December 2023

I have testet Joomla 4.3.4, 4.4.1, 5.0.1

PHP 8.1

Themler : /index.php?option=com_templates&view=style&layout=edit&id=18&editor=1&theme=untitled&ver=567
There are no updates available, "1 update" does not appear in the upper right corner.

When you make changes to the theme, the error appears: "0 - Class "Uri"

I have testet Joomla 4.3.4, 4.4.1, 5.0.1 PHP 8.1 Themler : /index.php?option=com_templates&view=style&layout=edit&id=18&editor=1&theme=untitled&ver=567 There are no updates available, "1 update" does not appear in the upper right corner. When you make changes to the theme, the error appears: "0 - Class "Uri"
CHSNET
16 Posts
CHSNET posted this 18 December 2023

Among other things, new templates cannot be created under V570.
This is immediately acknowledged with an error message.

I also work with Themler v559, the version works so far, but for a long time (+1 year) there has been a message in the backend that overides are incorrect.

Among other things, new templates cannot be created under V570. This is immediately acknowledged with an error message. I also work with Themler v559, the version works so far, but for a long time (+1 year) there has been a message in the backend that overides are incorrect.
jeanmarcvieux
44 Posts
jeanmarcvieux posted this 03 January 2024

Hello,
From home then settings add in the field additionnal head html between PHP tag :
"<?php" use joomla\cms\factory; use joomla\cms\html\htmlhelper; use joomla\cms\language\text; use joomla\cms\uri\uri; "?>"
Just withdraw the quote around PHP tag.
You can add it even if the error is in the editor. Add the lines and save.

This fix work with Joomla 4.X and 5 with php 8.x
This fix work after publishing too.

Hello, From home then settings add in the field additionnal head html between PHP tag : "&lt;?php&quot; use joomla\cms\factory; use joomla\cms\html\htmlhelper; use joomla\cms\language\text; use joomla\cms\uri\uri; &quot;?&gt;" Just withdraw the quote around PHP tag. You can add it even if the error is in the editor. Add the lines and save. This fix work with Joomla 4.X and 5 with php 8.x This fix work after publishing too.
haka81
15 Posts
haka81 posted this 04 January 2024

Big thanks. That fixed the problem.

Big thanks. That fixed the problem.
iMZ
1 Posts
iMZ posted this 14 February 2024

Where I may download ver 570, I have only 567. Same errors. I am pissed off. What developers do ? 2 months and nothing fix ?????

Where I may download ver 570, I have only 567. Same errors. I am pissed off. What developers do ? 2 months and nothing fix ?????
CHSNET
16 Posts
CHSNET posted this 14 February 2024

The Version 570 dont fix the Bug.

The Version 570 dont fix the Bug.
KeiraSchurk
2 Posts
KeiraSchurk posted this 4 weeks ago

I want to download 570, but I can't find the download location.

I want to download 570, but I can't find the download location[.][1] [1]: https://janitorailogin.com/
You must log in or register to leave comments