Yoast SEO Title Name Repeated

DCND
23 Posts
DCND posted this 01 January 2015

Not sure if this is a bug or a setting. I have created 2 sites and I noticed when I use the plugin Yoast SEO for wordpress that the sitename gets appended twice at the end of the website title. I have 2 examples of Themler sites I am developing and noticed it. The only way I can get rid of it is by taking away the sitename in settings. I am also overriding the title in Yoast for the individual pages. I am not sure what is triggering it. What I have found is that you had to modify the header.php for normal themes, however I noticed in themler they are pretty complicated and did no know where to start.

http://www.dcnd.com/swl
http://www.vegasroaches.com

Both are examples. Also you will notice that for some reason on Vegasroaches if you go to the home page or contact page is is messed up with the title being appended at the end. But if you pull up the How To Information it is right. Both pages are using the frontpage template and changing it to Page template did nothing. Both are pages so and have similiar settings for Yoast so I am not sure.

I use Yoast with no problems in the past with other templates made in Artisteer so I am not sure what is going on. If you need access let me know.

Brian

Not sure if this is a bug or a setting. I have created 2 sites and I noticed when I use the plugin Yoast SEO for wordpress that the sitename gets appended twice at the end of the website title. I have 2 examples of Themler sites I am developing and noticed it. The only way I can get rid of it is by taking away the sitename in settings. I am also overriding the title in Yoast for the individual pages. I am not sure what is triggering it. What I have found is that you had to modify the header.php for normal themes, however I noticed in themler they are pretty complicated and did no know where to start. http://www.dcnd.com/swl http://www.vegasroaches.com Both are examples. Also you will notice that for some reason on Vegasroaches if you go to the home page or contact page is is messed up with the title being appended at the end. But if you pull up the How To Information it is right. Both pages are using the frontpage template and changing it to Page template did nothing. Both are pages so and have similiar settings for Yoast so I am not sure. I use Yoast with no problems in the past with other templates made in Artisteer so I am not sure what is going on. If you need access let me know. Brian

Last edited 08 January 2015 by Support Team

Vote to pay developers attention to this features or issue.
3 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 03 January 2015

Hi,

Have you switched to the default WP template? Does it give the same effect?
Also, you say:

What I have found is that you had to modify the header.php for normal themes, however I noticed in themler they are pretty complicated and did no know where to start.

So previously you have done some modifications in the WP templates? If that helps, you can provide the instructions here and we'll try to find out where it should be done in Themler themes.

Sincerely,
Hella
BillionDigital Team

Hi, Have you switched to the default WP template? Does it give the same effect? Also, you say: >What I have found is that you had to modify the header.php for normal themes, however I noticed in themler they are pretty complicated and did no know where to start. So previously you have done some modifications in the WP templates? If that helps, you can provide the instructions here and we'll try to find out where it should be done in Themler themes. Sincerely, Hella BillionDigital Team
DCND
23 Posts
Is Solution
DCND posted this 03 January 2015

Well I looked through and found that there is a setting in Yoast that I had to set. Under SEO->Titles&Meta

be sure to check "Force ReWrite Titles"

Even though by default Yoast will determine if it needs to be checked or not and it did not check mine, I had to. If I switched to a default theme and any non themler theme it still worked fine. I just had to check that box for my themler them.

Hopefully this will help anyone else. If you want to look into this more let me know I can help provide information.

If you want to make this public be my guest.

Well I looked through and found that there is a setting in Yoast that I had to set. Under SEO->Titles&Meta be sure to check "Force ReWrite Titles" Even though by default Yoast will determine if it needs to be checked or not and it did not check mine, I had to. If I switched to a default theme and any non themler theme it still worked fine. I just had to check that box for my themler them. Hopefully this will help anyone else. If you want to look into this more let me know I can help provide information. If you want to make this public be my guest.
Support Team
Support Team posted this 05 January 2015

Hello Brian,
so the issue is solved. If you need any further assistance please let us know.

I'm making this post public to share the solution with other users.

Regards,
Aileen

Hello Brian, so the issue is solved. If you need any further assistance please let us know. I'm making this post public to share the solution with other users. Regards, Aileen
You must log in or register to leave comments