Use iframe code on page?

caliray
33 Posts
caliray posted this 25 April 2016

Trying to add iframe code for an interacive image into a page. I added a text container, selected HTML as the type and pasted the iframe code into the container. After saving/publishing the theme and reviewing it, all I see is the HTML code, not the image.

Any suggestions how to do this correctly so the iframe displays the image?

Trying to add iframe code for an interacive image into a page. I added a text container, selected HTML as the type and pasted the iframe code into the container. After saving/publishing the theme and reviewing it, all I see is the HTML code, not the image. Any suggestions how to do this correctly so the iframe displays the image?
Vote to pay developers attention to this features or issue.
12 Comments
Order By: Standard | Newest
Support Team
Support Team posted this 26 April 2016

Hi,

Use the HTML control and not the Text control.

Sincerely,
Hella

Hi, Use the HTML control and not the Text control. Sincerely, Hella
Support Team
Support Team posted this 26 April 2016

Hi,

It depends on what layout you want to see. You can find the HTML control under the Insert >> More option.
I'm not sure that there is some exact documentation regarding your question. Here is all documentation that we have:
http://answers.themler.com/Doc/Index

Sincerely,
Hella

Hi, It depends on what layout you want to see. You can find the HTML control under the Insert >> More option. I'm not sure that there is some exact documentation regarding your question. Here is all documentation that we have: http://answers.themler.com/Doc/Index Sincerely, Hella
caliray
33 Posts
caliray posted this 26 April 2016

Thanks.

Thanks.
caliray
33 Posts
caliray posted this 26 April 2016

Is there no way to paste the HTML code into the section? Right click does not bring up an option choice like it does in a text section.

Is there no way to paste the HTML code into the section? Right click does not bring up an option choice like it does in a text section.
Support Team
Support Team posted this 26 April 2016

No, for the code insertion you need to use the appropriate content that will render the code correctly. The HTML control was made for that.

Sincerely,
Hella

No, for the code insertion you need to use the appropriate content that will render the code correctly. The HTML control was made for that. Sincerely, Hella
caliray
33 Posts
caliray posted this 26 April 2016

I don't understand the reasoning behind that. This is iframe code and quite long. Try to remember all of that and type it in without making a mistake when a simple paste operation would get it done correctly and in seconds.

I don't understand the reasoning behind that. This is iframe code and quite long. Try to remember all of that and type it in without making a mistake when a simple paste operation would get it done correctly and in seconds.
Support Team
Support Team posted this 26 April 2016

Hi,

Sorry, maybe I have misunderstood something. Why you need to type it? You can not paste it inside the HTML control? Not in the section.

Sincerely,
Hella

Hi, Sorry, maybe I have misunderstood something. Why you need to type it? You can not paste it inside the HTML control? Not in the section. Sincerely, Hella
caliray
33 Posts
caliray posted this 26 April 2016

I typed the iframe code in manually and, of course made few mistakes. Now when I correct them and use save and publish, the changes are not saved. It reverts back to the original code with the errors. That's exactly why a paste operation would be a lot more efficient.

This is the original iframe code<div style></div>

The code I entered into the HTML control window is displayed here
Unless I've not found all errors, after saving and publishing the theme and clearing my browser history, the iframe code is displayed as text, not the actual image that the code is supposed to display.

I typed the iframe code in manually and, of course made few mistakes. Now when I correct them and use save and publish, the changes are not saved. It reverts back to the original code with the errors. That's exactly why a paste operation would be a lot more efficient. This is the original iframe code`<div style></div>` The code I entered into the HTML control window is displayed [here][1] Unless I've not found all errors, after saving and publishing the theme and clearing my browser history, the iframe code is displayed as text, not the actual image that the code is supposed to display. [1]: http://www.texasregionalfishingguides.com/
caliray
33 Posts
caliray posted this 26 April 2016

I also checked the web page in another browser with the same result.

I also checked the web page in another browser with the same result.
Support Team
Support Team posted this 26 April 2016

Hi,

When you add the HTML control, please navigate to the HTML tab in the top bar and use the Edit HTML option, insert the code in the pop-up window. I have made it lie this and the iframe is working fine.

Sincerely,
Hella

Hi, When you add the HTML control, please navigate to the HTML tab in the top bar and use the Edit HTML option, insert the code in the pop-up window. I have made it lie this and the iframe is working fine. Sincerely, Hella
caliray
33 Posts
caliray posted this 26 April 2016

Thanks for the tip about the HTML edit window. That solved the problem.

Thanks for the tip about the HTML edit window. That solved the problem.
Support Team
Support Team posted this 28 April 2016

You are welcome. Feel free to contact us in any other occasion.

Sincerely,
Hella

You are welcome. Feel free to contact us in any other occasion. Sincerely, Hella
You must log in or register to leave comments